[Solved] MOD DUO not connecting to web (browser) interface (Windows 10 64bit)

So just running a W7 VM inside the W10 box works? It gets recognized as a network device with the correct driver? Or are you running the W7 VM in a different computer/OS?

Yes the W7 VM is running inside the same computer/OS.
Right now I´m running it on a Linux VM inside the same computer/OS.

On the W7 VM I needed to install the driver following the wiki troubleshooting but on the linux VM was a “plug and play” experience. :smiley:

an update on this topic…

I just got my USB Bluetooth dongle and installed the MOD Release 1.1.0 and now I can connect the MOD DUO with my Windows 10 64bit.
Unfortunately I did not have the time to look into a solution to solve the connection problem using the USB cable.

1 Like

Excellent @rogeriocouto that’s good news. Now you can enjoy it without any cable hassle!

Microsoft said that they are aware of the problems of the RNDIS USB network adapter in Windows 10, they are hoping to solve the problem. Once I get the answer to this problem, I will update you. Go2top, HP Support provide good driver for frim wire.

1 Like

If anyone is still interested on this, I solved it on my PC by deactivating and reactivating the ethernet driver/connection through the control panel.

Using the buletooth is not an option for me since my left knob isn’t clicking (and aparently no one cares)


Hi @adewaleandrade,

Thanks for sharing this solution.

Regarding your left knob, please send us a message to support@moddevices.com and we’ll open a support ticket straight away. Sorry for your trouble. I’m sure we’ll find a solution for you asap.

1 Like

Hi, first usage DUO X, using normally Roland stuff like SY1000.
Confused because of initial problem with connection with Windows.
My Win10 recognized DUO X as portable device and don’t allow me to choose any other driver.

Trie Bluetooth connection, in DUO X system enabled discovery, but DUO X with V1.9.1 is not discovered anyway.
Thank you for your help in advance

Got finally Bluetooth connectivity.
But seems for firmware upgrade the only way is USB connection.What information is provided from MOD DUO X to USB that WINDOWS COULD NOT RECOGNIZE IT CORRECT?

bluetooth is very slow, we purposefully do not allow to install system updates through it.

I expect a 10+ minute waiting time for the browser->device file send to take (the update files are around 90Mb in size)

1 Like

So my findings on the subject:

8 year old notebook (I7) with Windows 7: No connection possible despite the correct driver installation.

7 year old notebook (I7) with Ubuntu Studio 20 and corresponding drivers: No connection.

6 month old notebook (I7) with Windows 10: 5 out of 10 connection attempts fail. If there is a connection, it is stable.

1 day old High End Workstation (Xeon) with Windows 10: 19 out of 20 connection attempts fail. If there is a connection, it is quite unstable.

This seems to be a fundamental problem. I can still accept that it doesn’t work on older hardware. But with brand new hardware? Otherwise, I have never had a problem with USB devices on any of these PCs.

The problem may also only exist with certain lots. I ordered my MDX on 2020/10/18.


I have to correct my statement: I never had a problem with USB devices on these PCs. Unless the USB devices were defective. :wink:

Have you tried a different usb cable?

I’ve only used it on Linux, but 3 completely different computers (with different distro) it worked absolutely fine. (I am using manual commands to set the ip address though)


Oh yes. I even tested it with the super-expensive Elektron USB cables. :smiley:

Here it works with my 3 android tablet in bluetooth and a 7 years old bluetooth dongle, a 10 years old computer with I7 and W10, a 5 years old notebook with I7 and W10. It connect everytime, no issues. Sometimes it disconnect when I open many web browser pages…
So, am I a lucky guy?


It’s not just that I can’t reach the host, though. Even internally, communication doesn’t always seem to work properly:

This message is not from the browser. This is from the MDX web server, what seems to be Tornado.

This is another common mistake. Maybe a topic for support after all?

mailing support will likely end up with me writing something back to you anyway (via email instead of forum) so we can just keep the conversation here.
would be best to create separate topics next time though, as this one is already more than 4 years old…

anyway, as others have indicated here, this is not a common occurrence. so we need to go into steps to find out what is different/special about your unit and/or setup.

you are already running latest version, that is good.
so a few questions:

  • do you have any external gear connected to the unit?
  • are the plugins up to date?
  • are you using any beta plugin?
  • what pedalboard do you have the unit loading by default (on boot)?
  • do you have any external gear connected to the unit?
    Most times nothing. Sometimes a Keystep 32. Sometimes CV generators like an LFO.

  • are the plugins up to date?

  • are you using any beta plugin?

  • what pedalboard do you have the unit loading by default (on boot)?
    Always what I last edited.


The behavior is independent of the loaded board.

Incidentally, I also already had the problem that while I was dragging a plugin onto the board, the “Frontend” could no longer communicate with the “Backend”. Unfortunately I forgot the error message.

I have already opened a request (148) in the past because of another problem. Perhaps the information will also help.

But we don’t have to clarify this over Easter now. Everyone has the right to a few days off. :wink:

The problem solved itself. However, I can’t say what happened because I didn’t make any changes to the configuration or operating system or even installed any software (except Notepad++). Microsoft may have installed an update on the new PC yesterday which fixed the problem. I dont know. I haven’t had any problems since this morning.

And so far no more disconnections at all. So the MDX is fun again.

Thanks for your support.


I had a similar problem for a while on my Opensuse Desktop. After connecting the USB cable but I would not be able to connect to the Duo’s web interface. Solution was to run

 dhclient usb0

and refresh the settings. Have to do that approx. every 10th time I connect the Duo, but I do not reckon that it is a problem on the Duo side. Glad you got yours working properly again!

1 Like

In addition to Notepad++, I also installed a USB WiFi network adapter. I forgot about that. Perhaps these connection problems are also related to the network settings. If all USB devices, except one, work, you think that the cause can only be this device. I’m sorry for that…

Thanks for the tip, @eggsperde. When I have the time, I’ll have a look at it on the other computers.

1 Like