[Solved] MOD DUO not connecting to web (browser) interface (Windows 10 64bit)

Hello guys

I´m trying to connect the MOD DUO to the PC for the first time (Windows 10 pro 64bit).
The OS seems to recognize the device but no drive is mounted and I can´t connect to the device using google chrome.
Tried the troubleshooting guide at the wiki with no success.
Need help!

the mod duo will appear as mass storage device only when you are in the upgrade mode, for system upgrade purpose. However, this is no longer required for new versions.

mod duo works as network interface over USB when in normal operation.

Also check this thread: https://forum.moddevices.com/t/rndis-driver-for-windows-10

Thanks for the replay!

Now that I know that the mod will only appear as mass storage in the upgrade mode, I´ve changed the title to better reflect the problem!
The Mod Duo appears as Usb Serial Device (COM3)
When checking the properties the model shows “Duo Ethernet” and Category shows “Unknown”.
I did check the thread you mentioned but windows keep saying that the best driver is already installed.

Try forcing Windows to use the correct driver.
Run “devmgmt.msc” to open the device manager, then find the Duo Ethernet device and right click on it to update driver, then follow http://wiki.moddevices.com/wiki/Troubleshooting#Windows_7_or_Windows_10_64-bit

btw, does anyone has any idea why the same Windows version works so differently?
The PCs I experimented with all worked out of the box. Some user reports it doesn’t install any driver, and sometimes it installs the wrong one…

Hello Filipe,

I have tried following the troubleshooting steps but the MOD DUO is showing up in my system as a printer and not as a Network adapter therefore no option with the correct driver is shown to me.

Are you sure that specific device is the MOD?
If yes, then you can right-click it and select to update, then follow the instructions on the wiki to browse&select the correct driver.

Yes I´m sure it´s the MOD.
I can right-click, select to update but it´s not possible to follow the instructions on the wiki to select the correct driver.

I´ve connected the MOD to a really old HP Mini netbook running windows 7 starter edition and was able to follow the instructions on the wiki for the windows 10 32bit.
I downloaded the zip file and installed the driver.
On that system the MOD first appeared as an unknown device anfd after updating the driver it appeared as network device. I successfully connected to the web browser interface and updated the MOD firmware.
The only problem is that the HP Mni is not my computer.

Do you have a driver for the 64bit system like the one for the 32bit?
Maybe it´s possible to install it like did in the windows 7 starter edition.

Well, doesn’t hurt to try.

The thing about 64bit is that (I think) requires drivers to be signed.
I might be wrong, maybe it depends on the Windows version…

Sorry I didn´t understood.
Should I try to install on 64bit system the same custom driver you provided for the windows 10 32bit version?


Ok. I Tried to install it but it really need to be signed.

Hmmm that sucks…

With v1.1 we’ll have bluetooth working which, although being a little slow, it still works fine for normal usage (plus, wireless!).
Does your PC have bluetooth?
The MOD itself does not contain bluetooth, so you’ll need an extra bluetooth usb dongle.
This might be something that works for you.
If you’re interested I can push a beta build for you as soon as possible.

Yeah it sucks.
What are the prognosis for a windows 10 64bit signed driver?

I do have bluetooth on my PC but I don´t have a bluetooth dongle and I rather stick with the stable releases of firmware.

When I bought the MOD I really thought that I was going to have a “plug and play” experience and not being able to use out of the box was a bit frustrating.
As a workaround I installed the driver on a VM running windows 7 and it seems to be working fine.

I will try other systems running windows 10 64bit if I have a chance and let you know of the results.
In the mean time I´ll start learning how to use the MOD while waiting for a solution to this windows 10 64bit issue.


@rogeriocouto I use a Windows 10 64bit without issues. Plug and play it just fine.
Later today I will send screenshot and details about which driver my W10 picked up.

Thanks @acunha!

That will be great. Which language is your Windows 10 ?
Mine is PT-BR.

Mine is EN-US.

Here’s the ethernet driver details:

The device shows up as a Network Adapter under the Device Manager. One thing you might want to be sure is that you have the correct USB drivers installed for your computer. Make sure you go to your laptop company website and download the latest drivers and firmwares, specially a USB driver if any is available.

Here’s a link to the RNDIS driver directly from my computer:

Let me know how it goes.

the sys file is not useful here alone.
you also need other sys, inf and cat files.

as of right now I’m still not sure if Windows is just not listing the driver or if it doesn’t include the driver at all.

@rogeriocouto do you have an android phone? if yes, can you try enabling USB tethering please? (should be under extra network options).
The driver that windows uses for android phones usb-networking is the same that MOD needs.
So perhaps this way we can know if your windows install includes the driver or not.

Thanks! I will look into it but first I will follow @falkTX suggestion and try to find out if my system has the correct driver or not.

Hello @falkTX,

I Enabled the usb tethering on my android phone. Here are the results:

What should I do next?