MOD Duo Kickstarter Edition has problems with the 1.9.1 update

OK, something isn’t right still.

As already stated, with the ks-edition.tar.gz my Duo got up to blue LEDs. It then successfully took modduo-v1.9.1.1464.tar, switched to red LEDs, then several minutes later to green LEDs, then rebooted and…

“plug USB cable to PC”

hmm so we got one step closer, but something still not right…
would you be okay with figuring this out together in a live chat? There is a way to put the unit into SSH mode without modifying the contents, so we find out what is really going on.
Really want to make this work, and we are so so close…

Sure, I’m up to whatever helps.

Alright, I will PM you some details

1 Like

After the “duo-nand-mainline-factory-reset_ks-edition” script, I got the blue LEDs and the MODDUO drive on my Mac desktop.

That’s where I’m at now.

ok bad news, even with that the unit will not work.
there is 1 particular model we missed to implement support for.
I need to get hold of one of such units now…
really sorry for the trouble! :frowning:

in the mean time, let’s go with the fallback plan, so we get your units to work once again, just with the old kernel for now.
command-line instructions follow, macOS and Linux supported.


  1. download
  2. download and extract the zip file
  3. “cd” to the directory where the zip got extracted to
  4. run sudo ./bootfix -w /path/to/modduo-legacy-v1.9.1.1464-factory-image.raw
    (adjusting path as needed. use “bootfix.osx” if using a mac)

the deploy will take around 2 minutes. when done you need to repower the unit.
and once that is done, the unit will self-install, will take around 9 minutes. when you see green lights, repower the unit once again.


So, this did not work on my first attempt because the USB cable was still connected on the first power cycle of the unit.

But now, my Duo is up and running correctly :smiley:

Thank you falkTX for your guidance and patience in helping us resolve our current issue.


More on the side of 15 minutes in my case, but YES, these steps have my Duo up and running again. I never unplugged the USB cable in the process, but unlike @Simon managed to get through it just fine (could be the Debian vs. OS X question).

The whole thing should definitely make it into the upgrade instructions for the benefit of the few of us ‘lucky’ owners of this particular model.

1 Like

I’m thinking of updateing mine at the weekend (which I think was a kickstarter, my memories not great!), is there a way to tell if it is one that will have this issue?

Kinda. The steps are as follows:

  1. You make sure your Duo is not the modern eMMC one (that is, has no engraving over the right screen).
  2. You make a backup (via Settings -> Advanced) of your settings, because you’ll need it anyway.
  3. You follow the procedure described under “Special update image” section of this page.

The step where you’re supposed to see the blue LEDs is where you can tell that you have the “right” device. If the blue LEDs don’t come up after 15 minutes — yes, your device is subject to the issue. If they do, you just proceed with the procedure, your device isn’t one of them.

If the blue LED’s don’t ever (as in “20 minutes”) come up, you take a spare paperclip, unbend it, put it through the hole to push the FEL button for two seconds while you’re powering up your Duo, then follow the fallback procedure.

Restore the backup and you’re all done. :wink:


Nice one, thanks for all the help there.

I’ll give it a go and see how it goes…

Just updated my NAND unit here with the custom image - no problems, completed in several minutes end-to-end! I restored my pedalboards from backup and am back up rocking! Thanks so much MOD team! And thank you for fixing the snapshot MIDI nav bug when the web interface is up! :heart_eyes:


Mine doesn’t work anymore.

I have a MOD Duo NAND unit. I went through entire procedure successfully to update to 1.9.1 until the very end when I waited for it to have green leds and reboot. It is now just frozen and won’t do anything. It turns on and the 2 screens light up but that’s it. I can’t get it to do anything other than turn on. I’ve tried the procedure with the FEL manual deploy but I can’t make that work either.
I’m using Mac OS 10.15.1

Thanks in advance for any help with this.

Can you provide more detail? Did you run the full procedure and nothing changed? Did you encounter an error at any step? In case you’re on Catalina, you might bump up against the “helpful” new security measures: How to run bootloader or factory restore on MacOS Catalina

I did a backup of my data first to a thumb drive. Then I followed the instructions for the update via a special update image. All went exactly as described until the very last step which is “Wait until the MOD sets leds green and then reboots itself (this will take around 5 minutes)”

At that point nothing happened after waiting for 15-20 minutes. So I thought I had misunderstood the last step and that I needed to turn the unit off so that it would reboot. After I turned it off it will only show the opening graphics on the two displays when it is turned on and won’t go any further and show menus etc.

After I that I tried to do the MOD Duo Factory Reset. I was able to download the tar file that’s needed but had no success with the rest of the process. I’m not familiar with command line interfaces but thought I could use the Mac OS Terminal utility to run the factory reset.

I hope this gives you an idea of the problem.

@Jkick You’re correct in thinking you can use the Terminal utility. You can paste in the commands as described in step 5 of the restore to factory steps:

Assuming you’ve downloaded the image file and unzipped the archive (it should have prompted after downloading with this option, or you can double-click the file in Finder in your Downloads directory. When you have a directory called duo-nand-mainline-factory-reset in your Downloads directory, you can run the commands in your Terminal app:

  1. First paste in cd ~/Downloads/duo-nand-mainline-factory-reset (and hit Enter) which tells the Terminal to use that directory as the current working directory to work in.
  2. Then you paste in ./ (and hit Enter) which runs the restore operation. When the tool runs it will output a bunch of text that may appear as gibberish to you. If the tool encounters a problem you’ll see an “error” message in the output.

See also my link above if you’re on Catalina - you’ll have to jump through an extra hoop in the system security settings to allow the tool to run.

1 Like

OK. I did all that and it appears to have worked correctly. I’m now at the point where the unit is on and all the leds are blue. What’s next?

Connect unit to PC with usb cable, it will appear as mass storage device.
Download the duo image from and copy that file into the mass storage drive, then “eject” and unplug usb cable.
Wait until light turns green, the device will reboot itself after that

All done and updated now to 1.9.1. and everything appears to work correctly. If I want to restore my settings that I backed up to the thumb drive will that affect this update at all?