MOD Duo Kickstarter Edition has problems with the 1.9.1 update

Connect unit to PC with usb cable, it will appear as mass storage device.
Download the duo image from and copy that file into the mass storage drive, then “eject” and unplug usb cable.
Wait until light turns green, the device will reboot itself after that

All done and updated now to 1.9.1. and everything appears to work correctly. If I want to restore my settings that I backed up to the thumb drive will that affect this update at all?

the user-data partition does not affect the main system, so this is fine.

Thanks to you both for the help!

1 Like

My Mod Duo from 2nd Kickstarter also requires FEL update now.
Is there a chance to accomplish the described steps also somehow via WindowsPC? Or does exist a ready to use linux USB Stick image / live CD image to proceed?

I now tried 2,5 hours to make it work with Linux as describe - my result for now:

  • you can’t use LibreElec (I run a RasPi with Kodi at my home) for the bootfix - it seems to be incompatible, building it again with ‘make’ fails and seems to require even more steps and credentials…
  • you can’t use a Virtual Machine (Virtual box 6.1.2 on Win10 running a fresh virtual Ubuntu 20.04) - FEL update step 1 seems to work with the “tunneled” USB port of the MOD but after step 1 the USB connection seems to be reopened but now the USB can not be connected any more to the Virtual Machine. So I conclude that I need a native Linux directly running on the hardware…

Ideas are welcome. Currently I’m stuck.

On Windows you can use the LiveSuite application to flash the unit.

You mean I should upload the modduo-legacy-v1.9.1.1464-factory-image.raw via Live/Phoenix Suit?!
That program is only able to load *.img files.

Is it ok/required to rename the file from raw to img in order to load it into Live/Phoenix Suit?

isnt that an img file there? why does it need renaming?

Hi everyone,

I own a second kickstarter version of the Duo and would have liked to know if the update files and instructions have been updated to save me the pain these other users have been through when upgrading the firmware to 19.1.

Thanks for confirming

1 Like

I did those stops on a 2nd edition KS unit, all went fine.

So it turns out it is not exactly related to the batch series. Something else is at play here that makes some rare units not have a nand flash visible by the kernel. Hopefully I get my hands on one of those units soon.

1 Like

I hope I won’t be the one providing you with one of these :smile:

Thanks for your fantastic work anyway !

Could you let me know, how it went, @Azza? I am have a KS unit as well and are reluctant to change the kernel, too. Thanks! :slight_smile:

1 Like

Not done it yet, but be sure I will post about it :slight_smile:

Hi @Zenpoolzone , I noticed your message went unanswered in this thread. Did you manage to fix the problem on your unit? Do you still need help?

It worked perfectly ! :smiley:


My unit took the update well, too! Thanks for the feedback and the outstanding effort to keep the Duo up-to-date @falkTX and @gianfranco!


I forgot to tell how I fixed mine in the end:

I used the latest Ubuntu which I started in live mode from USB, downloaded the files and followed the steps as described above by @falkTX (MOD Duo Kickstarter Edition has problems with the 1.9.1 update).

My device is working now with the modduo-legacy-v1.9.1.1464-factory-image.raw

1 Like

I have a kickstarter MOD with NAND. I was able to install the 1.9.1 update by following the instructions MOD_Duo_Factory_Reset and Special update imageThe Mod booted to 1.9.1 which I checked using the Mod left button to bring up the menu, and did “System->Info->Versions”. This seemed fine, except I cannot access the Mod anymore at I tried rebooting, different USB ports, nothing worked. Then I did system update and was able to install which was again verified with “System->Info->Versions” on the Mod. However, I still cannot connect via web browser. Any suggestions?


With my DUO, if using a USB connection, the address is but if I use a Buetooth dongle, the address is