MOD Duo Kickstarter Edition has problems with the 1.9.1 update

In attempt to install the new awesome 1.9.1 on my Kickstarter Edition (second batch) MOD Duo I seem to have finally bricked the thing.

Following the recommendations I got up to the step where the device was supposed to reboot back to rescue mode after flashing that “special update file” so that I could flash the firmware itself. The device did reboot, but all it showed me after that reboot was “plug USB cable to PC” on the left screen. I did try plugging it to two different PCs, but nothing changed.

I tried the MOD Duo factory reset. The script worked OK, but the device’s LEDs never (as in “40 minutes later as opposed to a minute promised in the guide”) turned blue. If I try to power-cycle it, I’m greeted with “plug USB cable to PC” again.

So, a couple of hours into the upgrade attempt, all I get from my MOD Duo is “plug USB cable to PC”. I’m able to activate the FEL mode and even flash this file, but that gives no results.

Anybody out there with Kickstarter Editions — beware!

1 Like

It worked with my Mod Duo (Kickstarter Edition). I’ve unplugged it before. Because it said so in the instructions.

If you are able to get into restore mode, the device is surely not bricked.
The only way to really brick the Duo is to break its hardware. Software-wise it is always possible to deploy again via FEL.

We are here to help, let’s try to get this fully working.

What OS do you use? linux, macos or windows?

I am having the exact same situation.

Mod Support suggest I send the unit for servicing but seeing this thread here I will wait a bit to see if we can avoid that.

In my case, I am using MacOS Catalina 10.15.6 on a Mac Mini.
My Mod Duo’s serial number starts with MDS-20170811.

My current status is:

  • If I power on the unit while pressing the reset switch (little hole in the back), I get the MOD DUO logo and nothing else. Connecting the USB cable does not change this status and no “drive” appears on my computer.

  • If I simply power on the unit, I get “please Wait” in the left screen for a moment and then “plug the USB cable to PC” and nothing else. Connecting the USB cable does not change this status and no “drive” appears on my computer.


Ouch, read this a bit too late…
Having the same issue and symptoms.

Macbook Pro Mid-2015, os 10.14.6
Kickstarter Edition (second batch) MOD Duo

By the way, in the factory restore instructions, this is mentioned:

Now simply run:

…but that script is not in the downloaded folder; only came across ./

Would be awesome.

I’m on linux, Debian 10 to be exact (both my laptop and my desktop). I can borrow a Mac from my wife or fire up an ancient WinXP laptop if that’s necessary.

I have a Mac Mini with 10.15 as well, will test the procedure there later today.

What is the output of the factory-reset script? Any errors in there or is it all clean?

Good catch, a typo from our side, updated it in the wiki just now.


When I try to run the script from my Mac I get this: “ERROR: Allwinner USB FEL device not found!”

What is the output of the factory-reset script? Any errors in there or is it all clean?

for me, it seems to run fine - showing progress; ending with ::::all done…
unfortunately no blue LEDs as a reward!

That needs to be solved before the procedure actually starts.
The unit must be powered on while the “FEL” button is pressed, and the usb cable needs to be connected to the computer.
If this still fails, try a different usb port of the computer perhaps… it might not work with usb hubs or usb-type-c/thunderbolt adapters.

Should be fine on Linux. I find it odd that the deploy does not seem to be doing its job at all for you.
Because you say:

This means the deploy did not erase the flash, otherwise the power cycle should not get you into restore mode again…
Let’s try the alternative, please use a windows PC and deploy using the steps at

FWIW, here’s the script output:

$ sudo ./ 
100% [================================================] 21229 kB,  569.9 kB/s 
100% [================================================]     1 kB,  395.7 kB/s
Passing boot info via sunxi SPL: script address = 0x43100000, uEnv length = 0
100% [================================================]    69 kB,  569.3 kB/s
100% [================================================]    36 kB,  563.6 kB/s
100% [================================================]    29 kB,  564.7 kB/s
100% [================================================]    28 kB,  558.5 kB/s
100% [================================================]    29 kB,  566.1 kB/s
100% [================================================]   355 kB,  570.2 kB/s 
:::: all done

Will try, will report back.

Ok, I was using a USB Hub so I changed that now to direct USB port on the Mac Mini. (Maybe you should add a notice to this on the Wiki?)

Then, while the USB cable is connected on both ends, I held down the “FEL Button Pressed” and powered on the Duo.

Then tried to run the script and now it worked with this result:

100% [================================================] 21229 kB, 575.2 kB/s
100% [================================================] 1 kB, 462.2 kB/s
Passing boot info via sunxi SPL: script address = 0x43100000, uEnv length = 0
100% [================================================] 69 kB, 573.1 kB/s
100% [================================================] 36 kB, 567.6 kB/s
100% [================================================] 29 kB, 566.7 kB/s
100% [================================================] 28 kB, 568.4 kB/s
100% [================================================] 29 kB, 569.1 kB/s
100% [================================================] 355 kB, 574.8 kB/s
:::: all done

Waiting for the next steps now :slight_smile:

Same information as on the Wiki:


  1. After the script finishes, wait for around 1 minute and the MOD Duo will boot into recovery mode. (confirmed by LEDs turning blue. note that sometimes the display does not change )
  2. Download and install a MOD OS factory reset image.
  3. Wait for the installation to complete (the unit will restart automatically).

Note: You can find MOD factory reset images in the Factory Reset Images section.

Good point on the USB hub not being mentioned on the Wiki, will add that info now.

Fired up an XP laptop, gave it a try.

Got up to “Firmware Upload Successful”. No changes yet (5 minutes in) on the Duo itself, no blue LEDs, nothing.

Unfortunately, after the script completed, my Duo did not boot into recovery mode and the LEDs did not turn blue so I cannot continue with the normal steps yet.

Those are really really odd…
After 3 minutes the LEDs should really turn blue, indicating it booted itself in restore mode.

So I think an auto-detection of the unit type is failing, kernel boots thinking it is the new “2020” model and thus LEDs and USB do not work.
If that is really the case then the unit still boots fine after power off and power on. Can you confirm?

After you confirm this and if that is indeed the case (either unit booting into restore mode or regularly),
please try this tarball for deploying the system.
This one will force the unit type to be of the early kickstarter models

Define “boots fine”.

If showing logos temporarily, then blank screen on the right and “please wait” followed by “plug USB cable to PC” on the left is booting fine, then yes, sure.

Exact same here.

That is what I mean.

The script is supposed to zero out the flash completely. If the unit is still able to boot in some form, it means that part failed.
All I can think of is that the auto-detection is failing for some reason. so that is why I made that new tarball to try, as it will ignore the check and force the reset.

In the very worst case scenario, we can revert to using the old kernel for your units, at least temporarily.
But first let’s try to get this working if possible. Thanks

Of course, sending unit for repair so we do the procedure/investigation ourselves is also possible. But if we figure this one out, that will not be necessary in the end. We have tested the procedure with quite a few units before making it public, and as you can see even here from other users, some are able to deploy successfully. This must be some edge-case :frowning:

1 Like