USB network is not recognized, can't connect to GUI. PLEASE HELP!

I’m plugged directly into my 2020 Mac Mini USB from the Dwarf.
No MOD network shows up in the add service dialog in Network settings.
Ventura 13.6.6

it worked before but went down about 6 months ago. I followed all the troubleshooting steps and nothing works. I’m desperate.

Thank you!
Teddy Kumpel

Can you try to connect the dwarf with another Mac? And, more important, with another computer? Also a tablet with an otg adapter?

Have you tried a different cable?

on my 2012 Macbook pro “Dwarf Ethernet” shows up in the list (I previously had it connected to the macbook) but it reports that the device is not responding

tried another cable, same thing

i’m on the default setting for usb in setting behavior

I Just noticed that you already have an open thread on this issue. Please consider this one closed and focus on My Mac, Ventura OS, doesn't appear to be registering my Dwarf in the network - #18 by Simon

that’s not my thread.
I have discovered that the mod doesn’t show up on my laptop on Catalina either. So… must be something wrong with the mod.

The cable for Dwarf Ethernet 2 is connected, but your computer does not have an IP address.

thanks for your help everyone, hopefully I’ll get this sorted.

finally after much unplugging and replugging it appears to be working on my macbook. thanks

spoke too soon. I got into the GUI and it kicked me off within a minute and won’t let me back in. The Mod ethernet is showing in network with an

Could be a browser issue?

Try with Firefox or chrome?

are you making sure to use http:// rather than https:// ?

I’m using Chrome.

Yes. Http:// for local

Can you open a command line shell and issue

ping moddwarf.local


Can you try a different browser?


What is that supposed to do? Load the dwarf into the network settings?

How would I do that? In terminal?

Yes in terminal. It is needed to help diagnosing the problem.

It will try to reach the dwarf from its name or for its address.

If the address works and the name not it is a DNS issue

If also the name works it is a browser issue

If also the address fail it is a low level network issue. You could try to manually specify the IP for that port to check if it is a DHCP issue.

Otherwise it could be a driver problem or a dwarf setting problem, this is why I asked to try to connect to a different PC, possibly non apple and to verify the USB setting of the dwarf