Suggested bluetooth dongle

Asus usb B-400 work for me. Didn’t tryed bluetoothctl with ssh, but is it possible to add a device like Yamaha MDBT01 or Korg nano studio BT ? Done with my raspberry but dunno if on the modduo the bluetooth is fully installed ?

Just got that one

Works perfectly :smiley:

1 Like

Mine is this one

works great works great, has a blinking green led

EDIT : I also tried this one

still great, no blinking led

1 Like


This Avantree was the only one that worked for me. I tried CDR EDR 4.0 and it doesn’t work. The Mod Devices guys tried to help me, but to no avail.

I am communicating through two Samsung devices. An A8 phone and an old tablet worked without problems.

I thank the forum, especcialy Fish, for providing the information so that I can follow and achieve this result.

Bluetooth communication, despite being slower, will help me a lot.

1 Like


Did someone try this 5.0 dongle ?



1 Like

It seems that this is not working on my Dwarf.

hci0: RTL: firmware file rtl_bt/rtl8761b_fw.bin not found
1 Like

We don’t ship with such firmware files. there are far too many to collect and they would make the OS image 2x or 3x bigger, plus there are often very strict license requirements that do not allow us to ship with them anyway.
You can try to follow the same steps as per WiFi to get the firmware inside, see WiFi - MOD Wiki


Firmware loaded, now status is discoverable but I’m unable to connect with my android phone. I’m able to pair the mod (it asks for a pin which should be 0000) but I’m unable to establish a bluetooth connection for some unknown reasons.

EDIT: it works perfectly with my iPad


On Android from my experience you need to disable mobile data and WiFi before it accepts network connections through bluetooth.
Have you tried that?

1 Like

Yep, no luck :pensive:

Maybe this is related to the android version? Wondering if the feature just got removed completely, it was kinda hidden before anyway.
What version is your device running at? Any chance of trying an old phone or something that runs an older version?

Hello. I have the same problem with my Mod Duo X.
I tried different android phone and tablet.
I think something is broken between android and Mod Duo devices.

You say the Avantree works for you but what’s your device? A Mod Dwarf?

Just tested with an old android 4.4.2 tablet but still is not connecting. Pairing is ok but no connection.

Qucik question :-). Have you followed step 5 ( 5. As soon as your MOD device is paired, click on its settings and activate the “Internet access” through it ) of the bluetooth/android-wiki?

Btw. I’m also using the Avantree DG40S USB-Bluetoothdongle like Fish and it works fine.

1 Like

Yep, maybe the problem is related to the fact that my dongle is 5.0?

I tried the tp-link UB500, it does not work.

Kernel log looked ok, but the device was not discoverable. No connection possible. I found this post [[SOLVED]USB Bluetooth 5.0 tp-link UB500 / Kernel & Hardware / Arch Linux Forums]

It says that the UB is supported from kernel kernel 5.15.4-arch1-1

So I assume no chance to connect it to dwarf, or does anybody have an idea?

1 Like

BT5 seems to have less support.

I have a BT4 dongle and a BT5, only the BT4 works out of the box in my situation.

1 Like

@Shoomo are you trying to connect to macOS?

1 Like

I tried to connect with ipad, Windows PC and Android phone. The dwarf was not visible on any of these.

1 Like