[SOLVED] Hanging Dwarf

Dwarf froze, purple light on centre pedal, totally unresponsive, after between one hour and four one hour and eight minutes using this pedalboard Shaggy parallel bass with full control - MOD Devices

The sound was still coming through both channels, one clean and one with plugins. The GUI was still showing, but although I could delete items from it any changes made on the GUI were not made to the Dwarf. Solved with a reboot. Unfortunately I don’t remember exactly which plugins were active at the time, but I’ll listen to the recording (yes, I was in a session!) and see if I can identify what was being used. I was connected to the GUI using a Bluetooth dongle in the back of the Dwarf.

EDIT: Having listened to the recording I can say that the DS-1 distortion and the DxDigital Delay were both turned on. The signal path was passing through all four effect plugins, but the wah and the SubSynth were turned off. The path was not going from the subsyth to the delay, but straight to the mono dynamics, which as also turned on, and operating as a hard limiter at -12db.

How to reproduce

Nothing specific, I was not changing anything, it was the end of a song, I went to change settings and saw that the Dwarf was locked up.

Expected/suggested solution

Not to happen again! I don’t know if this was due to the Dwarf itself or one of the plugins, so the solution could be any number of things.

Additional information

Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the version.

  • release: V1.10.3.2360

Also provide some information about your system if possible.

  • Operating system: Windows
  • System version: 10 home, latest update

Hey Simon,
really sorry for the late reply. Your report was open on my browser for a while and I wanted to give you an answer, but time was not really on my side to understand your issue.

Thanks for reporting this. We were trying to figure it out, but unfortunately, it is very hard to figure out what went wrong exactly in your case.
Are you somehow able to find a somehow reliable way for us to trigger the problem? That would really help us out finding and fixing the bug.

On another note, update 1.11 (which we aim to have a release candidate for in the next weeks) has bug fixes for some issues causing controller lockups. These could potentially be related, but it is hard to say for sure.

1 Like

Hi Jon, no worries on the time, I know you guys are busy! I’ll try to reproduce and see if I can find a direct cause and let you know.


I had a similar issue yesterday. Sound still going through fine, but interface completely frozen. I hadn’t been playing for that long, it was just a few minutes after turning it on. If there’s anything I can do to help debug let me know.

Also on the Dwarf? Which OS version are you running there?

Hi Jon, I’ve just had another hang, this time using this pedal board Shaggy 4 bass out Version 2 - MOD Devices. The only active pedals were compression and wah. The amp sim and speaker sim were selected and on.

I set the board and selected the snapshot on the GUI using a bluetooth link and then closed the GUI and went to the Dwarf and hit the centre and right pedal to take it into selection mode. I then pressed the left pedal to go into snapshots and the Dwarf hung. CPU was around 60% and Ram around 40%. The Dwarf was still making the right noises, but I couldn’t do anything on it. Had to reboot to get it back to normal. It had been powered on for a good couple of hours, but that was the first time I had closed the GUI.


1 Like

Hi Simon,
Thanks for the report. We will try to reproduce it and check what is happening.

EDIT: I got an answer and, there are some bugs on navigation mode currently. Those bugs should all be fixed with the 1.11, so it’s a matter of time for it to get solved.


Thanks Jon, that makes sense - I was using yesterday and it hung another couple of times, both when I was moving between snapshots. I’ll wait for 1.11 - any rough ideas as to when it might make an appearance? I saw mention of RC versions elsewhere, so I’ll try those, if I can, when they are released.

We are doing what is supposed to be final testing this week.
Target date is early October for now, unless we find some last minute show-stoppers.


Just to add that I have experienced a number of hangs so far. Sometimes with very basic pedalboards, and some with much more complex stuff going on (I’ve got one in the database called PB&DrumsV2 which is the one that froze today)

It happens randomly, and it always “fails open” so besides a couple of crackles from the audio sometimes, it normally will just keep passing audio. The web UI continues to work, but the display and buttons on the Dwarf just completely stop responding. Today it occurred when I added the second looper into my design above.

It often happens if I’ve been making big changes on the pedal - but sometimes as an example I can just power it on with no PC connected, switch to navigation mode to select a pedal, and it will half-load a preset and then hang. Again when it does this it passes audio. It has no reflection on the complexity of the pedal, and the CPU is showing very low usage normally if it was to hang.

I’ve also had some cases where the web UI takes ages to load, or the Dwarf stops being recognised as a USB device. Power cycling the dwarf always fixes any of the above.

My concern is that it happens randomly - currently I don’t feel that I could rely on it for gigging, as I never have any indication that it’s frozen - so I can be halfway through a song and then just can’t control anything.

When it works it’s incredibly powerful, and I’m loving the workflow! But I just hope it can be made more stable. I’m happy to run tests or provide any information as requested. When it arrived with me it was running a firmware that doesn’t appear to be available on the Wiki (newer version of 1.10). On recommendation from one of your team I reflashed the unit with the newest 1.10 version that I could get from the Wiki. I’m hoping that 1.11 can fix some of this.

1 Like

I also had such phenomena. However, it was primarily plug-ins in the beta stage that caused the Dwarf to crash. However, the crashes usually appeared in the same form: The sound was there, the Dwarf was gone. After removing the beta plug-ins, it ran again as before.

Do you have any particular plugin that you are always using?
There are a bunch of random freezes that were happening with the device and aim to get solved with the 1.11.
Yet your issue is weird, I had that with my own device in the earliest days, but I guess it got fixed after a few updates since its not happening since a while (and I have been abusing on the hours that device is on since a while)

1 Like

I use Sooperlooper a lot - I’ve definitely has freezes after I’ve added this to the pedal. However, I’ve also had it happen in really basic setups, normally after I’ve had something big running and then have loaded a smaller pedalboard. I really wish I could give a bunch of steps that I do to cause this freeze as I appreciate that it’s near impossible to troubleshoot something with the info I’ve given so far.
Is there a way that I can obtain some sort of runlog from the device (SSH or whatever?) so I can maybe give you a better idea next time this happens?

maybe @falkTX can help us out on that.

For now, I would go on an intensive test with pedalboards using the SooperLooper and others not and check if it freezes more often with it.

I would say to retry with 1.11-RC1 which should be out in a few hours/minutes.
Mostly it is just about writing the release notes now.


Will you put the link to 1.11 RC1 here?

No, we will post it on the releases section as usual.

1 Like

Ah Okay, it’s my first RC for this system!


I shall await with excitement! I may have to wait until nearer the weekend to test it though…

1 Like

OK, I am running the RC. Mostly good, but I am still having the hanging issue. I have narrowed it down though. On my PB&DrumsV2 pedalboard, I’ve got 2 x Sooperloopers - play and record are on CV triggers, and the reset buttons i have separately on their own page, for each looper. If I tap Reset 1 and Reset 2 in quick succession, it normally freezes - dropping to purple light on footswitch b, screen is totally unresponsive, audio still passes, but device needs a complete reboot to start working again… It doesn’t happen every time, but most times for me…

1 Like