[SOLVED] Hanging Dwarf

Was this exact freeze happening already before?

It’s hard to say if this was the exact freeze - as it was freezing on very basic boards, often after switching boards. But I found the above is a good way to invoke a freeze on the box, and it will happen randomly, so it might work a bunch of times and then suddenly freeze without warning. If I can obtain any more info that would help I’d be happy to do so. The freezing is the only issue that I’ve discovered so far with the dwarf - otherwise the other functions work exactly as I’d hope/expect.

Hmm let’s wait for the new RC and after you try it let us know if this is still happening.

1 Like

Hi @sloedowncadet
I’ve seen you post before you deleted it, is it “solved” ?

@Rom I don’t know if the original problem reported by @shaggydog is solved, because there was not a clear reproducible case posted in this thread, and there was no response from the original poster that their problem was solved, even though something similar was reported by several users like @seaandsailor and @whosagoodwizard .

As I understand it though, this symptom of hanging (UI unresponsive, purple LED, audio still working) can have a number of different causes. Something was reportedly fixed in 1.11 , but my issue occurred with 1.12.0 . I described a recipe for hanging that was reproducible for me (see Problem with DWARF - #5 by sloedowncadet) which has been confirmed fixed in the latest 1.12.1


As the original poster I can say that I’ve not had any hangs recently, so I’m assuming whatever the problem was has been fixed in one of the updates as suggested (way back) by @jon