Release 1.6.0-RC1

Hi everyone, a major release is finally here - v1.6.0-RC aka “the return of the living dead”.

This release’s main focus is around the introduction of our commercial plugin store!
On top of that a few small additions will help alleviate some problems that we’ve been discussing around here.

Don’t forget this is a release candidate so please handle it with care.
We expect a testing period of just a few weeks.

Here are the goods:

  1. Plugin Store:
    At last we’re putting our mouth where the money is. No, wait!
    Ok, so I can’t talk much because soon we’ll have an official release with full details on this. For now what matters is we implemented the support to have commercial plugins in our plugin store. It includes the full purchase experience in one place. Before buying you can install the plugin as trial which produces degraded audio. Once you buy the license the audio will no longer be degraded.

  2. New implementation for pedalboard screenshot:
    We had a solution based on phantomjs which would do the headless browser thing on top of our html UI. Then phantomjs project retired completely. So that clearly wasn’t going to work. After some hard work we finally got a solution that is not just better but more consistent and a lot faster (up to 50% depending on the pedalboard). It has its perks though. The plugin images are always the same (the knob position doesn’t change). Also the final image sometimes is not exactly the same as the original pedalboard. But the results are definitely an improvement over what was there before. We hope you all enjoy it. If this goes well we will probably go back and re-render all pedalboards in our feeds.

  3. Renaming unstable → beta
    There was a large discussion about this here in the forum and we’re moving forward to change the (unloved) term “unstable”. From now on they are called “beta plugins”. The UI reflects that change.

  4. Sharing pedalboards with beta plugins is enabled:
    If your pedalboard includes a unstable beta plugin you can now share it to the public feed. There will be a specific filter in the pedalboard page (not yet visible - only when we get out of RC) and then some warnings along the way. But it’s totally possible now and officially supported. Only users that have beta plugins enabled will be able to install them.

  5. Settings button
    Settings already existed but you had to know how to load it by hand and you had also to go back to it by hand. It was time to promote the settings screen to be part of the official UI. At the bottom right you’ll see an gear icon. Several advanced options are available which have tons of explaining in the page itself.

  6. Display brightness control menu option
    This has been a request for quite some time and it is finally here. It is now possible to dimmer down the backlights of the MOD Duo displays. Simply go to the Settings - long-press of Knob 1 - and adjust it to your wishes.

  7. Minors:
    There are a few minors. Here they are:

  • added settings button to bottom menu
  • improve encoders usability
  • bugfix when switching pb’s with a footswitch and scrolling through other banks at the same time (edited)
  • added ‘featured’ section to plugin store
  • fixed plugin version format to avoid confusion
  • fixed bug where tab tempo input text was cut off

This has been longer than usual but I hope you all enjoy. We encourage you to provide your feedback, good or bad. Enjoy!

Because this release is still under testing, it won’t appear as an update in the web interface just yet.
You’ll have to manually download and apply the update file if you wish to try it out.
(Release testers, also known as ‘group 1’, will receive this update as usual)

Here’s the manual download link:

The upgrade procedure is explained at the top of our releases page, here:


So I’ve installed 1.6.0-RC1.

Download and install process run smooth.
So far I haven’t any issue during testing.
The issue with 3.way controllers seems to be solved.

Only drawback I could see, is, that I had hoped that the padelboard share button re-appear on my screen, but it doesn’t. According to the web-inspector it still is hidden. :frowning_face:

In the plugin store there is now a Featured Plugins space on top, which is empty for now. Do you plan to put there something like “plug of the month”? When empty, the space in use is a bit to big for my taste.

I see that commercial plugins been listed between the stable ones, wouldn’t it be better to have a button for them, to list them explicit ( show commercial plugins (only)), when explore the shop?

That will make it a bit easier to find them, and check what’s new in the store.

Otherwise, great work, thanks for this.


1 Like

great news! I’ve got too much critical use going on at the moment to install potentially unstable software, but really glad to see this appear, and very much looking forward to the fully tested release (and a huge thanks to everyone doing to early-adopter beta testing. :slight_smile: )

@brummer check your ad-blocking plugins. Mine was removing the sharing button (for whatever reason). Once I turned it off the button was back.

@brummer Also, regarding the featured section. It’s already populated, I wonder if you need a hard-refresh on your screen? Can you try and let me know?


Indeed, it’s the addblocker. I’ve disabled it for modduo.local now, and the share button appear. :grinning:
Also the featured plugin section is filled now, and it looks good so far. Good work. :+1:

@acunha by the way, I could make the share button appear and work, as well, by renaming the button class to “.js-share” note the dot. only the icon wouldn’t be drawn then. Maybe that helps to find out why addblock believe it’s addon.
All together addblock reports 4 addons for the site.

1 Like

So I give the trail a whirl, now, I like to remove it, unfortunately the remove button is missing on commercial plugs. This should be possible, special for trail versions.

How can I get this update? The MOD here says “system is up to date” and this announcement does not have a download link like previous announcements had.

That’s hell of a way to get rid of release-critical bugs :slight_smile: nice Freudian slip. It should read “unstable -> beta”.

While speaking of typos, “-rc” is usually always lower-case in version numbers or tags.

1 Like

Install success, will kick the tires this weekend. Congrats MOD team, it’s nice to have activity in this channel again!

1 Like

The display dimming is a nice addition, I don’t need the backlight a lot of the time.

A few times while on the Store view the UI has become unresponsive and Chrome will display the Wait/Kill dialog.


I just installed 1.6.0-RC1. This works without any problems. After installation I tried to update my plugins.

The first (small) problem encountered when opening the plugins store: “Our commercial plugin store is offline now, sorry for the inconvenience”.

Ok, I selected “Installed only” and “Show beta plugins”. After that I tried “Update All” which responses with “All plugins are updated, nothing to do”. But this is not true… there are several plugins marked as “New version”. I will update them one by one…

Next I created a pedalboard with Dexed and checked if long preset lists (e.g. from Dexed) can be assigned to a knob (see Limitation for preset assignment to a MOD-Display?). This seems not to be working yet. If I use “ASSIGN ALL” to Knob-1 I am only getting the first 36 user presets. But there are 64 user presets and some more factory presets. For the synths there are mostly very much presets, so a way how to select them with the knobs is IMHO a must have :wink:

Now I will get my guitar and will have some fun to make some noise for my neighborhood :slight_smile:

Regards, Holger

1 Like

I’ve added the manual download link in the post.

1 Like

Thank you. /me updates.

I ran into the similar issues. ublock-origin blocks “shopify” and worse: eff’s privacy-badger blocks “failed to connect to the MOD cloud”.

The 1.5 release does not have this issue.


So now there is a uninstall button for the trail version, I uninstal it and receive a message

“couldn’t uninstall plugin”

but, as far I could see, the uninstall was successful.

Can you please confirm you’re still having this? Did you try a different browser?
If possible can you revert back to 1.5 and see if that is an exclusive problem with 1.6 ?