Release 1.12.1

Hello everyone, a bugfix update for the 1.12 series is here - v1.12.1 aka “the second best time is now”.

This update fixes an important bug (but somehow only now discovered) where the Dwarf would crash when browsing snapshots right after boot.
It also allows to load remote pedalboards outside of the pedalboard feed, needed for something interesting that is coming soon…

Hope you enjoy :slight_smile:

Here’s the full changelog:

  • add hysteresis to internal noise-gate
  • allow loading remote pedalboards with full URL
  • fix addressing multiple instances of AudioToCVPitch plugin CV ports
  • fix value for options sampleRate parameter (continuation of fix from 1.12.0)
  • handle web browser cut events on searchboxes

Dwarf specific changes:

  • fix device crash when browsing snapshots right after boot

The next time you open the MOD web interface you’ll receive an update notification.
Just click on the tooltip icon in the bottom-right when that happens, then ‘Download’ and finally ‘Upgrade Now’.
Wait for a few minutes while the MOD updates itself automatically.

We hope you’re enjoying your MOD unit.
Let us know if you find any issues.


Hello all!
Curious detail regarding the update, for a while (long while) my screens on the Mod Duo X have been dark. But during the update the lit up like a Xmas tree! Bur alas, after the update was finished the returned to their darkened state. This does not really bother me as long as I know the Mod works properly but I would appreciate an explanation/solution for this
Be well all.

1 Like

That would just be the display brightness. You can configure it in the Duo X device settings.

On the final stage of the update process, the device-side controller firmware is updated too which lights up the screens fully while that happens.
All as expected.


No, sorry. That is not it. Tried that before. Now the brightness is set to 75 percent and still utterly dark…

1 Like

Then contact support about it please, via should work, @jon is the one that will assist you (in due time, everyone is busy in the office at the moment packing up the dwarfs)


How many minutes is “a few” minutes? Mine’s been going for over 15 minutes at this point. Looks like I’m going to be having the same updating problems I did before…

1 Like

Here on my DuoX it takes:

  • 20 seconds to download the update
  • 30 seconds to check the file
  • a minute to install the system
  • a minute to update the controller/HMI
  • 10 seconds to restart the device

So say 3-10 minutes depending on your internet connection?

1 Like

that jibes with my experience on a Dwarf

Since I did the update, pressing B and C gives me the snapshot selection and ot the pedalboard selection. I do not know how to change pedalboards now except via pc when connected.

Is this a bug or expected behaviour?
if expected, how do I browse pedalboards now?


I find that it goes to snapshots now, too. if you tap the lonely button on the far left of the Dwarf, it switches to pedalboards.


Sadly, my experience with updating the Dwarf is that mine won’t. I’ve eventually gotten it to update but it always is an ordeal. Evidently, it looks like it’s going to be that way this time as well. It stays stuck in the “I’m updating now” mode but rarely completes the process.

1 Like

What’s your environment like? OS? USB hub or direct connect? Browser?

I have used:
Microsoft Edge

Win10 Pro

all directly via USB - no hub.

1 Like

well, that’s pretty exhaustive :slight_smile:

The tester in me wonders if you’ve tried different computers (sounds like you have), and different USB cables (to cover all the bases)

1 Like

Issue is likely something wrong with the restore partition making it unable to enter recovery/update mode.

If you hold down the left knob and button while powering on the dwarf, does it enter recovery mode or does it still boot up normally?


I’ll check on that later - heading to work now.

I didn’t mention that this has been such an issue that I actually sent my Dwarf back to MOD for them to check. Of course, they had no problem with it. :frowning:

1 Like

Okay - I’m finally home.

I did what you asked - it boots up normally.


I have a bit of an issue I was hoping this update would fix. During the previous update, my duo x became unresponsive after my laptop indicated that the update was complete. The device was still looking like it was updating and/or stuck in that mode. So I did what I know I shouldn’t have and turned it off. It came back up normally and indicated that it was on the new update. However, none of the pedalboards or anything else made the sound change. It was like it was in permanent bypass mode. I did a manual update after downloading the file. It finished properly, but still no effects. I got busy with he holidays, so today I noticed there was another update. I completed the update and it finished fine with a reboot. Still in bypass. I can’t figure out how to fix it. I also unplugged everything else except the duo x, which is plugged straight into my PA. Lights indicate a signal is being received. I also have the audio file player and the indicators show the audio file is progressing forward, but that doesn’t make any sound either. Any help would be greatly appreciated.


1 Like

@Bruce_McLEAN, I would suggest you to write me at
Please include the serial number of your MOD Duo X and eventually a video showcasing the issues.

One thing and one question that quickly comes to my mind:

  • Do the new updates successfully install?
  • For sure you don’t have the Hardware Bypass on in the device settings, right?