Release 1.11

Hi there everyone, the stable release of v1.11 is here - v1.11.0 aka “You didn’t come here to make the choice, you’ve already made it”.

This release is mainly focused on the Dwarf, but the rework and improvements (see below) are made available to the other units too.
A few of the new controller features are exclusive to the Dwarf on this release.
The list of new features was posted on the 1.11.0-RC1 announcement, but let’s go through them again.

(Virtual) MIDI Loopback

Coming from a request by our community in this release we have added a “Virtual MIDI Loopback”,
basically a way to feed back MIDI generated by plugins back into the system input.
The main idea being that, through the use of MIDI learn, MIDI output from plugins can be used to change/modulate other plugins parameters.

Previously the community resorted to hardware loopback solutions (MIDI DIN in & out connected together), this feature removes the need for such tricks.

To enable it simply click the “MIDI PORTS” button on the web gui, tick the new “Virtual MIDI Loopback” option and click Save.
This setting will be saved on a per-pedalboard basis.



Snapshots rework, now always on

Stability and reliability are important to us, so in this release we have reworked some core elements that either didn’t always work right or got users confused.
One of such elements are pedalboard snapshots, which we have now decided to make always on.

Previously depending if you had snapshots enabled or not on your pedalboard, the way that plugin state was saved worked differently.
When a pedalboard was loaded with snapshots enabled, the first snapshot and its corresponding plugin parameter values were the ones that got loaded.

Now starting with v1.11, snapshots will always be enabled.
To make things easy for users, the state of the pedalboard that is saved will match exactly the state it is currently on.
So if you were on snapshot #3, changed a few parameters differently from what the snapshot has set and then saved, this same state is what gets restored.
You will be on the same snapshot #3 with the same parameter values exactly as before.


See documentation button on plugin info dialog

As the plugins grow in complexity, we found the need to provide more extensive user documentation besides just the plugin description.
If the plugin developers so choose, they can now ship with a pdf file for documentation and a button will appear on the web interface on such cases.

We have used the Calf Flanger and Calf Phaser as initial plugin examples providing this feature.


Notification/warning when using trial plugins in a pedalboard

We got reports from some confused users where the pedalboard was cutting off sound intermittently,
not realizing they are using trial/demo plugins.
While this is more or less obvious when loading pedalboards from the device, there was no indication of that being the case when loading from

To make things clear, we will now show a little notification when loading a plugin in trial mode.
The notification will appear at maximum 1 time per pedalboard.

Hopefully that makes things clear for this specific situation.




NOTE: the features now described below are dwarf specific for this release

Audio processing options

A noise gate, compressor and pedalboard gain are now accessible directly from the device, through the input processing and output processing settings.
They are built in the audio chain and do not appear as plugins in the pedalboard.
These are optional and not enabled by default.
Settings are persistent across pedalboard changes and reboots.


Bank, pedalboard and snapshot management

It is now possible to create and manage banks and snapshots on the Dwarf without the use of a PC or web browser.

For banks management you can import all the pedalboards from another bank or individually.
You can also delete individual banks.

On the snapshots side you can use the save function and give the current snapshot a new name as a way create new snapshots.
Deleting snapshots is possible as well, working the same way as for banks.

And for pedalboards, it is now possible to save (overwrite) or save with a new name, directly from the device.
You can do this by opening the menu, pressing the save button, and following the steps on the display.


Controller feedback for plugins

This is a new MOD-specific LV2 feature we implemented to give plugins the possibility of taking over certain parts of the device screen and LEDs.
Plugins cannot draw custom shapes but can change the text, indicator value and LED color.

As typical for such new features, we have to create them first and only then plugins can make use of it.
We have verified that the feature works by the use of test plugins.

For something actually useful on real plugins, we have modified die-fluidsynth plugin to blink the LED when loading an sf2 file and its on/off switch is assigned to a footswitch.
You will see the LED blinking to indicate the file is loading in the background.
The blinking will stop once the sf2 file has finished loading, indicating the plugin is ready to be used.

We are working on developer oriented documentation so external developers can implement this too.
The upcoming Looperlative plugin is one that makes heavy use of this feature and the main reason we have implemented it.

There’s also quite a few more changes and tweaks.
Visit Releases#Release_1.11 to see all changes since v1.10.

The next time you open the MOD web interface you’ll receive an update notification.
Just click on the tooltip icon in the bottom-right when that happens, then ‘Download’ and finally ‘Upgrade Now’.
Wait for a few minutes while the MOD updates itself automatically. :slight_smile:

We hope you’re enjoying your MOD device.
Let us know if you find any issues.


I’ve a big issue with this update.
I can’t use 2 buttons for changing plugin setting without freezing the unit! Changing preset with the 2 endless knobs works.
For example I’ve assign button 1&2 from the first page to Gaffa preset and I can’t change prest without freezing the unit.
bug preset

When the unit is frozen the web editor still works.

I have to return to RC3 I can’t even change snapshot with 2 buttons withour freezing.
Sorry, this release won’t be for my Unit.

So we have a regression around assignment groups, I will take a look at this shortly.


Found the issue, and have a fix already :slight_smile:

Can even tell where exactly it happened.
Started here (it was my fault, sorry!)

Easily fixed by

Sometimes the callback is None, so there needs to be a check for that.

Thanks for spotting the issue, I will now do the whole dance for pushing new builds.

EDIT: New builds are up!


So the issue is resolved in a new release?

Regarding firmware upgrades:
First of all, thank you for the effort and hard work of the Mod teams.
Now the grievances (Dwarf):
1-It seems that I have problems with the sliders of the ToggleSwitch 4 plugin.
Before this update I could easily use the cursors with the mouse with immediate responsiveness.
After this update the handling of these sliders seems to me more “erratic” I am sometimes forced to double-click on the slider to switch it to “On and Off” mode.
2-Concerning the sound:
On all of my pedals, I have the impression that my ears hear a change in high frequencies like “annoying” highlights.
A more digital sound definition less warm than the previous firmware.
Is it possible to downgrade the Dwarf to its previous firmware version.

Thank you.

In fact the drag function with the mouse pointer is no longer possible on all plugins that have horizontal sliders.
What a pity !


I find that if I click on the buttons on the ToggleSwitch 4 plugin then they change state, but not if I try to slide them - actually easier, but easy to miss.

1 Like

I’m having a problem with the update - It’s been supposedly ‘starting upgrade’ for a couple of hours. I gather it shouldn’t take this long. Do I need to unplug the Dwarf or leave it connected? Some kind of progress meter would have been useful.
UPDATE: problem solved. I needed to disconnect the USB cable & reboot the computer as well as power the unit down.

1 Like

Small update: While doing some final testing for looperlative plugin we found a small issue on the dwarf side. So we pushed a small tweak as needed for it.
If you have already updated to v1.11 you will see another v1.11.0 update yet again.
Other units remain the same, as they do not support HMI Widgets yet.


I’m in the same situation here!

I will try it. But… When you say computer do you refers to mod dwarf or your computer?

I ended up powering both down.


Hello, @falkTX. I noticed a small bug into the Mod UI at the dwarf

The font color of the input is white
I’m using Firefox 95.0.1 (64-bits)

EDIT: Isn’t a v1.11 bug, is a specific Logic Operators bug:


good find. it is always nasty when modguis change more than they should…
time to check the git blame :sweat_smile:


I also have two big issues on my Dwarf with the upgrade as well… or better three… I think two are the result of the same thing:

  1. When working on my pedalboards I have system crashes in Edit mode. If I noticed it right it is always the case after deleting one of the 8 Mindi PlugIns that are running in my pedalboards (in the release before it worked fine for weeks) (and yes, the Dwarf then is connected to my PC). The interface of the deivce is frozen, the foot switches as well, the right foot switch light gets brighter in white colour when Dwarf is crashing. I then still can work in the editor but it makes funny things after a while (like listing more and more snapshots with the same name). After rebooting it works fine but I can redo the same thing: Delete a Mindi, it crashes again and so on.

  2. After rebooting the Dwarf several times because of this issue the reboot is no more working fine: The two input indicating LEDs and one of the output LEDs are blinking in red. The sound is completey distorted, there is much too much input gain. I can reduce it to 0 and still it is the same (the red blinking goes to yellow permanent colour, then to red blinking again, to yellow etc. without any logic and the sound still is massively distorted). Reboot: still the same: Much too much input gain. Now I unplugged the Dwarf from my PC and made a reboot, then it worked fine again.

  3. After the upgrade, the Midi is no more working properly. Before upgrade, the Mindi PlugIn sent all Midi values after loading the pedalboard automatically. Now it is no more sending, even if I send it manually by switching Mindi on and of. I checked if Midi commands are coming back to the Dwarf with the Midi Display PlugIn: Utter silence, no Midi commands coming in (also the other pedals got no commands). After sending then a Midi command from my external Midi controller into the system, Mindi suddenly starts to send the Midi values (Midi Display PlugIn now shows the sent values). It’s a bit like having to tickle the Dwarf to get him to send. I tried to change the new available Midi settings, no changes, it is in all settings the same.

There are some other issues with Midi: Sometimes a value has not been sent, sometimes other strange behaviour. I could not redo these issues, thus it is not possible for me to describe what exactly has been going on. May be if the issue described above is solved, it runs properly again. If this is not the case I will try to analyse if something is going wrong.

@falkTX Now it crashes even without deleting a Mindi. A simple Snapshot change is enough to let the Dwarf crash. I think it is nevertheless a problem with Midi, maybe especially with Mindi PlugIn. It is not crashing all the time, only sometimes. And I cannot see any system behind it. The only thing that I can say is, that it crashes after changing something in the Mindi PlugIn, but I am not 100% sure.

It crashes now often after changing the snapshot. I need one reboot all 5 minutes when working on my pedalboards. After some of the reboots the foot switch for changing the snapshot is no more working (in the PC editor it is still possible). All during the Dwarf is in Edit mode and is connected to the PC. Sometimes it shows bug reports, something like: “Adressing of parameter is not allowed”.
After all I am sure that this is a problem with Midi (maybe Mindi). Pedalboards without Midi are working fine.

@falkTX @jon No answer?

We were just on holidays :slight_smile:

I will have to test this and see what I can find about the issue, haven’t done that yet.

When you see issues like that, ssh’ing into the unit and running journalctl -u mod-ui might show some errors. If you spot any, they would be extremely useful.