Release 0.15.0

Hello everyone, a new update is here - v0.15.0 aka “the best MOD release yet”. :wink:

This release took a little more time as we had the MTF event in between.
In the other hand, some of the hacks we implemented for it have been merged.
You’ll now be able to use PS3 and PS4 joysticks as MIDI devices (connected over USB).
We’ve got 1 specific Guitar Hero joystick working as MIDI device too (red octane xbox controller).

We made several system tweaks and a few kernel changes, which finally fixes the sporadic xrun issue.
You can still get xruns if you load too many big plugins at once, but if you keep the cpu load ~80% there should be no xruns.

We also modified the update procedure to be less error-prone, although making it slower.
Any updates you install after this one should never fail.

Last but not least, we added support for user presets.
You can now save, rename and delete your own presets.
And addressing the preset list to mod controller actuators is now possible (knob or footswitch).

Here’s the download link:
Note: version 0.10.4 or higher is required to install.

Here’s the full changelog:

  • add user preset support (save, rename and delete)
  • allow to use integer and toggle type controls with midi cc
  • implement addressing of preset list (to controller actuators)
  • increase screenshot timeout value, needed for big pedalboards
  • initial support for some joysticks as MIDI devices (via nooice project, work in progress)
  • make system updates much more reliable (but slightly slower) [*]
  • fix control unaddressing when moved to a different actuator
  • fix loading addressings on toggle-type controls
  • fix possible black-on-black text input in save dialog under firefox
  • fix wrong plugin version micro/minor order
  • prevent pedalboard save without name
  • save gain stage and volume values when changed via controller (by clicking “back to settings”)
  • send initial port values to javascript ‘start’ event
  • several kernel and system tweaks, finally fixing the sporadic-xrun issue

The update procedure is explained at the top of the releases page, here:

We hope you’re enjoying your MOD Duo.
Please let us know of any issues!

1 Like

Just installed, but I cannot access to the Assembler (“500: Internal Server Error”).
Should I come back to the previous version?

The answer was yes, I went back to the v.14 and it works now. But the problem is that since I’ve installed almost 30 new pug-ins from the store there are lot of bugs loading banks and adding the new effects.
“Bug! Couldn’t load banks”
“Error adding effects. Probably a connection problem”

Hi there, please try installing the 0.15 release twice.
That will make sure it is installed correctly.
(first time can fail from 0.14 to 0.15, unfortunately)

Trying right now…but it’s blocked on “copy file, eject and unplug” since 15 minutes ago.
The procedure was right.
I think something went bad, hoping it’s not too bad…

Have you tried turn it off and on again? :wink:

Hold the left knob and footswitch down before turning it on (for ~5secs).
That way it starts straight to the restore/upgrade mode.

Yeah, safe :slight_smile:

And it works! But the bugs remain since I installed the new plug-ins :confused:

I’ll try to reproduce it here then.

Can you tell me more about your setup?
What plugins did you use, and what kind of addressings you made.

Here there are some screenshots of banks

Basically, I use to split the sound in two to create interesting textures. I cannot list all the almost 15 banks I did, but the tools used are pretty the same (common effects for guitar). guitar simulator, the yellow eq, monophonic comp, some modulations, delay and reverb (Shiro and the plate).

If it doesn’t help, I’ll provide a more detailed list.
By the way, today it seems something’s changed: the Assembler works quite well, just some crashes sometimes.

Regarding presets: is it possible to define presets for the entire pedalboard and switch between them using the built-in footswitches, like within banks?
This can be a good solution for being able to switch between sounds in a stage scenario without having the long gaps that switching between pedalboards incurs.

That’s something we have planned for later.

@ytai this was already in our roadmap, but we end up releasing the plugin presets first. We already had exactly what you asked in our plans… thanks for the feedback!

@Emilio_Larocca_Conte I tried a few things but I cannot reproduce your issue.

Which browser do you use? Are you using Mac?

After 1 week testing this release is now considered stable.
Enjoy! :wink:

PS: If we’re able to reproduce @Emilio_Larocca_Conte’s issue we’ll do a 0.15.1 release.

I’ve seen the exact same issue when zooming the page while loading (linux/firefox : here accidental ctrl + scroll-wheel) but have not been able to reproduce it: Reloading the page fixed it.

Since the knob image uses some fancy css/js to set the image offset, it’s entirely believable that it would break on IE or some older browsers. but that should not be specific to 0.15

Yes, I’m using Mac! OS X El Capitain, the latest one (10.11.5). Sorry for being late

I’ll check tonight if everything works :wink:

Stupid question, but is there a way to know if the update actually went through? The system info screen on the device shows a hex value (fbbffb5f) and the web interface has no “about” or “info” button available.

I tried the 0.15 update three times already. I attempted starting from a fully booted state first and ran into the “copy file, eject and unplug” issue pointed by @Emilio_Larocca_Conte. Then I followed @falkTX advice and booted straight to recovery mode. In this case it looks like the update worked - I can even connect to the assembler - but the knobs and buttons don’t do anything.

It’s the first time I update the firmware since I got it, and I noticed there’s a minimum 0.10.4 version for it to work (BTW this information is nowhere to be seen on the releases page; if it’s important, it should be there).

As a last attempt, I’ll try installing 0.10.4 first and then 0.15. Let’s see how it goes.

Update: It looks like it worked. Please update the release page with the 0.10.4 requirement!

Hi @fzero, thanks for the feedback, we’ll get the release page updated.