Problems using mod-plugin-builder [SOLVED]

I’m working towards building a plugin for the Dwarf.
I’m developing on a Mac M1 system.
I’ve tried two approaches to getting a Docker container working:

I experience the same two Issues on both. All commands are run in ~/mod-plugin-builder

Issue 1
Trying the command:
./build moddwarf-new mod-volume

I get the following error:

./build: line 99: cd: /home/builder/mod-workdir/moddwarf-new/build/buildroot-2016.02: No such file or directory

Issue 2
Trying the command:
./build moddwarf mod-volume

It appears that the plugin compiles, but then the process fails during install … the last few lines of output are:

>>> mod-volume bc55d4f336b00a8766817f65121b9ec59d20f98d Installing to target
install -d /home/builder/mod-workdir/moddwarf/target/usr/lib/lv2/
cp -r /home/builder/mod-workdir/moddwarf/build/mod-volume-bc55d4f336b00a8766817f65121b9ec59d20f98d/volume/source/*.lv2    			/home/builder/mod-workdir/moddwarf/target/usr/lib/lv2/
cp -r /home/builder/mod-workdir/moddwarf/build/mod-volume-bc55d4f336b00a8766817f65121b9ec59d20f98d/volume-2x2/source/*.lv2  			/home/builder/mod-workdir/moddwarf/target/usr/lib/lv2/
cp -rL /home/builder/mod-plugin-builder/plugins-dep/../plugins/package/mod-volume//mod-volume.lv2/*        /home/builder/mod-workdir/moddwarf/target/usr/lib/lv2/mod-volume.lv2/
cp: cannot stat '/home/builder/mod-plugin-builder/plugins-dep/../plugins/package/mod-volume//mod-volume.lv2/*': No such file or directory
make: *** [package/ /home/builder/mod-workdir/moddwarf/build/mod-volume-bc55d4f336b00a8766817f65121b9ec59d20f98d/.stamp_target_installed] Error 1

Has anyone found they get these issues/found a workaround?

So … after a suggestion in another topic by @micahvdm, I installed UTM running Debian, cloned the mod-plugin-builder repo and ran ./bootstrap moddwarf. This ran to completion without errors (Tho it took the best part of an hour).

I STILL got the two issues I mentioned.
Then I remembered something about git submodules and ran the following:

git submodule init
git submodule update

This resolved Issue 2 but I still cannot execute ./build moddwarf-new mod-volume successfully. Do I need to do another ./bootstrap specifying moddwarf-new (And does this actually then use the more up to date toolchain)?

You must run ./bootstrap moddwarf-new


That totally resolved it, thanks so much @micahvdm !

1 Like