Input clipping with nothing connected [SOLVED]

I’m having an issue with my Dwarf where upon boot, both led’s for inputs 1&2 flash red (indicating clipping) even with nothing connected, and a ton of squealing comes from the outputs.

After power cycling I can often times get it to boot ‘properly’ but yesterday I had to power cycle 8 times before I was able to play. After getting it to boot cleanly, I was able to play for many hours without issue.

Has anyone else experienced this?

Side note: I did a side-by-side sound/feel comparison between the Dwarf and my actual guitar rig with pedalboard/amp… and I’m considering selling the old rig. I really am loving this thing!


I came here to search for anybody else having this issue. I just updated to the latest software and I bet that’s what’s causing it.

Edit: I was trying to follow the steps from the releases page to try to manually downgrade (don’t know if that’s even possible) and I noticed it works just fine if I don’t start it with the USB plugged in.


I have not found that to be the case. As a troubleshooting step I’ve been powering up with nothing connected to ins/outs/usb-a/usb-b. Still happening.

I’m relieved to hear it’s not just my device. Thanks for replying.

1 Like

I’ve seen this too, but only two times, each time after a long day of rehearsal (I re-powered the dwarf after the end of the day to change something in the patch for the next day). I put this constant-clipping-bug on the “too hot work today” side, I didn’t have the issue since 2 months now.
And I couldn’t reproduce the bug so I didn’t made a report.

Hope you find a solution…

1 Like

I had the same issue everytime a PB with several distortion plugins was loaded, the workaround was to delete the first snapshot of the liste, the “Default” one.

1 Like

Oh this is pretty cool!

I’m not happy with you issue though!
Have you checked if the power plug is well connected?
What OS version are you running on the MOD Dwarf? And does this happen with any particular pedalboard or even with the default one?

Hmm wasn’t it a coincidence? can you confirm it?
On the downgrade, you just need to download one older version and do the update manually (make the device to be recognized as a storage device, etc.)

1 Like

Still not supposed to happen. @FistfulOfStars did you have the device on for long before?

Yes, the power plug is fully/properly inserted. I’m running the latest firmware, updated this weekend. I believe that it was happening before the update also, but can’t confirm that.

Regarding pedalboard active at boot, I’ll try to do some more testing after work today if I have time.

No, it happens even after being off for a full day. Again, will try to do more thorough testing on this point.

Interesting, will look into this.

1 Like

My suggestion is: try to make it happen even with the default pedalboard - the one only with the gain plugin.
If it happens with only that pedalboard, it is really a problem either on the device OS or on the device itself.

Well, I tried to troubleshoot this evening, but the problem wasn’t wanting to cooperate.

First boot had the issue, input clipping immediately.

Power cycled 16 times, never did it again. I tried various combinations of accessories plugged in (bluetooth and usb-b connection) - different pedalboards loaded (including default) etc. Only the first boot had the clipping issue.

That would be good news except that it leaves me with no answers.

Also, while power cycling so many times I noticed that it appears to load the “Default” pedalboard upon first boot, before loading the last selected pedalboard. I don’t think this information is helpful, but I did find it notable.

If I’m ever able to get any further information I’ll post it here, otherwise I’ll just attribute it to a quirk in the system.

Being a Linux audio production enthusiast, using Jack, Ardour, and many lv2 plugins on the PC, I’m kind of used to these types of quirks to be honest. As long as it’s not a problem with the hardware I’ll happily carry on.

I’d be willing to read through the boot logs the next time it happens, but I’m not sure how to do that.


I had this issue sometimes as well. Especially after crashing. @falkTX Do you remember? You did a hotfix for me (and for the community of course) and I reported the same issue. This comes up sometimes. Before the fix it has been often, now it came up once a week round about.


Hmm wasn’t it a coincidence? can you confirm it?
On the downgrade, you just need to download one older version and do the update manually (make the device to be recognized as a storage device, etc.)

That theory can be thrown out the window - it’s not happening anymore. I’ve powered the Dwarf off and on again several times (with the USB cable plugged in) and it works fine so far.
Thanks for the info on downgrading - might come in handy someday, though hopefully not :smile:


Exactly. I totally understand that. That makes it harder also for us to understand what is really happening (so we fix it).

What do you mean? That first loads the default and then “rescues” the last loaded pedalboard?

Thanks. Please do that.

maybe @falkTX or @Jan can help you with that.


You’re welcome. Well…knowledge is always helpful!
Thanks for reporting that.

In the following video, if you watch the screen after the 'MOD" boot splash screen, you can see it first loads the “Default” pedalboard, then loads the previously selected “Just Play” pedalboard.

Hopefully at some point I’ll have some time to publish my ‘Songwriters Sketchbook’ pedalboard and do some Youtube videos on my experience with the Dwarf. It really is very close to the self-contained solution I’ve been seeking for almost 15 years. If/when we have a simple multitracking plugin, it will really be the best songwriting tool I’ve found. Very close as it is right now!


Gotcha :wink: This is normal and expected.

Thanks a lot :slight_smile: I can’t wait to watch those videos :wink:

Same problem here, in-out leds flashing with high noise (which can be dangerous in some situations…)

It happens randomly often after saving a PB in standalone, never connected to the web GUI.

Sometimes it freezes after saving, related to my snapshot /PB /save issue?

I had to power cycle several times until it boots with no problem.

Here is a video after a failed boot, and a freeze issue.


@zwabo I’ve experienced that same freeze issue as well, but only once, and I didn’t know how to recreate it.

Do you know what you’re doing to trigger it? Can you detail that so I can try to recreate?

1 Like

I’ve also had this issue a couple of times.
It did it a couple of weeks ago before I upgraded to the latest firmware. It was at a little gig - I’d played my set and then was asked back up after about an hour so had quickly set-up again. First time I powered it up I got the problem described above. After repowering it was OK. It was a straightforward setup - 2 ins, 2 outs, no USB etc.

Then it happened again today at home having upgraded to the latest firmware the other day. I think it was the first time it was powered-up today and went straight into the fault condition. Again repowering fixed it. While in the fault condition I was able to change the controls as usual and switching the pedals on and off affected the horrible noise but I couldn’t hear any input signal.
I tried altering the input gains but it made no difference.

I was using my own PSU (which claims to be 12V 3A) - not the standard Dwarf one. The previous time I think I was using a different 12v 2A PSU.

Hope that’s of some help



Thanks for reporting and for the video. We will try to replicate it on our side.

@ianr yes it is. Thanks for sharing. We will try to understand what it’s happening. Anyway, it shouldn’t even if you are using a different PSU - as long as it has the same specs it should be just fine.

1 Like