Dwarf first impression issues

Okay, first off looks great and sounds great. Now for some issues:

1.Can’t it route output of 1 into input 2 like the Mod Duo? I’ve even tried it the other way around. This was super helpful as an effects send loop.

2.I’m getting audio drop outs every 20 seconds. CPU below 70%, closer to 60%.

3.I’m getting some crazy CPU spikes at times from 62% CPU to over 100%.

Anyone else? Back to it. Trying a bunch of stuff…

1 Like

I was going to post a bug about assigning the footswitches to subpages, but it turns out I just didn’t understand how they worked. Looks like that all works fine. I didn’t realize you had 8 pages (and the extra pages only appear if you assign something on them - cool!), and the subpages I, II, and III only apply to the knobs.

My only glitch so far is that the sub vintage rig has some audio problems occasionally (clicks, and once no output at all) but I think that is the Supersonic plugin. That thing is unreliable on my Mod Duo X as well and I have filed a report on it in the past.

No real CPU problems or audio dropouts on mine yet - but I haven’t created any pedalboards of my own.

1 Like

Lots and lots of audio dropouts. Swapping plugins, etc. to no avail. A few clicks here and there too. CPU never gets above 70% but still shaky. Spent about 3 hours so far. More tomorrow…

Solved the dropouts but lots of clicks and CPU spikes from 70% to over 100% randomly.

Also semi solved the effects loop issue. Started over from scratch (which was a PITA) and swapping plug ins.

Also, some plug ins like the Bollie delay, the Caps Plate, Tube Driver, Shiro Harmless and Shiro Verb don’t save the settings after you save a pedal board and reopen it later. Has happened several times.

Same here. It dawned on me how it’s supposed to work after studying the interface a little bit longer. I also was looking for a way to remove subpages, since they seem to persist even after unassigning all controls. After the next restart of the dwarf the empty subpages were gone.

Started up again today after shutting down last night. Settings for the previously mentioned plug ins still aren’t saving.

Will do more intense testing.

Edit: The Guitarix WahWah also doesn’t retain its settings. Must have missed that last night. I’m pretty sure this issue has something to do with code of these plug ins and syncing with the web app as the settings seem to be retained when disconnected from the app. more later…

Still getting weird clicks and CPU spikes from 63% to over 100%. The clicks aren’t always a result of spikes as I’m watching the screen while playing.

Oh, also on/off states aren’t preserved in those plugs ins always (the Caps reverb state is preserved but Avocado and Harmless are not for instance). It’s possible all these issues are happening in the unit irrespective of the web app after a few reboots without the app.

The CPU “spike” is fake, we added that way back in the day to prevent people from pushing the Duo too much or doing things that would cause xruns (so bad audio) but with the CPU still at a low value.
It is very misleading, so I will remove that.

If you enable “developer mode” (in advanced settings option in the bottom-right), you should be able to then see a counter for the xruns and also system temperature.

1 Like

Got it! Done. Good to know the clicks have nothing to do with that.

Unlisted crude video. I guess I’m done for the day if this keeps up:


1 Like

thanks for the video, I will have a look at this.

btw do you have a link to your old duo pedalboard?

Here you go: Ed Ambient X 3 - MOD Devices

One weird thing: In my old Mod Duo I could split the signal running channel 1 into channel 2 and then a bunch of plug in in between out to 2’s output. I just stumbled on something (who knows, maybe I’m an idiot and it’s been possible all along) but if I run a path out channel 1 then have effects in channel 2 as a loop so to speak but in the app I bypass that and connect input 2 straight to output 2 the loop with other effects is active. Very interesting. Possibly a way around the issue? I dunno’. It’s not the same for sure but if it works…

Oh, and one more thing: I bought the premium plug in package but how the hell do I get the Dwarf to recognize it? They ain’t there. Thanks.

we do not ship with payed plugins in the factory-reset image, you will have to install them yourself.
not sure if we have started giving licenses to the plugins, that is a good point, I will ask the rest of the team.

thanks for the PB link btw
I will be investigating this, couple of fixes coming soon in a new build

1 Like

I’m totally fine with installing plug ins myself, no problem. I would just prefer working with some plugs I am familiar with from my Duo which I paid extra for. Especially the drives and reverbs. Thanks!

Somewhat of a work around but not perfect (the volume pedal is only active on the loop). Not what my Mod could do but I’m sure we’ll work it out:

Investigating the “plugins dont save their settings”, I really cant reproduce here.
BollieDelay was a plugin you mentioned did not save, but it does work fine here.
Very odd. Maybe this was fixed already, I am a few bug-fixes ahead vs the current build.

I will sync with the team and try to push new build already tomorrow morning.


Wow, that’s odd. For me it happens every time and I have the latest firmware for the Dwarf.

So I recreated my old Mod Duo board with different plug ins that weren’t misbehaving and had to use two less plug ins (???) because this was perilously close on CPU. I’d much prefer having my old board with the wah and chorus added and the CPU was lower but maybe with the new bug fix:

1 Like

This is the old Mod Duo set up:

1 Like

FWIW that dual cab patch I posted won’t survive with more than a few effects active. As soon as I engaged the octave drop CPU hell broke loose and lots of artifacts. I’m gonna’ attempt a workaround.