Dwarf first impression issues

Here’s another less CPU hoggish patch though no Low Drop (clicks galore and peaks CPU when engaged) and no tremolo or chorus. This is about as far as you can push it as I still see peaks:

1 Like

I am a little confused here.

Are these pedalboards targeting the dwarf?

In any case, I will try to load them here.

EDIT: “New Ambient V3” loads with about 70% CPU usage here.

New Ambient V3 was targeted towards the Dwarf as was the Dual Cab.

New Ambient V3 runs at 78% here but peaks higher even in developer mode.
I removed the Drop plug in because it, the chorus and tremolo put it well over 100% but the Drop when engaged put it over 100% by itself.

Edit: Ambient Dual Cab is off the scale with plug ins engaged.

For what I know, the premium plugin licenses were not yet processed. But should be soonish


Let’s hope so. It would make a big difference in testing this puppy!

BTW-Are you on a Mac or PC?

Okay, Just did the update this morning and now I get no signal out of Ambient V3 or any other patch I created for the Dwarf where output of 1 goes into 2 and out 2 again. Nada. Zip. Zero. And it doesn’t save my presets either. Everything of those plug ins I previously mentioned went back to defaults.

I’m on a PC running Windows 10 BTW.

I’m trying to decipher the pedalboard. I notice there are a few points where the signal from the first chain (in1 -> out2) is being inserted into the second chain (in2 -> out2)

Video 1 - (red line)

Video 2 - (red line)

Is that intentional? I’m just thinking it may make it difficult to isolate whether the individual chains are working correctly like this

1 Like

Yes, for now that was intentional because I couldn’t get my old signal path–from output 1 into input 2 (and effect loop to other pedals) to work like it did with my Mod Duo. There’s many way you can do this such as direct from input 2 to output 2, but I was trying to get the wet effects in there. Right now I’m rebuilding the whole thing from scratch with dry effects (dirt, fuzz, compression and EQ) to output 1 and all wet effects after the loop to output 2 keeping them separate. So far that’s not working either (well it was but I’m getting red on output 1 without even playing and thus no signal). Frustrating.

Okay, rebuilt the board from scratch using the default patch (nothing but a mini split at the end). I’m sending input 2 direct to output 2 (sending output 1 to input 2 doesn’t work) as well as having some wet effects between input 2 and output 2. Honestly, a very similar set up I had does not work after this morning’s firmware update. I went to bed and it worked, it worked this morning but after the update no worky. New patch:

As far as I know, it has never been possible to virtually connect out1 into in2 even on the Duo. I confirmed this with Jesse who has been here since the production launch of the Duo. Unless you mean something else? You could of course, do it with a physical cable.

So just to clarify, with this current pedalboard, you are getting signal on in1, out1 and in2 but not out2?

Yes, I’m talking about with a physical cable.

Yes, after the firmware update with the patch/board I sent yesterday I’m getting signal out of 1 and into 1 and 2 but not out of 2. Must be some weird plug in thing after the update. That new Reverb First patch I posted really doesn’t work because unless you have all the wet effects from input 2 to output 2 once you engage effects on the physical loop it dimes the meters so forget that. Uggghhhh…frustrating…

Here’s an updated version doing it the old way I used to with my Mod Duo. Again, external effects are routed with physical cables from output 1 to input 2 for this to work. An effects loop if you will. So far this is working but I had to build it from scratch:

Right so you meant that connecting out1 to in2 with a cable does not work. But since we could see the peak meters lighting up on in2, it means that it was working. So there is no difference with the device comparing the dwarf to the duo. There was just no signal coming out of out2 which indicates to me, either there was a problem with the pedalboard routing inside the device between in2 and out2 or there was one or more plugins which were not alowing audio to pass through.

The latest pedalboard you posted looks to have good routing so it should work fine. If it does not then there must be a problem with one of the plugins. In that case, I would just put a tiny gain between each pedal to see where the signal is getting cut. Also I would recomend using seperate tinygains on the outputs rather than using the stereo tinygain so that you can control the 2 signal chains independantly

1 Like

Right, this new pedal board works fine, even with the same effects, because I built it from scratch. Which correctly means there’s an issue with one of the plug ins in chain 2 which I surmised as well. This issue only occurred after the new update. I tried taking plug ins out of the chain but that didn’t work which is why I rebuilt it from scratch. Anyways, obviously a bug there or at least some existing plug ins aren’t cozy with the update and/or Mod Dwarf just yet. Fortunately as a full-time musician I’m in the right position to be part of the BETA team!! :grinning:

1 Like

So it is working now after being updated and with the same effects? When you say built it from scratch, do you mean that you were previously using a pedalboard that was made for the Duo? As far as I know, Duo pedalboards should not be compatible with the Dwarf because they have different assignments etc. So I would expect trying to port a Duo pedal board to the Dwarf would not be very smooth

Just to clarify, it is working now right?

It’s working now with the same effects yes but again, I started completely from scratch from the pedal board I built yesterday specifically for Dwarf. Dig? Board built for Dwarf, worked, updated, then did not work.

We are talking about the same web page application right? There was no documentation with my Dwarf so…

I just wanted to check if the problem is resolved so that we can consider this case closed.
It seems like everything is okay, if there is another problem let’s revisit it

As for the issue of plugins not saving there state, I think Falk is investigating

This morning’s issue is resolved yes but again, only by rebuilding from scratch. Gotta’ be a plug in compatibility issue. And yes, plug ins are not saving their state when relaunched still in Windows 10. Thanks!

PS-I was giving this some thought as I was working in the studio today with the Dwarf and I think it could be indeed the web browser app itself that has a compatibility issue with some plug ins. This would make sense no? In fact, I bet if I don’t open the app tomorrow while I’m using the Dwarf my settings will be the same in the hardware itself. Just an idea.