DUO X Locking up A LOT since latest update

Hi - not sure what has happened but seeing loads of lock ups atm. Can you fix?

You updated from what version? The Duo X related changes are very minor on 1.13.3 to 1.13.4, we basically introduce a delay of the USB activation so it always initializes properly, everything else is exactly the same…

From the previous one - seems to mostly related to using MIDI CC as far as I can tell.

In fact another issue too - the USB keeps disconnecting from my Mac. Doesn’t even reconnect if I restart the device.

Not seen these issues before - must be due to the update.

@falkTX Could this be related to the ‘delay in the USB activation’ you mention. Maybe it’s not activating correctly because my Mac can no longer detect the device.

Never had an issue with this before the update.

Looking at the full changes I do not see how that is possible. I think there is really something more at play here.
But just in case, 1.13.3 Duo X image is https://download.moddevices.com/releases/modduox/modduox-v1.13.3.3255.tar

It may be slightly dependent on which mac OS and version of safari/chrome you’re running-- but try disabling all the sleep/screensaver modes while on power, that may help…

Thanks @falkTX - can I do this without losing all of my stored pedalboards.

I’ve now also tried this on a separate Mac laptop and seen the same issues. Definitely a problem here.

Why would any of that have to do with the Mac not being able to detect the device?

Or the fact that I’ve not seen this issue at all before?

Please read before commenting, it’s just noise otherwise.

I’ll let you sort out what you consider noise on your own time-- a hazard of the forums, but if you don’t want people to offer what they consider help, don’t ask for it :slight_smile:

I don’t know what that would have to do with the Mac not being able to detect the device as I am not a programmer, maybe something with sleeping changes whether it perceives USB ports as active, but I can tell you that doing it made my Mac detect my own Dwarf more reliably so try it if you want, if it doesn’t help c’est la vie.



Again - read my posts, I don’t have a Mod Dwarf,

Great - thanks @dreamer

How do I install this?


Put the device in update mode (hold down the top-left encoder → system → system upgrade). Mount the new usb drive. Copy the firmware zip file onto the device. Safely remove.

Brilliant - thanks!

After updating my DUO X with this v1.13.4 the XF4 MOD Footswitch is not recognized any more, before the update, it worked well.
Other users of this combi have better experience?

I think this update has potentially bricked Bluetooth too - its connected via my Mac but as with USB it cannot ‘see’ the device in the MIDI Studio or access via browser,

I’ve recently returned to using my mod duo x and with latest update my device controls become unresponsive very often. It looks very similar to what I had in 2019, and it was fixed (workaround) with turning off peak meters. But now I don’t have such option in advanced settings. Unfortunately I cannot tell if such thing appears on previous firmware as I’ve updated from 2019 version)
But I’ve made a test, and there is no freezing if no input signal is coming.
I’m not sure if this is the same problem, but sometimes in pedalbord editor you cannot save knob mapping (button save does nothing)

I remember some of the very first Duo X units having a problem with the peak meters, but that was quite long time ago. Eventually we removed the option to disable the peak meters as we thought whatever the issue was got resolved on the way with other updates, but obviously it still happens for a few units then.

Your unit is a limited edition one, correct?