Connecting to the Web Interface

At the moment I can only connect to the Modduox via my laptop.
With the desktop the connection fails, no matter which USB port the Modduox is connected to - I have tried them all. I used Firefox and Chromium, I had the extensions disabled.

I didn’t find anything in and now I have no more idea. Have I forgotten something important? What can I do?

Desktop: Debian, XFCE4
Laptop: Debian, Gnome

What does lsusb on the desktop say when the Duo is physically connected? If the Duo is detected you will see something like 0525:a4a2 Netchip Technology, Inc. Linux-USB Ethernet/RNDIS Gadget. If this is not the case, we got a problem on the USB hardware level.

What network devices are present when running ip a? Usually the last device in the list is the Duo. Does it have an IP address assigned? If there’s an interface with no IP, is the network manager running?

Also try running sudo journalctl -fk before plugging the Duo into the USB port and look at the USB and network related messages.

1 Like

The moddoux is recognized by lsusb.

However, according to “ip a” it is not assigned an IP address.
XFCE4 has a network manager in autostart. But no matter if it is switched on or off, the moddoux has no IP address.

“journalctl -fk” shows me on some USB ports that the USB cable is defective, on other USB ports it detects the Moddoux without error messages.

With the laptop, the Moddoux has an IP address, everything runs smoothly - plug and play.

Ok then try dhclient <insert interface name here> and see if you get an IP.

1 Like

This just seems like a quirk of XFCE not automatically assigning or connecting

Thanks for the quick and successful help.
Everything works now and: I have learned something.

1 Like

This is so fucking finnicky – I’m on POP OS with a frameowrk laptop, and haven’t had an issue AT ALL, but everytime i try to connect via USB, fmy laptop won’t connect to http://moddwarf.local.

This is expensive gear; and it only works when I’m at home. PLEASE HELP.

1 Like

moddwarf.local depends on the local network, it needs to support mDNS and zeroconf.
some routers and/or network setups block this (as seen recently in another thread when using a VPN)

the best is to use which is the IP assigned to the internal USB network.