Can´t save, rename nor delete preset from the user preset list

This is a very annoying bug and I don´t know if it´s happening with other plug-ins.


Guitarix GXSupersonic Version 35.0-3
Can´t save, rename nor delete preset from the user preset list.

How to reproduce

  1. Create a new user preset.
  2. Save as “whatever”
  3. Change the parameters
  4. Save it
  5. Change to another user preset
  6. Select the “Whatever” user preset to verify that the parameters were not saved.
  7. Try to rename it to verify that it is not possible.
  8. Try to delete it to verify that it is not possible.
  9. Exit the plug-in settings
  10. Reload the GUI (Browser)
  11. Enter the plug-in settings to verify that the parameters were actually saved and now you can rename and delete the “whatever” user preset but not if you change it again.

Expected/suggested solution

Be able to save, rename changed user presets and delete unwanted user presets without the need to reload the GUI (browser).

Additional information

  • release:
    Unit: MOD Duo (NAND Version)
    Build Date: 2022 Jun 07 19:50:59
    OS Version:

  • Kernel info:
    Machine: armv7l
    Release: 5.10.33-rt37-modduo
    Version: #2 SMP PREEMPT_RT Tue Jun 7 19:50:05 UTC 2022

Also provide some information about your system if possible.

  • Operating system: (Windows)
  • System version: (Windows 10)
  • Chrome Browser Versão 102.0.5005.63 (Versão oficial) 64 bits

I couldn’t replicate this.
I tried it on a MOD Duo X and a MOD Duo and everything seemed to work fine. Do you have any more details?


The short story is that although the settings are being saved, the GUI will only reflect that if the user closes the plugin settings and refresh the browser.
And yes… same behavior with other plugins.

Can´t think of any other details.


So immediately after saving the preset if you try to swap around between presets it doesn’t reflect it? And the same happens with all plugins?
If that is the case, it is exactly what I couldn’t replicate.

1 Like

if you mean that saving presets on 1 instance does not right away show that same new content on another instance of the same plugin, this is a known limitation.
saving and editing preset details from the same instance you are using should work though.

or is this happening for you even when using a single instance of the plugin?


I don’t know If It happens with all plugins but It happens with at least one other plugin in the same pedalboard so I assumed that other plugins would show the same behavior.
I will create a new pedalboard to see what happens.

1 Like

I have only one stance of each plugin in this pedalboard , so It is happening on a single instance.

Hello guys

I recorded a short video to better explain the bug.
Please don´t mind my english!!! I has been a long time since I last spoke in english.

No worries with the english. It’s not that rusty :wink:
Thank you a lot for the video! It helps to better understand.

I’m not sure, but I believe that this may be some issue with the cache of the browser. Does the same happen if you use an incognito session on the browser?

1 Like

Hello Jon,

I’ll try that and let you know what happens.

1 Like

Just tried that and presents the same issue.

1 Like

My last suggestions for now are:

  • Please try another browser;
  • If possible try also another computer

Let us know about the results.



  • Diferent computer, same browser, same behavior.
  • Diferent computer, diferent browser (firefox), same behaviour.

I just tried to reproduce this, but I am unable to.
Used a Duo too, though in 1.12-RC2 instead of 1.11, but shouldn’t matter for this case.
Both in Firefox and Chrome presets are working as intended, so there is something else going on…

I dont know what to possibly try though, my only guess is some other plugin in the pedalboard messing with global state.


Hello @falkTX Filipe, @rogeriocouto Rogerio and @jon,

Sorry for being verbose…

I can replicate what Rogerio is experiencing.
I am on a Mojave mac 10.14.4 with
Opera 88.0.4412.40 (current) and Safari Version 12.1 (14607.
both in normal and private browser sessions.
My Mod Duo is a NAND one http://modduo.local/?v=

Like Rogerio, I tested this with the Gain 2x2 plugin with the help of the
TAP Pink/Fractal Noise plugin( -20dB output) and the X42 Level Meter.
I didn’t connect the gain plugin to the outputs on the right of the GUI because that was not necessary for this test.

In my case I made entries in the 2x2 Gain plugin as follows:
A: +4dB => Level Meter reading -16dBFS
B: +5dB => Level Meter reading -15dBFS
C: 0dB => Level Meter reading -20dB
If you switch between list entries, the level meter shows the right value accordingly.

I then selected entry A (current gain value +4dB) and altered it to +5dB.
Then I hit save. I expected the list entry A to be altered.
Other preset list entryies that are not saved anew are all perfectly okay (B and C) showing correct values.
If I then select preset A the gain value reads +4dB, also Level Meter reading -16dBFS

After a browser refresh the GUI works as expected with the new value of +5dB for list entry A.

Greetings and God bless


Hello @mj_prod

Really nice to know that I´m not alone. :relieved:

One thing I can assure is that this is a very consistent behavior (bug) and very time consuming for the user because one are never really sure of the changed settings.

I keep re-entering the settings window to verify if things are accordingly to what I want and think twice before I change anything.

I wonder if others don’t have this issue, didn´t notice yet or simply don´t care about.



Not ideal, indeed. Our biggest issue for now is that we can’t really reproduce it.
Is your MOD Duo also a NAND unit?


Not sure.
Here are my machine unit details:
Machine: armv7l
Release: 5.10.33-rt37-modduo
Version: #2 SMP PREEMPT_RT Tue Jun 7 19:50:05 UTC 2022


Hello @rogeriocouto

This information should be more popular to find,
both versions of the Mod Duo differ as shown here in the wiki:

The eMMC version has the logo and Mod Duo printed above the right display.

Greetings and God bless, Marius


Hi @mj_prod

I have the nand unit then.
I updated the kernel so I was aware of this info back then.

I´ll create new a topic to make it easier to find this info here in the forum.
Thanks for sharing it again.