Bluetooth issue

I already have a Mod Duo that works perfectly with a bluetooth dongle and all my android devices.
I just received my new Mod Duo X and I’m trying to connect with the same bluetooth dongle to my android tablet but it doesn’t work.
Is there any differences between Mod Duo and Mod Duo X? Should I choose a other bluetooth dongle?

Hey Julien,

Are you using the same dongle and host computer?
Did you also activate the discover mode on the DuoX and pair it in the right time window?

Yes, same dongle, same android device, discover is activated.
My tablet can see the Mod Duo X but can’t connect.
It works perfectly with my Mod Duo.
Could be the dongle not compatible with the Mod Duo X.
I read somewhere that Mod duo X have USB 3 not USB 2.

The devices have some little config differences in terms of drivers.
Can you tell me the usb id of this device? (the 4digit-vendor:4digit-product you see when running “lsusb”(

1 Like

How do I run “Isusb”
Is it a command line.
I’ve never done that with Mod Duo.

when the bluetooth stick is connected, you just run

if connected over bluetooth
ssh root@ lsusb


if connected over usb
ssh root@ lsusb

when it prompts for a password, write mod and then enter

I tried the command line but I couldn’t write the password…strange…

I have a sneaking suspicion you may be trying to connect to the web ui using the Mod Duo URL (http://modduo.local), not the X specific one:

I just accidentally did this with my beta Dwarf :wink:

Edit: Actually I may be wrong. I may have misunderstood what you meant when you said the tablet can see the X but not connect…

1 Like

I not able to try to connect to the web ui because I can’t connect to bluetooth with my android device.
But it works pretty well with USB connected to a computer , it works even better then with Mod Duo. It’s faster and there’s no delay.

Yeah kinda figured that after I typed my reply, sorry!

You can try to get the vendor id and product id on your computer. Connect the bluetooth dongle to your computer and search the web for your OS (OSX/Windows/Linux) and “find usb vendor and product id”.

Hey Julien,
Have you set on the tablet some check box or so allowing that bluetooth connection to be used as internet source? Something like this, it may depend on the version of the Android

Hi. The problem is that I can’t connect to the Mod Duo X bluetooth. I have set bluetooth on discovery, powered off wifi on the tablet, the tablet can see Mod Duo X bluetooth but it can’t connect.
That works perfectly with my Mod Duo and the same bluetooth dongle.
So is there any differences between Mod Duo and Mod Duo X that can make the Duo X not compatible with this bluettoth dongle?

On that what @falkTX told you before is a better input than I can give you.
This weekend I connected the Dwarf to a tablet via Bluetooth (first time I did it) and I was kind of rusty on how to do the connection. So I forgot that the first time you connect the device, you need to thick a box on the settings of the Bluetooth paired devices list that says something like “Use this device to connect to Internet”

Yes I understand but.
But the android device must be connected to the Mod Duo X bluetooth to have the permission to thick that modem via bluetooth option.
So every time I thick this box I have a error message impossible to connect the bluetooth modem blablabla…
The problem is andoid device see the Mod Duo X bluetooth bit can’t make a connection.

HI @jon
I always have the same bluetooth connection issue. Whatever the android device I use, whatever the bluetooth dongle I used, the android device error is “password error” for older android version or when it is connected to mod duo x I don’t have the check box that says “use this device to connect to internet” for the most recent android version.
I’ m using bluetooth 4.0 dongle because I understood that bluetooth 5 is not supported.
I really want to use my tablet instead of my computer to connect to the mod duo x.
Any idea?

Have you ever added a password upon request?
It is 0000 I believe. You also need to set on the android that you will access the internet from the MOD DuoX.

Salut Julien,

I have the same issue with my eink tablet, but weirdly it worked some times ago (before I send it to repair), and now it keeps telling me “Cannot establish association with MOD Dwarf 01-00506 due to incorrect code or access key.” when it stops trying to connect.

The password is never asked in this process… so I’ve never could try forcing 0000 !

For adding strangeness I don’t have any problem connecting with my phone or with my computer (with the same bluetooth 5.0 dongle on the dwarf) !!!

Is there a way to clear bluetooth setting in the device through ssh ?

Hey Romain,

I would say that this is an issue on the tablet side. Have you set it up to get the MOD Dwarf as an Internet access device?

1 Like

The MOD units are very frisky when it comes to bluetooth, they will accept all connections you throw at it.
So for the case of a unit failing to connect to a specific device, but connecting to others, it is likely a setting in that device that has marked the MOD unit as untrusted.