Work! Access over WiFi with GL.iNet GL-MT300Nv2

Tested and worked with ModDuoX
Very simple.
Purchase this GL-MT300N-V2 / Mango - GL.iNet

Install this firmware (need to register, use google translate to translate from Russian) GL.iNet GL-MT300N - 4PDA

Connect SSID: OpenWrt
Go web-interface of router
Login: root
Go tab Network → Interfaces
Find interface called HILINK-> Edit-> tab Physical settings
Select interface: usb0
Save-> Save&Apply

Change SSID to whatever name
Set Password for SSID

Now you can load web GUI via WiFi connection. Loading fast, same as by cable.

How it loads on phone


Thanks a lot for this! I was about to buy the mini router but then I thought, that you might be knowledgeable enough to help me find a better solution for my setup.

My Duo lives in a rack near a Raspberry Pi which in turn is Ethernet-connected to my router/switch. I would like to hook up the Duo to the USB-Port of the Raspi and make the the Duo’s IP address accessible in my home network ( Do you have any idea how to accomplish that? It is probably gateway functionality I am looking for… but I am not entirely sure whether that is the right terminology. Thanks in advance for your advice, @Eikni!

Hello! Unfortunately I don’t know how establish connection with Raspi. My idea was to use DuoX as “4g Dongle” and this worked out. Only few messages being on this forum about this topic

This is the most detailed one

Maybe will help you.


Nice find! I had completely forgotten about this thread and should be able to get this working with the procedure given there. Cheers!


Interesting thread. It dates back a couple of years now - how does this sit against the more recent discussions about Wifi?

Anyone that has seen any of my other posts will realise that I’m am not a particularly technically minded person! I am keen to see when we could use a Wifi connection though - BT works for me but is too slow. Plus when using the Dwarf live I have a need to switch apps on my iPad (IEM mixer, set details, charts etc), the BT connection holds just fine when I switch back to the browser but the time required to ‘redraw’ the board is not so helpful.

All of this is quite manageable at home but in a live setting the more immediacy the better. Fully appreciate that even with a wired connection there is still a degree of time to draw the board.


I have not tried this router approach, so I cannot give any recommendations on this particular method, but meanwhile FalkTx have mentioned access point mode for Dwarf being tested and possibility of adding it to next or next-after-next release:

Therefore if you are not much in hurry, you can just try waiting for this hotspot mode to happen, it might be much easier.

As for me, I was personally balancing on the fence between ordering GL.INet Mango and waiting, but it is not clear if MDX is going to receive the same hotspot feature as Dwarf, so I’ve ordered a Mango router, and would share my experience later once I would get it.


I’ve got my my Mango router today:

What I’ve found out, is that microusb port on the router is just for power, nothing more.
Therefore to connect it to my MDX device - it requires two cables. I was expecting only one, and that’s a downside, adding to the annoying web of cables I already have.

Anyway, I’ve connected it this way:

  • White cable is just for power, and goes from USB A port of the MDX (the one for perepherials) to USB Micro of the Mango router imageimage
  • Black cable is for the data, and goes from USB B of the MDX to USB A of the Mango router

Basically, MDX is connected to the router the same way as to PC, and from the router perspective looks like something similar to the 4g modem or phone tethering via usb.

I had firmware 3.215 on the router, and routing between WIFI access point and and MDX usb tethering worked out of the box, after connectiing to the [GL.iNet GL-MT300Nv2 access point.
MDX web interface was accessible by link (modduox.local does not work this way)

Just in case I’ve upgraded the firmware to the latest 3.216, by connecting an ethernet cable to the WAN port of the Mango router to my home internet router, going to the Upgrade section of the router’s web interface in the page.

Also I’ve changed wifi SSID and password.

For the reasons which are obvious I hope, when you are connected to the Mango hotspot - you do not have internet, and MDX does not have it either - you cannot install any new plugins from the store or perform updates. (Might be possible to overcome this by connecting your internet router via WAN ethernet cable I guess, I have not tried to connect to the MDX and home router in the same time, due to physical distance between them).

The router OS is basically an OpenWRT with some visuals makeup from GL.Inet, and software packages can be installed on top of it. Therefore I think it should be possible to install some customized dns bindings to bring back modduox.local dns name to be resolved properly. However, ip address works fine, so I do not bother at the moment.

To conclude:

  • Two cables instead of one, that’s worse than I expected.
  • Setting this up was quite easy and straightforward, at least for me, stock firmware was fine.
  • You lose access to the internet, store and updates while connected this way, to install plugins and updates you would have to connect USB cable to your PC instead as usual.
  • WebUI has to be accessed by IP address rather than cute dns name.

From my point of view it seems like quite a working solution.