Using global tempo freezes MOD X

I have an issue with my MOD X - after assigning global tempo to any knob (lets say knob 1) my MOD freezes, knobs and buttons do not work. I need to turn off mod and then it starts to working, but again, when I use the knob with assigned global tempo the situation repeats. It is not possible to comunicate with mod then by web browser.

I tried to reproduce your issue on my Mod Duo X but here it works.
I’m using V1.11 RC2

Thanks for checking it.
I have this same situation (mod x crashes) if I set global tempo divisions to any knob.

Assigning tempo and division works here.

Would you be able to experiment the V1.11 RC2 and let us know if the issue is still there?

I’ve connected my modx yesterday to local and there was a note that my device is up to date so it seems I can not make any update.

The next v1.11 is still under testing phase so it is not available as update just yet.
Anyone willing to try it has to be in the testers group (PM me or someone from the team for that), or otherwise apply the update file manually.

1 Like

ok, I did’t know that. How can I join PM? I love my modx so I would be really happy to become beta tester. Is there any other users which has this same issue with global tempo?

1 Like

by PM I mean personal-message or direct-message, like, just say you want to be in the group to receive RC as regular releases and anyone from the MOD team and set that up.
The only thing needed is the device serial number.


offcorse, I will send my serial no. later this day.

Alternatively you can test the beta version (

1 Like

I had not to much time to test but It seems the update solved the problem.