Unable to connect / access GUI with Mac Catalina 10.15.7

Everything worked fine until yesterday… No way to access the DUO X GUI interface (USB connection) under Catalina 10.15.7

  • I tried another cable
  • I tried to plug / unplug the USB port of the DUO X
  • Ping fails

Haves spent hours already on this issue… NO solution so far… Please help !

Hi Olivier, I’ve got the exact same Catalina version and it works fine with my DWARF.
What is your web browser ? For exemple, i’ve never had any problem using Firefox but I assume the web gui is not optimized for Safari.
Also, did you try to reboot the DUO X, letting the USB cable pluged to your Mac ?
I don’t have any other idea but I’m still a newbie with Mod’s technologies.

Does the browser show a message about https/secure connection not available, or even using http also does not work?

I have same situation on my Dwarf but I’m on PC.

Tried on 2 windows 10 machines, no firewall, Dwarf recognised as a network , not able to connect on Firefox, Chrome or Edge including incognito modes on all of them. And yes tried different usb cables and sockets.

Super frustrated

On Windows with the Dwarf you have a device menu option to switch the USB mode.
That typically helps, assuming you have an up-to-date Windows 10 or 11.

1 Like

Cheers Falk - worked a treat


Hello Everyone. I have the same problems of Austin73, so my dwarf does not connect to pc (win 10 64bit, chrome). I set the “usb mode” on network (default) and also net+midi, but, nothing it still does not work. The message is: moddwarf.local refused the connection.
who can help me?

thanks in advance


Hello @francesco!
Have you tried to install the driver available here?
Let us know if that solves your issue.


Thanks Jon. installed the driver, now it works!


Perfect! You’re welcome :slight_smile:

1 Like

Thanks to you, Jon!
Another problem that I had not mentioned concerns the power supply: in fact, I initially used the one supplied which however produced a lot of noise - then I tried to replace it with a universal one (12 V +, 1A) which instead worked very well, therefore without any noise. is there perhaps an explanation for this?
Thanks in advance


1 Like

Yes. That power supply is not grounded. What you were facing with the other power supply was a ground loop issue.
I can’t really advise you to use the replacement power supply. Anyway, if it works…well, it works.

Allow me just a particular note here: the supplied power supply has 2A and the one that you are using now has only 1A. You probably noticed the device being a bit slower to turn on.
This may also affect the performance if you connect peripherals on the MOD Dwarf (such as Control Chain devices or MIDI controllers). Also, in a future update we may need to pump something up and that may result in the device no longer working with that particular power supply.
With a 2A power supply, you will be safe to know that no issues will pop up.

1 Like

Ok Jon, so i seem to understand that i need a new universal ps but with 2A, right?


Exactly :slight_smile: At least I advice you to do it