This site can’t be reached? Too long to respond

Any idea why this keeps happening?

When I try to connect to the ip address I always get this message:

This site can’t be reached took too long to respond.

Only after several attempts I’m able to connect.


Could it be a firewall or antivirus problem?

Depending on your computer/firewall/antivirus+sniffer it might affect the DHCP client in obtaining an IP address. You have to keep an eye on your the network indicators to make sure the MOD network interface is up and it received a valid IP address.

So next time you see the issue I suggest you open watch closely the network interface and check what status it’s in. If it says “acquiring address…” or “connecting…” it’s still working on the DHCP handshake. If it says “established” and you can verify the IP address has been assigned the browser should be able to connect immediately.

If you have a established connecting but the ui won’t load, try pinging and see if you get an answer.

Once you’ve debugged it a bit it will become more clear what the problem is. From my experience Windows has a long history of showing different behaviors depending on which driver/windows/security software you have installed.

Also you might want to check a different USB cable just to eliminate that from your list.

I also found some oddities on our code that were producing similar behaviour, but strangely the same code worked fine before.
As browsers keep changing all the time maybe some behaviour regarding this as changed…

Please keep an eye open for the upcoming 1.2 release, there’s some changes in there that affect this, although I can’t promise it will fix your specific case.

Thanks guys…yeah it says connecting a lot. This always happens to me. I need to refresh about 1-5 times before the MOD interface opens. I can live with it.

But as I was playing around with it tonight it kept disconnecting. At the time I was in a pedalboard that had around 80-90% CPU. I tried stuff like closing the browser (chrome, windows), disconnecting, shutting the mod duo off. But it loaded up but disconnected after a maybe 5-20 seconds or so.

But one time during these seconds or so I managed to switch pedalboards to one that only was around 60-80% CPU and then it was fine.

So I guess you run a risk of some problems if you set up a board with over 80% Cpu?

Ps. a quick noob question…so this IP address…I guess one does not need the internet to connect a mod duo to the mod interface? As there was no internet where I was tonight I was plesantly surprised that everything worked without me having to connect to the internet. Being a noob I thought using a browser like chrome required an internet connection. Does this IP thingy work like að home network then?

The MOD provides a network interface.
A special one that only includes a specific address. The webpage you see under runs inside the MOD.

PS: If your last pedalboard is too heavy and the web interface takes too long to open, you can browse the banks via HMI and load a different one.

I am having the same problem and after refreshing over five times it is still giving me nothing.

We need more information to know what exactly is going on for you…

Did it work before for you? Or you’re using the MOD for the first time?

If you’re using Windows, might be worth to check if the MOD Duo is using the correct drivers.

New, yes. I have a weird laptop where things don’t work for a while then i go back and they work again. This was one such thing that worked the next day. Thank you for your reply though! :slight_smile: