[SOLVED] MIDI DIN OUT port issue

Hey folks,

Happy owner of Mod DUO X. Recently, I’ve tried to use it as the main clock source to all MIDI-capable devices connected via MIDI thru box. I’ve encountered the issue where it seems that no matter what, there is no signal going out on the MIDI DIN OUT port of DUO X, although MIDI DIN IN works perfectly fine. Running the latest (v1.9.3) version.

Until now, I’ve checked all of the obvious things: double-checked the MIDI cables and tried other ones, tried connecting gear directly without the MIDI merge/thru boxes. It seems that enabling the internal clock option and toggling ‘Send MIDI clock’ option in the system settings doesn’t have any effect. I tried connecting DUO X’ MIDI OUT port to the MIDI IN on another interface, and it seems neither clock/start/stop is arriving, while with the other gear connected, I can successfully see it.

Are there any other debugging actions I can do to determine if the MIDI OUT port is busted or not? Is it possible to “swap” the ports (MIDI IN w/ OUT) somehow?

I have seen this issue before in 1.9 myself too.
But while developing v1.10, couldn’t reproduce it anymore. Since we are moving forward with that ASAP, we didn’t look further.
We just finished fixing the last remaining known issue for the Duo X, so release can happen anytime now. We just need to fill in the details on the wiki and make the forum post :slight_smile:


It took me a while to upgrade to 1.10.0, but can confirm that the issue now is resolved, thanks!