[solved] Dwarf does not recognise widi jack

Hi folks

I’m a new dwarf user trying to connect touch osc via iPad and widi jack

The widi jack is configured and connected ok to the iPad and is plugged to the dwarf serial ports but the dwarf does not seem to recognise it.

Anyone experienced this or ideas to solve?

Much love x

Hi and welcome

The only problems I have with the midi jack are quite dumb :

  • reverse the input and outputs
  • not plugged the jacks as much as it should in the dwarf
1 Like

thanks Man, yeah it’s often the little things I agree, in this case though I’ve checked through that (more than once!), still no joy…

I’m sure there will be an obvious answer to this!

1 Like

By ‘not recognise’ I do youmean that no MIDI messages have any effect?
I’ve had to do some ‘debugging’ to see what MIDI is incoming as follows:
At the bottom of the web interface is a MIDI icon, clicking will display a small dialog. Does the WidiJack appear?
Try aggregated (so all midi comes in one one midi socket), navigate to the pluginstore (I’m not in front of my Dwarf so can’t recall exact link, but it is one of those in the bottom left) make sure you have beta plugins enabled and search for midi monitor (I think it is called). Install, add to a p’board and then connect it to the Lefthand MIDI input … it should show any MIDI messages that come in.

1 Like

Thanks for this. Yes, it looks like my midi messages are getting to the Widi Jack ok but then nothing hitting the Dwarf.
The plugin is called Midi Display and thanks for the link to that as I was wanting to find something that would validate exactly what is and isn’t being seen by the Dwarf. I also have a hotone ampero control wired in via usb midi and the Midi Display is tracking beautifully for all of the CC messages I’m sending that way.
I’ve also tested succesfully with a Komplete Kontrol keyboard. My conclusion at this stage is that midi works fine over USB, my problem is that I now can’t be sure if I have an issue with the Widi Jack (seems strange as it registers fine, latest firmware and I can see the midi messages hitting it ok with the flashing blue light when I send the signal) or if there is an issue with the Dwarf sending and/or receiving through the serial port.
I did have the thought of trying to connect the ampero control to the widi jack to see if this would register however not been able to work that one out yet!
The whole point of the widi jack is for me to be able to lose the USB cable for a keyboard controller in live situations. I’ve got a korg air on the way, I think at this stage I will test again once it arrives, if it doesn’t work then for now at least I’ll have to accept the cable (and perhaps swap the air out for something with bigger keys…)
Thanks for your input though, really appreciate it

1 Like

@andybassdoyle I think we didn’t check one thing (and the possibility that the problem is there is huge): how are you connecting the WIDI Jack to the MOD Dwarf? Are you using any TRS to DIN adapter? Please be as descriptive as possible here.

I’m asking this because I believe although you have type A selected on the WIDI, the cable that you are using to connect to the Dwarf is reversing it.
If it helps, share a short video.

Hi Jon,

Airkeys here now so have taken a couple of vids which hopefully will help, let me know what you think…

Many thanks,


1 Like

I’ve watched your videos and it looks like you’re doing everything exactly right. At this point, I think it’s safe to say that either the WIDI Jack A/B switch is broken or its output jack is broken or the Dwarf’s serial input is broken.

1 Like

Yep !
Can you test the midi input of the dwarf by connecting your keyboard into it ? (with a cable)

1 Like

Thanks gang,

Yeah this is kinda my conclusion. Unfortunately the Dwarf and Widi Jack are the only TRS bluetooth devices I’ve got so very difficult to test any further and narrow things down.

I’m planning to check the plugins for something that will generate a midi message so I can see if it’s possible to send this out to the Widi Jack. Appreciate that my problems might be on the Widi Jack out and Dwarf in so I’ll be testing the ‘wrong side’ if you like, it removes at least one other piece of the puzzle though.

I’ve raised this separately with CME of course as well including today’s vids, will keep you all posted with whatever they can tell me.

Thanks for everyone’s comments and help so far!!


1 Like

So the ‘output’ test was successful:

Keyboard into Dwarf via USB, then route USB input to Serial Output (aka Widi Jack). Widi Jack then connected to iPad, successfully triggering piano.

From this I can conclude:

  1. TRS Midi cables both work (I tested with both btw)
  2. Dwarf Serial out and Widi Jack in are both working ok
  3. Widi A/B switch is ok (there could still be an issue here perhaps, seems unlikely though)
  4. Issue must be with either Widi Jack out, Dwarf Serial in, or both
  5. I need to stop obsessing over this and have a beer

Would really appreciate any other suggestions on how to test. Mod people in particular, do you think there may be a Dwarf fault and should I raise this separately with you for attention? I am asking the same question of CME re the Widi Jack.

Much love



Good science there !!! Conclusion 5 may be too low on this list though…


Just had a watch of the videos. I believe you mention that you have the latest firmware on the Widi Jack?
One thought occurs, the Widi Jack seems to be powered up by pluggin in the TRS connector. I’m confused as to how this can happen as I do not believe the spec defines power supply over TRS connectors.
I wonder if there is any chance that the WJ is not getting enough power to drive the MIDI in on the Dwarf? Might be worth (as it is easy) trying supplying power to the WJ via its USB connector and seeing if anything changes.

1 Like

Hi Smanth,

Yeah I thought that too, tried it, no difference.

On the plus side the cme folks are sending a usb version of widi jack for me to test. Only other thing I can try now will be a trip to my local music store to see if I can id the cause



Morning folks - so I can confirm the issue is the output of the Widi Jack.

I found a 3.5mm TRS cable last night (the Widi cables are 2.5mm to 3.5mm of course) so looped the Dwarf serial output to the serial input. Set up a sequencer to send midi messages to the output (which we already know works from previous test) and then linked the input to the midi display.

The midi display beautifully registers the correct note messages from the sequencer.

Conclusion - Dwarf is working fine (phew).

Both Widi trs cables are fine as well so the issue must be with the Widi Jack itself.

I’ll let CME know but they have already very kindly sent me a USD device to test so hopefully this will be fine.

MYSTERY SOLVED!!! Yay, a bit of job satisfaction there

Thanks to all for your help. I’ll report back once the USB Widi is here, hopefully will all be fine!



Morning all,
Wanted to do a quick update on this.
First of all a big shout to the folks at CME. They were extremely supportive with my original problem and once I had identified the issue was with the Widi jack they immediately offered to send my a Widi USB pro to try instead.
The package arrived 3 days after sending with the USB and a replacement Widi Jack, all FOC.
Thanks CME, much love x

The replacement widi jack works just fine however the USB appears to me to be a little quicker connecting plus it is cleaner from a physical perspective as we have no more wires or magnetic clips etc to hold it in place. Just sits in the USB hub. Excellent piece of kit.

So I now have a Launchkey 37 wired in to drive generators and midi, I also route it through to the Widi USB which can then drive Moog Model D on my iPad.

Works great. The only bummer is that the Launchkey does not operate over BT but frankly I struggled to locate anything at a reasonable cost that had a decent form factor (Korg Microkey air keys are just toooo small), controls for CCs (filter cutoff etc), and operated over BT.

The CME Air 37 was the only contender really but no additional controls…

Be interested if anyone else has been exploring this.

Anyhoo, thanks again folks for your help with all this!




Sorry @andybassdoyle but I don’t understand why you said “mystery is solved” (perhaps because I’m not english native ;-). I only understand that your problem is solved with a “CME USB” (Uhost ?).

I have also tried without succes to make my new Mod Dwarf work with my CME Widi Jack (with 2.5mm-3.5mm). I know that both the CME Widi Jack and the cables work fine because I use them with another stuff.

So I’m very interested if you can precise the situation :grin:

Hi there - I’ll do my best to explain

My problem was with the Widi Jack and I was able to confirm this when CME send the USB item - that was what I meant by problem solved

If you’ve used your Widi jack succesfully with other devices this suggests a problem with dwarf. Have you been able to route midi with dwarf with any other devices?

Best Regards,


1 Like

Thanks for your explanation.
No I didn’t try another midi controler with the dwarf because I haven’t got another one with 3.5 jack!

I have no problem with the WIDI Jack and my Dwarf, so it’s not a system problem, it should work straight out of the box !
I had some troubles when :

  • I messed up connecting the midi-output of the Dwarf to the input of the Widi (it’s really easy to do some mess here because the ins/outs are on the back, I had to take some habits to make it right each time I plug this thing)
  • I plugged the jacks not deep enough into the Dwarfs in/out

Can you confirm (even it it seams obvious) you’ve checked those points ?

Does your Widi lights up ?
(the Dwarf powers the Widi, that was a good surprise for me !!!)

1 Like