Release 1.9.1

Hello everyone, a “bugfix” update for the 1.9 series is here - v1.9.1 aka “Mainline is here, so hot right now”

This is a major bug-fix release that brings mainline kernel support for the Duo.
Additionally, pedalboard snapshots can now be triggered with MIDI Program Change messages while the web GUI is open.
We have fixed a couple of bugs too, see the full changelog below for the full list.

One very important point is that for older Duo units (the “NAND” models), this update will not automatically use the new kernel.
Please check this link for more details.

And for those that missed it, we have an overview of v1.9 new features in our blog.

Hope you enjoy :slight_smile:

Here’s the full changelog:

  • MOD Duo with 5.4 LTS mainline kernel
  • MOD Duo with mainline mtd drivers and ubifs over NAND
  • MOD Duo X: finalize support for rk3399-based units
  • MOD Duo X: set “44.1kHz de-emphasis” and “DAC invert” controls to true by default
  • Allow pedalboard snapshots via MIDI Program Change messages while web GUI is open
  • Fix buffer overflow in Control Chain lists with items bigger than 16 characters
  • Fix MOD Duo trigger controls doing nothing (regression in v1.9)
  • Fix dragging plugin out of bounds under Firefox
  • Fix plugin store carousel animation and positioning
  • Fix priority of screenshot process (could lead to xruns in some cases)
  • Fix wrong initial “true bypass” state in some cases

The next time you open the MOD web interface you’ll receive an update notification.
Just click on the tooltip icon in the bottom-right when that happens, then ‘Download’ and finally ‘Upgrade Now’.
Wait for a few minutes while the MOD updates itself automatically.

We hope you’re enjoying your MOD Duo and/or MOD Duo X.
Let us know if you find any issues.


@falkTX the link does not work

Yes… something is wrong with the auto-update on the Duo. so release is taken down for the time being…
Investigating as we speak.

1 Like

We have fixed the issue, just pushed the actual duo update.
Those with a Duo unit that updated to 1.9.1 early, the next time you try an auto-update it will fail on the install phase.
You can manually install and get it all working again.
Sorry for the inconvenience!


This release is really good on CPU performance. I’m able to run pedalboards which include the JCM800 simulation and the Calf Multiband Limiter at the same time. Before, I could barely use just one of those.
Whatever changed here, seems to have optimized CPU usage in a significant way.

That said, I am experiencing various stability issues. Although, I don’t have enough experience with the release to say just yet.

In any case, great progress here! Many thanks!



I have the Kickstarter ModDuo and it was dusting somewhere since I got it. I am trying again to make a good use of it, but I have a problem updating it.

I open the GUI in my browser and I am prompted to make an update, I download it and when it starts upgrading it instantly stop and says “Download Failed”. What am I doing wrong? Didn’t find an answer searching the forums.
I guess I am still at version That is what is in the URL of the gui

ModDuo KS, Windows 10, using a cellphone as my modem is that a problem?

Likely it is not possible to update from this version as it is too old.
You can try to manually update to v1.6 (from and then do the auto-update

1 Like

I’m a bit late in updating my mod. I have a nand one so I tried to follow the instructions at but they do not work. Specifically, holding down left pedal button and knob while powering on does not result in MOD LEDs turning blue and a special disk appearing on my computer. Instead MOD boots normally. However, when connecting to the mod to my computer there was a prompt of a required upgrade to so I did that which worked fine. Tried again the hold down left buttons which booting, still no effect. Do I still need to “recreate my flash data”? Am I missing something with the hold-down-knobs-while booting trick?

I just got around to it today and I had the same problem, also with a nand one.

I got it to work by following the section at the bottom of the page - “Manual deploy from FEL”, using the command line utility on a linux machine.

It does make a difference over just installing the update from the gui. If I ssh into the mod I can see the kernel is updated to 5.4.x whereas it was 3.4.x before. It’s also shown on the settings page in the gui.

Also make sure you backup your pedalboards before you do the update. You can do that from the settings page of the gui to back up and restore using a usb stick.

After the nand update I had all the default pedalboards that I hadn’t had before and then after restoring from the backup I have both my pedalboards and the default ones.

1 Like

Since the update I’ve been having a problem. The audio seems to drop out for about 5 seconds every 90 seconds.

edit: Looks like it’s this issue Purchased pedals are in demo mode