Release 1.13.1

Hello everyone, a bugfix update for the 1.13 series is here - v1.13.1 aka “All pedalboards welcome”.

This update fixes most performance regressions when compared to 1.12, by reverting some of the changes in 1.13.
There are a few other important fixes for issues reported by users.

Hope you enjoy :slight_smile:


Here’s the full changelog:

  • Fix MIDI program changes not matching loaded pedalboard (Duo and Duo X specific)
  • Fix performance regressions in 1.13 (downgrade glibc to 2.27, more system-level tweaks)
  • Relocate transport to frame 0 on playback stop

Dwarf specific:

  • Fix selected pedalboard mismatching when removing pedalboards from banks on the device
  • Fix a newly created bank becoming the active bank when created on the device

The next time you open the MOD web interface you’ll receive an update notification.
Just click on the tooltip icon in the bottom-right when that happens, then ‘Download’ and finally ‘Upgrade Now’.
Wait for a few minutes while the MOD updates itself automatically.


We hope you’re enjoying your MOD unit.
Let us know if you find any issues.

7 Likes

Performance (on Dwarf) seems a lot better again!

6 Likes

Upgraded an older Mod Duo to this release and it doesn’t like it :frowning: I’ll admit it’s a dev version, I always use that one to test new releases and this is actually the very first time ever it bails out. I selected a Shiroverb pedalboard and then the unit went poof. I’ve reflashed it like 10 times now, even managed to revive it but after having flashed this bugfix release the unit boots into this Shiroverb pedalboard again and locks itself up (probably because that pedalboard is too resource intensive). Any way to revive this unit again without it booting into this too hefty pedalboard? I wouldn’t be surprised if something else is faulty (eMMC/NAND), this is more or less a depreciated unit which was tagged as a dev version.

For those very old units please do a full factory reset as instructed on Troubleshooting Reinstall Duo - MOD Wiki
A couple of years ago we updated from the now super-old 3.4 kernel to mainline, providing not just a fresh kernel and mainline experience but actually helping making it more reliable due to old nand always being a bit subpar in reliability. The mainline kernel setup we have has data duplication (reducing half the nand size but making it more robust), together with kernel-side service/watchdog that keeps checking for nand data bitflips and correcting them automatically.

In short: please do a full factory reset in order to get the mainline kernel benefits as soon as possible.

The http://192.168.51.1/settings.html page needs to show 6.1.15-rt7 as the kernel, meaning good :+1:
If you see 3.4…, it is bad :-1:

Let me know how that that works for you.

PS: Nice to see you again on the forums Jeremy!

2 Likes

Just as I typed this the unit came back to life. Let’s hope it stays that way.

1 Like

Thanks for the quick reply Filipe! I already did a complete factory reset when the unit failed at first and saw that it was running a 6.1 kernel after that. Great to see it’s following mainline so closely!
It did fail again after that factory reset so I did a new factory reset with the 6.1.15-rt7 kernel. Maybe I’m being too impatient too :smiley: Whenever it locks I should try rebooting it a couple of times instead of reflashing it again :roll_eyes:

1 Like

No more CPU jumps with long convolution reverbs. Thanks!

5 Likes

So Mod Duo is getting 6.1 while Mod Duo X is still on 4.4?

Yes. Duo needed to be updated to mainline (a.k.a. official linux latest version) in order to keep working reliably. Dwarf already was on mainline since the start.
When updating the Dwarf kernel, it is very minimal work to push the Duo along the way, and preferable too since it is less kernels to patch and maintain.

On Duo X we had to use custom vendor kernel because not everything we needed was available on mainline when we first started. Now getting Duo X on the same version would require several weeks of effort for research and testing…
As long as the Duo X linux kernel still keeps working, there is little incentive at the moment to update it, as it would take away time for other things that need more attention right now.

3 Likes

Thank you for the clarification.

1 Like

Hmmm, this seemed to kill what ever little light there was in the screens and the uodate window does not go away. And nothing is displayed on the display screens…Do not know if the unit has frozen or if I dare trying to reboot it.



Suggestions?
And also no light around the buttons.
And the version says
1.13.0.3090

Hi,

I’ve followed the instruction and also using the latest [modduo-v1.13.1.3122.tar], but now it’s stuck again on the logo.

Here’s what i do, correct me if i’m wrong

  1. I do the MOD Duo Factory Reset (push FEL button) (using Terminal on mac)
  2. I do the Special update for nand units (drag the special file)
  3. It back to recovery again, then i drag the modduo-v1.13.1.3122.tar
  4. It reboot again → Turn green lights → and then green lights off
  5. It stuck on the logo (with no lights on)

I’ve already email the support but still no reply since yesterday
Here’s my serial number: MDS-20170811-1-02-003-0234

Also did a factory reset on my “production” MOD Duo and that unit did better, no weird behavior so far. The wiki was a bit unclear though, I assume that when doing a factory reset it is not necessary to do the special update for nand units? I didn’t do that now, also didn’t do it on the other unit. But both are on kernel 6.1 now.

Correct. the nand update thing is something on another category/section.
The wiki format makes this a bit confusing, maybe they should be separate pages…?

1 Like

Took the liberty to clarify the note on that specific Wiki page. Also added a bullet point to create a backup first.

2 Likes

I’m a bit scared to load this on my Duo X since it bricked @modfox’s unit, has anyone else installed it on their Mod Duo X and got it working?

worked fine for me. At least update itself.

P.S. I do not know if it is something introduced by 1.13.1, or beta plugins I use, but sometimes some knobs stop working in main web ui for some pedals in the whole pedalboard interface. For example, mod switchbox channel switch. Meanwhile, same knob works fine inside plugin’s config menu. Had not noticed anything like that before. MDX.

just installed 1.13.1 on my Duo X
two issues at present…
i. pressing right encoder engages the pedalboard but the interface doesn’t show until i press the left encoder
ii. on start up right screen shows two dark vertical slabs over the X, these then spread out into vertical lines which are making some screens/pages hard to read.
nb: just noticed that the vertical bar ’ seems to relate to the top row of text…pattern’
anyone else experiencing this?