Release 1.11.4

Hello everyone, another bugfix update for the 1.11 series is here - v1.11.4 aka “I can now play a whole 8th note!”

This update brings quite a few bug fixes, enough to deserve a new release.
We also changed a few things on the MOD cloud side, which requires us to push an update (MOD downloads now use https everywhere)

Hope you enjoy :slight_smile:

Here’s the full changelog:

  • allow knob tooltips as parameter comments in web gui settings dialog
  • bump maximum allowed JACK clients of Duo X to 256, Dwarf to 128
  • fix a few issues around the search boxes in web gui
  • fix control chain device updates (fixup for server-side change, requiring https now)
  • fix handling of big messages from web gui to host/plugin side
  • fix installing pedalboard missing plugins when used more than once
  • fix potential bank reset (to “All Pedalboards”) when loading pedalboard from a MIDI program change message
  • fix snapshot index not being reported to device when changed from a MIDI program change message
  • reset device settings when doing a user data factory-reset

Dwarf specific (device side):

  • fix bypass controls in momentary mode
  • fix system popups opening on top of each other
  • fix momentary mode toggles stuck when triggering navigation mode popups
  • make only first button close information popups

The next time you open the MOD web interface you’ll receive an update notification.
Just click on the tooltip icon in the bottom-right when that happens, then ‘Download’ and finally ‘Upgrade Now’.
Wait for a few minutes while the MOD updates itself automatically.

We hope you’re enjoying your MOD unit.
Let us know if you find any issues.


I am !
thanks to all the team ! :heart:


Oh, @falkTX , guess what?
Can’t install the update. :frowning: AGAIN. Does the same thing as before - hangs up and does nothing. I really don’t want to have to go through the whole “wipe the Dwarf and reinstall the OS” thing again.

1 Like

@Roachmanfwa are you using any particular pedalboard or any particular plugin when that happens?

1 Like

I think that I’ve been in all different ones that I created. I may even have been in some of the MOD-provided ones. I’m pretty sure I haven’t been in the same one each time I’ve tried to upgrade the firmware.

It’s really really weird. Do you also have all plugins up to date?

I think so - I’ll check later when I’m able.

1 Like

I checked and updated all of the plugins. I then started the firmware update. About 45 minutes ago. On the Dwarf it’s the usual page but the knob settings are blank. The GUI has the “Auto update in progress, please wait…” screen. When I push the buttons or knobs on the Dwarf, there’s no response.

ok, maybe we need to recall the device to check what is happening.
Please write to, add your serial number, if you don’t want to write the issue again just share the links for this talk and the others where we talked about this. Maybe also add your address for the return label

1 Like

This is NOT what I’d hoped to hear. :frowning:. I’ll contact support and get this ball rolling. I just hate having to be without my Dwarf, though!


I’m sorry @Roachmanfwa it was also not what I wanted to tell you :frowning:
But unfortunately it seems that your device has an issue. And well, look from the bright side, your MOD Dwarf was not in the best shape, will now come to the “doctor” and get fit so you can use it in its full potential.
If we confirm that there’s really something wrong on the hardware level, sooner or later that could start popping up on other areas of your usage.


I had the same with my MOD DUO, followed the update steps, but the software got stuck when booting. Had to send it back for repair and had to pay for it because it was out of warranty. I’m not gonna update it again, quit disappointing,

Your issue was most likely quite different and would have happened at some point regardless of whether you updating the device or not. I’m not exactly sure of what happened in your case, but if we charged you for the repair it was because one of the electronic boards was damaged and needed to be replaced. This doesn’t mean that you were misused, but that you were unlucky and that particular board got faulty.
I wouldn’t advise you to not update the device because of it. More than losing features that can be implemented, lack of update means also a lack of software fixes that sometimes can be implemented to prevent issues like the one you had (or others) to happen.


@jon, when should I expect to hear from support? I emailed them six days ago. It’s starting to feel like the last time I emailed them and didn’t get a response.

1 Like

hmm you should have already if I was finding your email, which I didn’t.
I just double check and didn’t find it anywhere.
Do you have the ticket number? and have you written to

Here’s a copy of the email:

Hi there.

I have a MOD Dwarf, s/n -----. I’ve been having some problems with installing firmware updates. I’ve been in touch with João Neves and Filipe Coelho about this. The problem showed up when trying to update to 1.11.1 Release 1.11.1 and then with the most recent update, 1.11.4 Release 1.11.4 - #11 by Roachmanfwa João said that I might have to send the unit back, which makes me sad because I really like it! Anyway, please advise what to do next.

Tom Roach II


I’ve edited your post. It’s not really the best idea to share publicly the serial number of your device.

Anyway, can’t you find the ticket number or send the message over there again. I can keep an eye and let you know in DM here if we received it.
Posting it here will not bring much to follow thought and solve your issue.

Please try one more time over there, otherwise, if it doesn’t work we follow up in DMs here in the forum.

Will do.

update worked fine on my dwarf. thanks

1 Like