Release 1.11.0-RC2

Hello all. This is a bugfix for the previous 1.11 release candidate.

We made some small fixes and tweaks since RC1.
Everyone that has 1.11-RC1 build installed, please update as soon as possible.
Those who are in “group 1” testers group will get this upgrade in their mod-ui notification panel.

Please refer to the RC1 topic to read the changes made in 1.11:

Here’s the changelog for RC2:

  • fix loading list-addressings of pedalboards created before v1.11
  • fix snapshots with presets not always loaded correctly
  • improve trigger parameters on webgui (use mouse-down instead of mouse-up, ignore mouse wheel)

Dwarf specific changes:

  • better handling of closing popups
  • correct button led’s when naming widget is empty
  • correct pedalboard list getting out of sync when changing banks
  • fix button actions triggering closed popup
  • fix momentary footswitch display status being incorrect
  • fix crash when deleting active bank
  • fix click list displaying inactive item

Duo X specific changes:

  • fix decimal point missing on negative values
  • fix display flickering when turning pots

Here are the manual download links:
Duo X:

The upgrade procedure is explained at the top of our releases page, here:

We hope you’re enjoying your MOD unit.
Let us know if you find any issues.


Perfect timing!

Just got home and will fire my gear up and get this installed.

Thanks Falk!


No issues, but chiming in to say it is running smoothly on my duo x - thanks!


A little problem with special characters when saving a snapshot :

  • I have a snapshot called Le Père, named with the WebUI
  • I save the snapshot with the Dwarf
  • the name appears LE PRE on the dwarf screen
    And when I overwrite the snapshot the name is still Le Père, so it’s just a print problem on the device.

It’s clearly not a critical issue, though !

I don’t understand the Virtual MIDI Loopback feature (I thought it was this one (I’m not asking, I know a RC is not a time for new features :wink:), do you have an example or a thread witch gives details of the request ?

Thanks for the report. I’m not sure if the dev team was already aware, but if they were not, they are now :slight_smile:

It’s pretty simple. The Virtual MIDI Loopback works as if you were connecting a MIDI cable from the MIDI out of the device to the MIDI In - hence the loopback :wink:
This allows you to do that without actually connecting physically the cable and “wasting” the MIDI ports.


It’s perfect !!! I’ve this option this week to midi-control a on/off with the B footswitch and with a preset of an external midi controller, it works like a charm !

It’s a bit messy though, it has saved the snapshot and loaded the pedalbord very strangely :

  • with the WebUI (and the dwarf) load the 1st pedalboard called
  • save a snapshot called “été 2022” (for exemple)
  • disconnect the WebUI
  • save → snapshot → add a D to the name
  • confirm
    → the Dwaf freeze : display brightness goes 100%, the footshitches and footswitch’s leds stays violet, but the sound fonctions normaly, you can even change snapshots with midi !

Is it possible the something has broken in the bluetouth ? I’m not able to connect with my (old) laptop neither with my (quite new) android tablet. On android the message is “Cannot establish association with MOD Dwarf 01-00506 due to incorrect code or access key.”, is there a pin code ?

1 Like

Another small issue with saving Pedalboards on the Dwarf : if the pedalboard has lower case the pedalboard like Youi → it will be save as a new YOUPI pedalboard.
So you get 2 pedalboards, one that you think is the one you’ve saved but doesn’t include the last changes you’ve made and another one with uppercase that you don’t remember create and is the one you need !


Cool! :sunglasses:

Ok. This really sounds like a bug. I think there’s something being fixed on that, but I’m not exactly sure if it is in what you reported.

I don’t think so. I tried it myself quite intensively this weekend and it worked perfectly.

Yes, 0000

1 Like

I can’t reproduce this bug at the moment, but I have already found some bugs regarding saving snapshots which have been fixed since RC2. Thanks for the update though!

I believe this has something to do with the communication between the WebUI and the device. I have reported this to the devs.


Thanks you two !

I forgot to mention the WebUI was disconnected when I saved the pedalboard with the device.