Release 1.10.0-RC2

Hello all. This is a bugfix for the previous 1.10 release candidate.

We made some small fixes and visual tweaks since RC1.
Everyone that has 1.10-RC1 build installed, please update as soon as possible.
Those who are in “group 1” testers group will get this upgrade in their mod-ui notification panel.

Please refer to the RC1 topic to read the changes made in 1.10:

Here’s the changelog for RC2:

  • Add controls for per display contrast (Duo X only)
  • Add disk usage information to file manager
  • Add opus audio file support
  • Fix bypass change ignored on Control-Chain change
  • Fix Control-Chain list addressing overflow (limit strings to 16 characters)
  • Fix Control-Chain list value set from Web GUI
  • Fix Duo X device snapshot #2 not being saved
  • Fix pedals.css not loaded for some browsers (no async support)
  • Fix reference to MOD Labs when sharing plugins, mention “beta” instead
  • Fix remaining issues with plugin info caching
  • Fix responsiveness of file manager contents
  • Tweak release update wording
  • Tweak/Invert colors of Duo X knob display area (improves usability)
  • Update libsndfile, has much faster seeking (needed for audiofile plugin)
  • Workaround for new Bluetooth 5 devices

Here are the manual download links:
Duo X:

The upgrade procedure is explained at the top of our releases page, here:

We hope you’re enjoying your MOD Duo and/or MOD Duo X.
Let us know if you find any issues.


Great Job !
The issues I mentioned in the lasts posts seems over. Thanks


Among other things: :+1: :eye: :notes:

I didn’t even know there was a Bluetooth 5 device out there supporting networking yet. As mentioned in Web UI over bluetooth very slow - #14 by aspiers I looked hard for one but couldn’t find anything useful yet. However that was August 2020 and since then I see there have been mentions of Bluetooth 5 devices like Asus USB BT500 and Authentication failed and Blooetooth 5.0. So what’s the latest on this?

1 Like

The tools in the MOD system do not support bluetooth 5, but hopefully with a little help it can be made to work.
At least on my side I do not have access to one, so I added a workaround for ensuring it is at least initialized. If it ends up working or not we do not know yet, needs testing.
Maybe it works but in some backwards-compatible way, that would be my guess.

1 Like

hi, i updated the last firmware and after some minutes the interface dont react nice. very laggy or sometimes it freezes. after restart i can use it for 5-10min without any issue.


Can confirm. There is a regression on Duo X limited edition units. It does not happen on production units, which is very odd.

EDIT: does not happen all the time, only in some boots…?

ive tested and its on every start. sometimes it takes 10min sometimes just 5min.
how did you know what version i own? i ask because i have a lot of problems since i ordered from a regular online store. do you have a tip what i can do now


The 4.9 kernel tells me right away this is a limited edition unit.
Visually, the production units have a power switch on the back, while limited edition units do not.

I have a suspicion already of what is wrong.
1.10-RC1 worked fine for you, correct?

sorry i did no tried rc1, but i can if u want.
is there are more differences between production and limitied edition? maybe this is the reason why i got so much ground noises. sory for my english, hard to describe but this firmware (rc2) is the first where the effects sounds good. except the freezes. before i had a lot of trouble with clipping and other or most effects dostn have much impact to my synth etc. i hope you can understand the meaning. sorry

Please do, it would confirm if one of the changes we did in RC2 is the reason or not.
Download link still valid for now,

ok i will. and you are right there is a big LIMITED EDITION on the bottom, lol i never saw it.
thanks for the support. iam sure this is why i got all the problems in the past :confused: i would swap it to a new version of course i also will pay for it. but they had mentioned it in the shop. i payed a normal price :frowning:

feels bad

I am out of the loop when it comes to that, but software-wise that unit model is still fully supported.
We have yet to drop support for a single unit since the Duo (Quadra being the exception for everything).
The first ever Duos were released 5 or more years ago and still kicking despite its flaws.

ok no freezes with rc1. but now i got the old behaviour. like full red output leds at 50-55% level and clipping. with rc2 no red leds at 75% and no clipping. also the effects sound much much better… not so smuddy… this cant happen right? but i swear i dont change any just the fw.
i also added a screen there u can see the noise. i also use the zoia there are no problems.
maybe this all is just a software “issue” since i own the modx i had just problems with restarts, freezes bad sounds settings etc. i wrot more than one emails to support, but never got any answer. :confused:

Many thanks for all new stuff this release brings to us.
Mod team have done a great job.

Here’s the issues I still have concerning footswitch.

  • control chain footswitches still deconnecting when using two control chain footswitches, perhaps CPU load is the cause of this issue?
  • Led status are still not updating correctly when loading snapshots engaging effects in the Web editor.
  • Led 1-2 and 3-4 are still inverted when using the Web editor
  • New bug : I lost 1 caracter on the footswitch screen!

What does work now

  • Switches work immediatly after loading a pedalboard or a snapshot, no need to press switch four times before it works.

So I’m sad to say that I can’t still use two control chain devices with a unit that is made to work with 4 control chain devices…
But I’m still hoping a solution will be there in the next release. :pray:

We are still investigating this. Do you use a lot of list-type addressings on the footswitches?

I thought those were handled now… care to share a pedalboard where this happens please?
It will help a lot with getting more information on this and potentially fix it.

Hah, likely my fault! I put a limit on all strings to 16 characters, as a way to prevent data overflow.
Where is this 1 character missing from? Can you take a picture?

1 Like

Interested of this, as the WIFI support is not a “plug and play” thing right now… And BT 4.2 is slow as hell. BT5 would have “decent” speed?

I don’t use list-type addressing on the footswitches

No need to share my pedal board to find the same issue.
You just have to do a new pedalboard. Just drag 5 or 6 effects and adress effects to footswitches. All is fine, no issue. Save your pedalboard. Then restart the unit and try again and you’ll see the issue is there now!

Only the last character is missing.

The 2 expression pedals from my FCB1010 “Assigning plugins parameters” no longer works. The 1st expression pedal I can assign (receives MIDI Ch.1 CC#0) but the assigned controller then jumps to 0 and remains there unchanged. The 2nd expression pedal I can not assign at all, ModX (4.4.x Kernel) does not respond.
With the old 1.9.x release everything still worked.