Plugin Idea... Start/Stop real time midi message plug in

Is there a plugin that sends real time Start/Stop message? Is this something that can be done?

I have a novation circuit and I’m trying to use my KM Softstep to start and stop it. I have the Softstep plugged into the USB port on the DUO and midi cable from midi out of the DUO to the Midi IN on the Circuit. The Softstep doesn’t send this message (at least I don’t see it) and so I thought that there may be a plugin that I can toggle with the Softstep to send the Start/Stop message.

Your input is appreciated!

I’ve just ported jack_midi_clock to a LV2 plugin… It has a mode “start/stop only” to do what you want.

I’ll ping the mod-team to upload it to the store, source-code is available at

1 Like

That should work. I still haven’t figured out how to take the source code and make it usable in the DUO… This can be my first victim to try to do it. Otherwise I can wait until the MOD team uploads it to the store.

Thank you!

I’ve uploaded a pre-compiled binary for the MOD:

There’s no easy way to install those yet, but if your MOD is connected to a GNU/Linux or OSX box, the following line should work in a Terminal Window:

curl -q | base64 | curl -F 'package=@-'

1 Like

PS. in case you do want to build it yourself, the place to start is

1 Like

Thank you for all the info.
I’m going to give this a try one of these evenings. I’ve been a little tight on time with work, family, home projects… But I think I should be able to do this one when I set aside a little time this week.


We started a blog series that gives you a walkthrough of how to create your own plugins and push it to the Duo :slight_smile:
You can see the first blog post here

Best wishes,
MOD Team


I did it!
I opend a terminal window and used the line you gave me and I have it on my MOD now.

Is there a way for it to sync the Tempo to an outside device like my Novation Circuit?
I don’t know why, but I can’t get my SoftStep to just start/stop the Circuit. I can do it with the Midi Clock plugin.

I’d rather have the DUO tempo synced to my Circuit. Right now, with the Midi Clock plugin, the Circuit is synced to the DUO.

1 Like

Hi Skydiver,

I’m glad to know things work for you so far. To answer your question let me elaborate:

The plugin is prepared to send [musical] time provided by the MOD host itself.
So eventually the idea would be: Slave the MOD-host to an external time master (in your case the Novation Circuit),
the MOD provides time for the Plugin and the Plugin can re-generate timecode/clock. In that case all other Plugins on the MOD will be in sync as well (sooper-looper, step-sequencer, delay…)

At least that’s how things work with DAWs (e.g. Ardour).

I don’t know the timeline for the MOD host to gain tempo/time features, but I do know it’s on the ToDo list.

Adding some specific “repeat” mode to the plugin itself strikes me as conceptually wrong. It would be a stopgap solution for a very specific workflow or a temporary workaround. If it turns out that it’s more than half a year away, I can add some “direct slave” mode to the Plugin as stopgap.

The only advantage to have it directly in the Plugin would be to allow multiple time-bases (e.g. 2 FX slaved to the external Novation, 3 effects synced to the MOD-provided clock and a couple of free-running effects). I can’t imagine a good musical case for that, but maybe Philip Glass can :slight_smile:

1 Like


Hi x42,

I thought the plugin set to Start/Stop mode would get my Circuit to start and stop.
I wonder if I’m doing something wrong…

I see the play button illuminate on the Circuit but nothing happens… The play button turns on and off but it doesn’t play anything…
I’ve changed the sync settings in the Circuit but it doesn’t change anything…

I really like having these Midi controls from Plugins in the DUO. So much easier than trying to program the SoftStep…

I can

Did you try to also send it MIDI clock?

I don’t know the Circuit, but most devices need a clock signal, and start/stop/continue are optional.

With the Clock+Start/Stop mode it works. Also works with Clock + Transp + Pos.
I guess I have a bit of learning to do…

I assigned the BPM to a knob and it won’t adjust in increments of one… I’m working in lower BPM (65 to 70) and I want to change it one BPM at a time but the knob settings, even at the most highest sensitivity it jumps quite a bit… make a lot of difference at lower BPM.

I think this is an MOD team thing… Can we have a super sensitive setting for 127 or 128 steps…?

Just click or shift+click will increase/decrease in steps of 1 BPM.
Click + Drag also goes in steps of 1 BPM, but it’s still hard to hit the correct value.

In any case the numeric display below the control does allow for numeric-entry, you can even set 123.45 BPM. but it’s quirky, with Firefox 45 I need to right-click to enter edit mode. The numeric entry in the setup view (wheel icon above plugin) works fine, however.

And yes it’s a known MOD issue, ideally a plugin can suggest a number of steps (LV2 specs already have semantics for that). Currently the MOD only offers 17, 33, 65 steps for knobs, neither of which is suitable for anything MIDI or fine-grained controls. Also on the Web-GUI the traveled distance (pixels on screen) per step needs to become configurable depending on the mouse-type and screen-DPI… Just some details to be sorted out down the road, I suppose.

I have no problem with the GUI.
I’ve been practicing a song and wanted to slow it down a couple of BPM from 70 to 67 or 68 by just reaching down at the knob without using a mouse. Using the DUO knob it now shows 68.87 BPM and one step up is 71.50 BPM…

I will suggest this update in another topic.

I’ve been using the Clock+Start/Stop setting on the plugin and many times the Circuit will take up to 10 seconds to start.

I hit the “Play” button (assigned to my KM SS).
The play light comes on the Circuit but it doesn’t start… just sits there for a while. Sometimes up to around 10 seconds.

Other times it seems to start just fine…

Any idea why this may be happening?

I don’t know the “Circuit” so I can only guess. maybe some initial sync to match BPMs (but 10 sec is too long).

To troubleshoot it’s usually helpful to simply dump and monitor the midi-stream.

Do you have a computer with a MIDI capable soundcard? If so e.g. connect MOD midi-out -> PC midi-in
check what the MOD + mclk.lv2 sends compared to other devices. If you’re on Mac/OSX: if you’re on GNU/Linux: jack_midi_dump (commandline) or gmidimonitor or kmidimon,… there are various midi monitors for every OS, google is your friend.

Maybe there is a lot of jitter (irregularly spaced events), or maybe you simply have a bad MIDI cable or maybe mclk.lv2 does not send the correct sequence of events (seek, start, clock) for the device at hand (some loopers are also picky and not to MIDI-spec in that regard.

Thanks for the prompt reply. I’m a work so I can’t check it out right now. Will give it a try later. I have a midi interface to my computer so I should be able to check it out.

I’ve been using the standard MIDI connection. I will give the USB connection a try as well.
The cables I have are very old… so it’s very possible there is an issue with it…

So I only got it to do the strange delay thing one time last night. I was clicking between the different modes when it happened. I think it happened when I was switching away from the mode that has Transp. (I’m not at home right now to see the plugin) I was trying to see if other functions worked with the clock on the Circuit set to internal only. I now have it set to clock + Start/Stop.

I did change over to using the USB. (I have a hub off the DUO and the KM SoftStep and my Circuit plugged into the hub) I will let you know if I come across any issues.

I was experimenting a little bit more with this, this morning…

In the Start/Stop only mode in the plugin I see that on the Circuit the Play button turns on and off with the plugin.
So… I figured that the Circuit is looking for some kind of clock… so in the DUO GUI I took the midi output of the Circuit and plugged it into the input of the Circuit. When I hit “start” the light comes on and nothing happens. But when I hit the button again to stop, the Circuit plays several notes in the pattern very quickly… very, very quickly. Sometimes it will just get stuck on one note and just bug out and sound like a chainsaw…
I have no idea what is happening here but it’s getting a bit of clock signal and doing something…

Is there a way I can plug in the midi output from my Circuit and into this plugin so that it can read the BPM and send it back out as clock? I guess I’m asking if I can sync the plugin to an external midi device?
I know in the future you are looking to make it sync with the DUO but it may be a good idea to have a Midi input so that the user can easily define which hardware they want to have synced with this plugin through the GUI without a global BPM.

Some thoughts from the morning…
Thanks for listening…