Plugin Idea... Start/Stop real time midi message plug in

There is no explicit BPM information sent along with a Midi Clock signal. MIDI clocks are just regular ticks, the speed of the ticks defines the BPM.

You don’t need a plugin to just “repeat” or “echo” incoming clock ticks to an output again, just a MIDI-thru will do.

What OS do you use? Debugging these issues is much easier on a Desktop or Laptop… something with a screen and keyboard, anyway :slight_smile:

I have a mac.
Is there a way I can debug this? Or gather information to send to you?

It sounds like such a simple thing… I just want to start/stop the Circuit with my foot…

I don’t have a “Circuit” but that plugin can start/stop Ardour and also and ancient Roland VS-890 that I have around.

Just to be on the same page, can you try as follows:

  1. Add the MIDI-clock plugin to the MOD, disable it (left switch) -> LED off, leave the configuration as default (120BPM, clock, transport & position)
  2. connect the plugin’s MIDI-out to the MOD’s MIDI sink (right edge) using the web GUI
  3. use a MIDI cable to connect MOD “MIDI-out” to the "Circuit’s “MIDI-in”
  4. configure the “Circuit” to sync to incoming MIDI clock
  5. on the MOD web GUI of the Clock Plugin: press the right button (rewind)
  6. on the MOD web GUI, press the left button (roll transport) -> LED on

… stuff to try: press the rewind button while it’s rolling.

Mhh I don’t know a simple standalone software for OSX to generate and dump MIDI-Clock.
Do you have some hardware that can correctly start/stop the Circuit? That would lend itself to investigate what the correct way would be if above procedure does not work,

I will give this a try when I get home tonight.

So I tried it out and it seems to work like it should.

Clock + Transp + Pos
I press play and it plays.
Press play again and it stops.
Press play again and it starts from where it left off. (sometimes it took a second or two to start)
Press rewind and it starts from the beginning of the pattern.

Clock + Start/Stop
Press Play and it starts.
Press play again and it stops.
Press Play and starts from beginning.
Press rewind any time it’s playing and will start from beginning.

Midi Clock Only
The Circuit will play at the BPM set on the plugin when the green light is on. I have to press play on the Circuit to get it to stop.
Press play on the plugin and the circuit stops.
Rewind does nothing.

Start/Stop Only
Press Play on the plugin and the play button on the circuit illuminates but does not start.
When I go to the Tempo page of the Circuit it says SYN. I guess it’s looking for a clock.
I change modes of the plugin to Midi Clock Only and it starts playing at the bpm of the plugin.

The circuit does have a mode to only play at it’s own internal clock but in that mode that light on the play button doesn’t come on with the plugin.

I’m starting to think that the Circuit will only accept a start/stop with external clock.

Ugh… I just want it to start and stop… and play at the tempo set in the machine… :frowning:

@Skydiver Thanks for the elaborate tests!

OK, that’s good info and confirms my suspicion: Only sending Start/Stop Messages without clock are useless for the case at hand. I don’t have nor know a device that solely responds to Start/Stop either. MIDI-Clock in usually relies on the clock signal and start/stop/continue/position are additional optional messages. Then again there may well be some MIDI device where this works.

The first 3 modes works as exactly they should (the 1 second delay in the’ Clock + Transp + Pos" mode is also intentional [1]).

As for the case at hand, sadly the “Circuit”'s manual is not very elaborate. Page 52, 53, 62:
makes it sounds like it’s either external-clock or not. It does not say if there are explicit messages to only start/stop the internal transport or how to control it.

There is another MIDI protocol: MMC (Midi Machine Control): Play, Fast Forward, Rewind, Record en/disable etc usually only supported by HDRs. Doubtful that the “Circuit” sequencer supports those, but it may.

Can you en/disable “buttons” using MIDI? Or MIDI-CC maybe? Might be worth checking what the “Circuit” sends out when you press play while it’s using its internal clock.

Circuit output -> MIDI-cable -> Mac OSX ->

Maybe there’s some dedicated circuit specific MIDI message…

[1] When seeking to a song-position, some HDRs need time to read files or wind tape… so the plugin sends “start/continue”, then waits for 1 second before starting the clock so that all slaved devices can be in sync. This hold-off delay is currently only configurable at compile-time.

Thanks for the explanation. This is really my first time jumping into this world and I appreciate your time to explain everything.

I went through their manual, just like you, and it’s pretty useless…

On eh KM SS there is MMC messages to choose from. I tried them and it did nothing for the Circuit. However, there are Program Changes and Midi-CC which are assigned to different functions on the circuit so maybe there is one that will activate the play button on the Circuit which would be pretty cool… I will ask them.
Here is the Midi Parameters but it doesn’t show anything for the Play except for supported real time messages shown on bottom of page 6.

I have a Tech 21 Midi Mouse for clicking through the sessions on the Circuit and I will click through with it to see if there is a program change that will activate the play button.

Thanks again for your time and support.

I got a reply from Novation.
They are telling me that either the Midi Solutions FootSwitch Controller or the Molten Voltage Start/Stop One Trick Pony should work. “The circuit will still clock off of internal- so you won’t need to send external clock.”

Very interesting…
I may buy one of the Molten Voltage units just to try it…

What do you think?

Hmmmm… :dizzy_face:


Looks like it is possible then. Now one only needs to find out what the correct MIDI message is to start/stop the Novation.

Maybe some SysEx or a specific CC. The “One Trick Pony” does not say what message it it sends, but since it can also control Ableton Live, maybe the Live doc has some info… I’ll dig for that later.

PS. Can you ask Novation what the exact MIDI message is?

I sent a message to Novation to let me know exactly what the message is. It will take a day or two to get an answer. It’s frustrating to not have a cohesive answer from Novation or peripheral manufacturers… No one agrees so I have to keep asking questions… ugh… :anguished:

Can we discuss the Start/Stop message you currently have on the plugin? I have no idea how these things work and I’m just going to throw out some ideas… Maybe there is a tweak we can make to it to make it work. just throwing some ideas out there.

Is it possible that the plugin is sending a single blip message, or some kind of sync message, and is causing the circuit to wait for the clock?

I’m asking because of the scenario below.

In one of my experiments… In the DUI GUI I took the MIDI OUT from my Circuit and plugged it back into the MIDI IN of itself. I also have the plugin plugged into the Midi In of the Circuit. Picture below. Plugin is in Start/Stop only.
When I hit play nothing usually happens except in the Tempo screen it shows “SYN” which I guess means it’s syncing to an external clock. Then I hit the Play button again and the green light goes off on the plugin and the Circuit then runs through about three quarter of a way through a pattern super fast (waaaay over 120BPM) and stops. If I continue to toggle the Play button it sometimes just glitches out on a single note. With or without the glitching the circuit won’t respond to any button so I have to turn it on/off to reset it.

I’m thinking that there is some kind of clock message shot out at some point. When I hit the Play button it gets sent out of the circuit and, because of the way the signal is wired, it’s recycling that message and plays through a loop until it stops or glitches out…

Is there maybe a half a blip getting out of the plugin and then releases another half a blip (I know this isn’t really possible but maybe half a clock signal) giving the Circuit enough information to believe what the BPM is and playing really fast until it recognizes the stop signal?

Can you try this on one of your pieces of hardware gear you have and see what happens?

I’m just putting it out there because my logical mind is telling me that a start/stop message should just tell the machine to just start or stop and it should just play at the tempo set internally. If it doesn’t, then why does the Circuit have a setting to read only it’s internal clock?

I’m getting a real education on this issue through these discussions and I appreciate your time.

Alas, the MOD’s physical MIDI I/O stopped working here. I did 2 things: update to 1.1.0-rc1 (didn’t test MIDI therafter) and then had it out on a gig last night… This morning the MOD does not send any meaningful message at all on the physical I/O. So I can’t test anymore.

EDIT: bah. it was a combination of an old MIDI cable and the MOD – interestingly enough the same cable works fine in other cases. maybe an intermittent contact or just the plug on the MOD. in any case I don’t just get 0xff anymore…

Anyway I can confirm your findings! The MOD seems to have a very long output queue.

After switching to “Start/Stop mode” and pressing start/stop I do receive old clock events. One at a time. Keep clicking and at one point - maybe 60-70 clicks toggle “play” it starts sending start/stop.

Follow up: re-start the MOD, add the MIDI clock plugin, keep it off (not playing) set it to “Start/Stop mode” before connecting it. don’t connect anything else to the same physical MIDI output.

The problem with delayed/queued events seems to be caused if there are more events in a cycle than the MOD can handle… I’ll continue to investigate.

1 Like

OK, I’ve filed a bug report … took 30 mins and the MIDI queue issue is fixed (pre release test build of MOD 1.1-rc2).
I love the short turnaround times!

Things work properly. In the linked video: MOD Midi-clock plugin -> cable -> PC soundcard -> midi-dump

"fa" (hex for binary 11111010) = Start
"fc" (hex for binary 11111100) = Stop
("f8" is a midi-clock tick and “f2” a song-position event)

The leading numbers are delta times (audio samples)


Dude! You are amazing!
I guess I need to wait for MOD to implement your fix and release the update. But these guys are fast and I’m sure we will see it soon.

I’m glad I kept on asking the question… I just felt that there is something there…
Thank you for being patient with me…

I don’t know what all the numbers mean on the video… but it looks good! :stuck_out_tongue_winking_eye:

1 Like

I downloaded the new RC2 release and unfortunately it’s still doing the same thing for me… Play light comes on on the Circuit but doesn’t play anything…

Did it fix it for you?
If it’s working for your gear then it’s something to do with mine…

I haven’t done much experimenting but I have to get to work… :fearful:

I updated to RC3 but still does the same thing.

In “Start/Stop Only” mode it turns on/off the start light but my machine does not actually start playing…

Let me know if you get the same with your hardware…

Things have not changed here. Since 1.1.0-RC2 the MOD sends MIDI data properly.

It looks like the issue at hand is that the Novation Circuit expects some other message to start/stop and not Midi-Clock Start/Stop.

Oh well… Very strange…

Thanks for taking the time. I guess it lead to one issue that didn’t fix mine… :stuck_out_tongue_winking_eye:

I may try the molten voltage unit.