Plugin Idea... Start/Stop real time midi message plug in

I did it!
I opend a terminal window and used the line you gave me and I have it on my MOD now.

Is there a way for it to sync the Tempo to an outside device like my Novation Circuit?
I don’t know why, but I can’t get my SoftStep to just start/stop the Circuit. I can do it with the Midi Clock plugin.

I’d rather have the DUO tempo synced to my Circuit. Right now, with the Midi Clock plugin, the Circuit is synced to the DUO.

1 Like

Hi Skydiver,

I’m glad to know things work for you so far. To answer your question let me elaborate:

The plugin is prepared to send [musical] time provided by the MOD host itself.
So eventually the idea would be: Slave the MOD-host to an external time master (in your case the Novation Circuit),
the MOD provides time for the Plugin and the Plugin can re-generate timecode/clock. In that case all other Plugins on the MOD will be in sync as well (sooper-looper, step-sequencer, delay…)

At least that’s how things work with DAWs (e.g. Ardour).

I don’t know the timeline for the MOD host to gain tempo/time features, but I do know it’s on the ToDo list.

Adding some specific “repeat” mode to the plugin itself strikes me as conceptually wrong. It would be a stopgap solution for a very specific workflow or a temporary workaround. If it turns out that it’s more than half a year away, I can add some “direct slave” mode to the Plugin as stopgap.

The only advantage to have it directly in the Plugin would be to allow multiple time-bases (e.g. 2 FX slaved to the external Novation, 3 effects synced to the MOD-provided clock and a couple of free-running effects). I can’t imagine a good musical case for that, but maybe Philip Glass can :slight_smile:

1 Like


Hi x42,

I thought the plugin set to Start/Stop mode would get my Circuit to start and stop.
I wonder if I’m doing something wrong…

I see the play button illuminate on the Circuit but nothing happens… The play button turns on and off but it doesn’t play anything…
I’ve changed the sync settings in the Circuit but it doesn’t change anything…

I really like having these Midi controls from Plugins in the DUO. So much easier than trying to program the SoftStep…

I can

Did you try to also send it MIDI clock?

I don’t know the Circuit, but most devices need a clock signal, and start/stop/continue are optional.

With the Clock+Start/Stop mode it works. Also works with Clock + Transp + Pos.
I guess I have a bit of learning to do…

I assigned the BPM to a knob and it won’t adjust in increments of one… I’m working in lower BPM (65 to 70) and I want to change it one BPM at a time but the knob settings, even at the most highest sensitivity it jumps quite a bit… make a lot of difference at lower BPM.

I think this is an MOD team thing… Can we have a super sensitive setting for 127 or 128 steps…?

Just click or shift+click will increase/decrease in steps of 1 BPM.
Click + Drag also goes in steps of 1 BPM, but it’s still hard to hit the correct value.

In any case the numeric display below the control does allow for numeric-entry, you can even set 123.45 BPM. but it’s quirky, with Firefox 45 I need to right-click to enter edit mode. The numeric entry in the setup view (wheel icon above plugin) works fine, however.

And yes it’s a known MOD issue, ideally a plugin can suggest a number of steps (LV2 specs already have semantics for that). Currently the MOD only offers 17, 33, 65 steps for knobs, neither of which is suitable for anything MIDI or fine-grained controls. Also on the Web-GUI the traveled distance (pixels on screen) per step needs to become configurable depending on the mouse-type and screen-DPI… Just some details to be sorted out down the road, I suppose.

I have no problem with the GUI.
I’ve been practicing a song and wanted to slow it down a couple of BPM from 70 to 67 or 68 by just reaching down at the knob without using a mouse. Using the DUO knob it now shows 68.87 BPM and one step up is 71.50 BPM…

I will suggest this update in another topic.

I’ve been using the Clock+Start/Stop setting on the plugin and many times the Circuit will take up to 10 seconds to start.

I hit the “Play” button (assigned to my KM SS).
The play light comes on the Circuit but it doesn’t start… just sits there for a while. Sometimes up to around 10 seconds.

Other times it seems to start just fine…

Any idea why this may be happening?

I don’t know the “Circuit” so I can only guess. maybe some initial sync to match BPMs (but 10 sec is too long).

To troubleshoot it’s usually helpful to simply dump and monitor the midi-stream.

Do you have a computer with a MIDI capable soundcard? If so e.g. connect MOD midi-out -> PC midi-in
check what the MOD + mclk.lv2 sends compared to other devices. If you’re on Mac/OSX: if you’re on GNU/Linux: jack_midi_dump (commandline) or gmidimonitor or kmidimon,… there are various midi monitors for every OS, google is your friend.

Maybe there is a lot of jitter (irregularly spaced events), or maybe you simply have a bad MIDI cable or maybe mclk.lv2 does not send the correct sequence of events (seek, start, clock) for the device at hand (some loopers are also picky and not to MIDI-spec in that regard.

Thanks for the prompt reply. I’m a work so I can’t check it out right now. Will give it a try later. I have a midi interface to my computer so I should be able to check it out.

I’ve been using the standard MIDI connection. I will give the USB connection a try as well.
The cables I have are very old… so it’s very possible there is an issue with it…

So I only got it to do the strange delay thing one time last night. I was clicking between the different modes when it happened. I think it happened when I was switching away from the mode that has Transp. (I’m not at home right now to see the plugin) I was trying to see if other functions worked with the clock on the Circuit set to internal only. I now have it set to clock + Start/Stop.

I did change over to using the USB. (I have a hub off the DUO and the KM SoftStep and my Circuit plugged into the hub) I will let you know if I come across any issues.

I was experimenting a little bit more with this, this morning…

In the Start/Stop only mode in the plugin I see that on the Circuit the Play button turns on and off with the plugin.
So… I figured that the Circuit is looking for some kind of clock… so in the DUO GUI I took the midi output of the Circuit and plugged it into the input of the Circuit. When I hit “start” the light comes on and nothing happens. But when I hit the button again to stop, the Circuit plays several notes in the pattern very quickly… very, very quickly. Sometimes it will just get stuck on one note and just bug out and sound like a chainsaw…
I have no idea what is happening here but it’s getting a bit of clock signal and doing something…

Is there a way I can plug in the midi output from my Circuit and into this plugin so that it can read the BPM and send it back out as clock? I guess I’m asking if I can sync the plugin to an external midi device?
I know in the future you are looking to make it sync with the DUO but it may be a good idea to have a Midi input so that the user can easily define which hardware they want to have synced with this plugin through the GUI without a global BPM.

Some thoughts from the morning…
Thanks for listening…

There is no explicit BPM information sent along with a Midi Clock signal. MIDI clocks are just regular ticks, the speed of the ticks defines the BPM.

You don’t need a plugin to just “repeat” or “echo” incoming clock ticks to an output again, just a MIDI-thru will do.

What OS do you use? Debugging these issues is much easier on a Desktop or Laptop… something with a screen and keyboard, anyway :slight_smile:

I have a mac.
Is there a way I can debug this? Or gather information to send to you?

It sounds like such a simple thing… I just want to start/stop the Circuit with my foot…

I don’t have a “Circuit” but that plugin can start/stop Ardour and also and ancient Roland VS-890 that I have around.

Just to be on the same page, can you try as follows:

  1. Add the MIDI-clock plugin to the MOD, disable it (left switch) -> LED off, leave the configuration as default (120BPM, clock, transport & position)
  2. connect the plugin’s MIDI-out to the MOD’s MIDI sink (right edge) using the web GUI
  3. use a MIDI cable to connect MOD “MIDI-out” to the "Circuit’s “MIDI-in”
  4. configure the “Circuit” to sync to incoming MIDI clock
  5. on the MOD web GUI of the Clock Plugin: press the right button (rewind)
  6. on the MOD web GUI, press the left button (roll transport) -> LED on

… stuff to try: press the rewind button while it’s rolling.

Mhh I don’t know a simple standalone software for OSX to generate and dump MIDI-Clock.
Do you have some hardware that can correctly start/stop the Circuit? That would lend itself to investigate what the correct way would be if above procedure does not work,

I will give this a try when I get home tonight.

So I tried it out and it seems to work like it should.

Clock + Transp + Pos
I press play and it plays.
Press play again and it stops.
Press play again and it starts from where it left off. (sometimes it took a second or two to start)
Press rewind and it starts from the beginning of the pattern.

Clock + Start/Stop
Press Play and it starts.
Press play again and it stops.
Press Play and starts from beginning.
Press rewind any time it’s playing and will start from beginning.

Midi Clock Only
The Circuit will play at the BPM set on the plugin when the green light is on. I have to press play on the Circuit to get it to stop.
Press play on the plugin and the circuit stops.
Rewind does nothing.

Start/Stop Only
Press Play on the plugin and the play button on the circuit illuminates but does not start.
When I go to the Tempo page of the Circuit it says SYN. I guess it’s looking for a clock.
I change modes of the plugin to Midi Clock Only and it starts playing at the bpm of the plugin.

The circuit does have a mode to only play at it’s own internal clock but in that mode that light on the play button doesn’t come on with the plugin.

I’m starting to think that the Circuit will only accept a start/stop with external clock.

Ugh… I just want it to start and stop… and play at the tempo set in the machine… :frowning:

@Skydiver Thanks for the elaborate tests!

OK, that’s good info and confirms my suspicion: Only sending Start/Stop Messages without clock are useless for the case at hand. I don’t have nor know a device that solely responds to Start/Stop either. MIDI-Clock in usually relies on the clock signal and start/stop/continue/position are additional optional messages. Then again there may well be some MIDI device where this works.

The first 3 modes works as exactly they should (the 1 second delay in the’ Clock + Transp + Pos" mode is also intentional [1]).

As for the case at hand, sadly the “Circuit”'s manual is not very elaborate. Page 52, 53, 62:
makes it sounds like it’s either external-clock or not. It does not say if there are explicit messages to only start/stop the internal transport or how to control it.

There is another MIDI protocol: MMC (Midi Machine Control): Play, Fast Forward, Rewind, Record en/disable etc usually only supported by HDRs. Doubtful that the “Circuit” sequencer supports those, but it may.

Can you en/disable “buttons” using MIDI? Or MIDI-CC maybe? Might be worth checking what the “Circuit” sends out when you press play while it’s using its internal clock.

Circuit output -> MIDI-cable -> Mac OSX ->

Maybe there’s some dedicated circuit specific MIDI message…

[1] When seeking to a song-position, some HDRs need time to read files or wind tape… so the plugin sends “start/continue”, then waits for 1 second before starting the clock so that all slaved devices can be in sync. This hold-off delay is currently only configurable at compile-time.

Thanks for the explanation. This is really my first time jumping into this world and I appreciate your time to explain everything.

I went through their manual, just like you, and it’s pretty useless…

On eh KM SS there is MMC messages to choose from. I tried them and it did nothing for the Circuit. However, there are Program Changes and Midi-CC which are assigned to different functions on the circuit so maybe there is one that will activate the play button on the Circuit which would be pretty cool… I will ask them.
Here is the Midi Parameters but it doesn’t show anything for the Play except for supported real time messages shown on bottom of page 6.

I have a Tech 21 Midi Mouse for clicking through the sessions on the Circuit and I will click through with it to see if there is a program change that will activate the play button.

Thanks again for your time and support.