Nothing happens with "Try Now" for online pedalboards

I went to and clicked Try Now. The resulting page said

Victory! Your MOD Duo is now loading the pedalboard you picked… Rock on!

but nothing happened on my Dwarf. As well as making it work, presumably that message needs to be updated to not be specific to Duo devices. Does it work on Duo X?

It should work on all units.
Yesterday was working fine for me.

But there are some reports of it not working, we dont know yet why.
Do you have any browser plugins that could be blocking such things? like noscript, umatrix, privacy badget or others.

1 Like

Yes, I have a million extensions. Also I’m using Brave. I’ll try with shields down first…

Hrm, that didn’t help. Any suggestions for how to debug?

CTRL+shift+N will open an incognito window. Most folks don’t have their plugins run in incognito. That should at least allow you to decide whether a plugin is the culprit.

1 Like

open the webconsole on the browser tab that has the mod web interface open, and try to load an online pedalboard. there might be some errors logged in there.

1 Like

Thanks will try those when I have time!

I have this same issue with my Dwarf running Windows 10/Chrome. After clicking Try Now I get the message “Victory! Your MOD Duo is now loading the pedalboard you picked… Rock on!” but nothing actually loads.

Have you tried @falkTX browser webconsole suggestion? which browser are you using?

I got it working. This error was being thrown: A window.confirm() dialog generated by this page was suppressed because this page is not the active tab of the front window. Please make sure your dialogs are triggered by user interactions to avoid this situation.

I had to click try and quickly switch back to the interface page and things loaded.

1 Like

Just in case anyone runs into this issue too:

The “Try now” button expects the device to be running on one of the standard IPs either or . If you are using WiFi you likely won’t have one of those IPs.

I ran into this earlier today and connecting via Bluetooth fixed it.