Morningstar suddenly not recognised

Hi there. I have been using the Morningstar MC6 Pro with the Mod Dwarf with great success for the last year. The MC6 It is also receiving power from the Mod via the USB A port. This has been working solidly until today when the Morningstar suddenly no longer powered up from the Mod. I’ve checked the cable and have managed to power up the Morningstar from my computer. If I plug an independent power source into the Morningstar, the Mod still doesn’t react to the pre programmed midi controls. I haven’t changed anything that I know about so wondering if you know what may have caused this and if there is a fix? cheers. Julian

Unless you try different connections (USB, midi), double check if the morningstar works with other units, triple check if mod works with other midi sources it is difficult for us to guess

Maybe you changed by mistake the midi settings on the dwarf? (The PC values for snapshot or pedalboard change)

I would connect the morningstar to a PC, open some midi enabled program and see what it is sending

Then connect the dwarf to the oc and send the Program Changes it is expecting

Then try to infer what is going wrong

Thank you! I have tried the Morningstar with my laptop and that looks fine. I was wondering perhaps if it has something to do with the latest Mod Dwarf update. I read that someone else had problems sending power to their midi controller after updating. Perhaps I might try returning to an earlier firmware version?

Ok - it looks as perhaps my Mod Dwarf’s Usb A port may have a problem. I tried doing a backup and the dwarf didn’t recognise the Sandisk flash drive…mmmm is there way of running a diagnostic on the ports?

I had a similar problem with my MC6 pro, I had doubts about the Dwarf’s CPU being to high, but in fact I had 2 problems :

  • it was simply the USB cable that was dying, replacing the cable was a relief !
  • the Dwarf couldn’t handle the multiple message at once, to I have set a 2ms delay (in the morningstar setting) between each message

oh… that looks bad…
Does it power the MC6 ? (if yes you could send midi through the jack)

Thanks for the suggestions. I think the problem may be with the Usb A port on the Dwarf. I tried backing up through the port it didn’t recognise the drive either. My workaround is to power the MC6 independently and use the TRS midi plugs from the MC6 to the Dwarf. Now works but now I need to think about how to repair the Usb A port…