MODDUO stopped working


my modduo does not boot anymore. I had an error trough the web interface while making pedalboards, and since the moduuo is stuck on boot screen.
I followed the troubleshooting page, but any attempt to reinstall bootloader or make a factory reset fails with the error :
ERROR: Allwinner USB FEL device not found

Any help appreciated…

I am supposed to play live with my modduo saturday, still no answer today, I understand now that it’s hopeless. I will get by with integrated effects of my amp… it sucks.
What should I do now ? send back my mod to customer service ?

1 Like

Isn’t USB FEL something with booting over usb? How does the mod duo uses this? Is the flash drive connected over usb?

Can someone help gromit?

1 Like

Hi @gromit

Sorry for the delay.

As I remember you’re using Debian Linux correct?

When trying the FEL procedure, are you keeping the FEL button pressed when turning the Duo on? (sorry for the question but sometimes we miss the tiny details :wink:

Last but not least, where are you based. I’d like to know if it easier to ship the unit to us.




yes I am using debian. I can also bring my mod at work to try with windows 10 if it helps.

Yes I kept the button pressed during power up and for a few seconds.

And I am based in France. But I am OK to follow instructions to try to fix it before shipping it back (I am working in electronics, and I designed an embedded linux device some years ago… I am not afraid by command line, or by opening the case if a cable needs to be connected directly on PCB).


1 Like

still stuck. bootfix still giving “ERROR: Allwinner USB FEL device not found”.
I checked the USB cable and USB port of my PC with another device, it is functional.
I tried with the other USB port of the moddevice (port A), just in case, as the troubleshooting page just states “connect via USB” without detailing which port.

So what can I do ? Should I ship back the modduo ? I would prefer trying to fix it if possible with standard equipment.

please help

Hello everyone!
Recently my Mod Duo has been acting weird. It used to be that it needed a few attempts to connect to the browser, to later on starting up but not loading any patches (and not being able to open the banks). Right now it doesn’t start up at all, it just shows this on the displays. I’ve tried to reboot it, tried holding down the left knob+left footwitch while starting up, tried pushing in the FEL-button while starting up - Nothing happens…

Please help!!


Hi @Oskar_Molander

When you hold down the left knob and the left footswitch together and wait for a bit, do the peakmeter-LED’s turn blue?

If so you, when you connect the Duo to your PC, the Duo should present itself as a USB device and you can restore it by putting a release file on it:

Do you know which version of the MOD software you had installed before this happened?

No nothing happens. It just stays like in the picture the whole time…

No unfortunately not. The version that was on when I got it :sweat_smile:

the “hold down the left knob and the left footswitch together” advice was missing the essential part of doing that during boot.
for that I mean, do that while powering on the unit, and keep holding for 5 seconds.
the unit should enter “recovery mode” where you can install the latest release image.
can you confirm if that works for you?

Yes, I tried that. I tried holding them down while powering on the unit. No response at all, no lights turning on, nothing. The displays just shows the logo on the left display and the “Mod Duo” on the right display. I also tried holding them down after powering on, nothing.
I tried holding the FEL-button while powering on, nothing happens. I’ve tried to push every pushable knob/footswitch in every possible order, nothing happens. It just stays on with the displays not changing until I unplug it…

I don’t know what to do, can I ship it to someone to fix it for me?

can you give the “bootfix” method a try, if that does not work then yeah, we’ll have to see about a hw fix.

(not talking about the Factory Reset, that option will delete all your data so we only leave it as last option; though that is also known to work in most cases)

As I said, I’ve tried that too. I’ve held down the FEL-button while powering up, noting happens. I’ve had the Mod Duo connected to the computer via USB, but the computer doesn’t find it. I’ve tried having it plugged in to the computer while powering up, I’ve tried holding the FEL-button while powering up, then connecting the USB. Still nothing. The device is on, but the displays only shows what I said in previous post.

I can’t even do a factory reset, since I can’t get the Mod Duo to connect to the computer.

I have tried every single thing written in the troubleshooting page. I did all of that before consulting to this forum.

I really enjoyed using the Mod Duo so I really want to get it fixed…

Ah I misunderstood, sorry. Just pressing the FEL button does nothing, and I got the impression that is all you did.

Can you please send us a message to ?

This way we will be able to open a ticket and organize the replacement of your unit.
Please specify the serial number of the unit in the email.

Okay, thank you! I’ll do that as soon as I get of work, got the device at home right now!

How long does a repair take?

My unit got delivered about a week ago, but haven’t heard anything. I get no response on the emails and just want to check the status of the repair, or at least get a confirmation that the package was received :slight_smile:



Hi @Oskar_Molander
I’ve just replied to your email :slight_smile:


My Mod Duo is back and working fine! Really fast service, great job everyone! :smiley: