Modduo Bricked

My Moduduo doesn’t boot, frozen on logo. I’m not a noob in computer’s so i tried on one pc windows, one pc linux and one mac osx reflash method like on wiki with left buttons, the emmc (it’s the emmc model) doesn’t showed up. I decided to factory reset the device. Can’t be done on windows on linux too cause i was on arm not on x86, but on Mac os it worked well, so after flash the special reset factory firmware i saw the emmc disc partition to put the reset factory Os (wiki one) unpluged the usb, blue led, white led, red led then green led, and nothing more than a frozen logo… I tried 3 times with differents usb ports and cable and same. So now i can’t do no more here. May be change the motherboard or the emmc component. I done everythings on Wiki never showed up over usb or ip, i suspect the device doesn’t boot and have an emmc dead problem. Tried to contact technical service but they don’t have a solution and ignore me for now… What can i do ? Where to send you for repair ?
Luckily I have a pisound which is stronger. Thank’s for help.

the duo uses sunxi-fel for deploying stuff, so on the downloads from the wiki you can simply delete/replace the pre-built binary and use the system one.
just needs a small edit on the deploy script.

since the leds go blue, red and green during the factory reset, I think your unit might be fine and the issue is something else.

we can easily debug this.
download this

and run: (adjusting as needed, though the SSH=1 is important)

FEL=/usr/bin/sunxi-fel SSH=1 ./

this will boot the unit in restore mode, but give you network and ssh instead of mass storage.
takes around 30-40s to boot.

can you confirm that this works? do you get SSH access?

1 Like

Ok i will do that asap thank’s for help.

So on mac osx i moded the script and flashed with ssh1 but do i need to remove the usb and replug or just try to access to ssh ?

sorry i tried to connect to and it ask a password i think it’s the duo interface.
So i’m in what to do now ?

run dmesg (inside the ssh session) and PM me the full output please.

Hi @Kapi, here is João who was talking with you over the support email.
Just for some clearance, I/we was not ignoring you. I was trying to find time both on my side and with other people to take a more close look at your situation. Actually, by the end of Thursday, I got some input, but I didn’t have time to write you on Friday (I was going to do it today).
Anyway, sorry for the delay.