Hi everyone,

I’m using Wifi now for quite some time, both on my Duo and my Dwarf.
For me it is the absolute best way to control the units, as I can leave the pedals on their pedalboard, have no hassle with cables and no noise from the USB supply.

Worked fine on both units, but recently I updated my Duo to the latest supply version ( ) and since then it doesn’t connect anymore. Checked the /data/wpa_supplicant.conf file, it’s still present and double/tripple checked the passwort and it still seems correct.

“systemctl status wpa-supplicant-wlan0” gives me an “Active” and dmesg shows me:

[ 3374.976147] wlan0: authenticate with d4:72:26:ba:88:e9
[ 3375.015894] wlan0: send auth to d4:72:26:ba:88:e9 (try 1/3)
[ 3375.020815] wlan0: authenticated
[ 3375.027242] wlan0: associate with d4:72:26:ba:88:e9 (try 1/3)
[ 3375.034767] wlan0: RX AssocResp from d4:72:26:ba:88:e9 (capab=0x431 status=0 aid=4)
[ 3375.039671] usb 1-1: rtl8xxxu_bss_info_changed: HT supported
[ 3375.049071] wlan0: associated
[ 3378.172594] wlan0: deauthenticated from d4:72:26:ba:88:e9 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)

Any ideas how to solve this? Also tried to switch the Wifi-Dongles, same result.

Only thing i recognized is, that the “mod-hotspot.service” isn’t present anymore, but since it also isn’t present at the Dwarf, I suspect this to be a remant of an older version in the Wiki.

Which dongle do you use for Wifi on the Duo?

Basically the first thing I got a hold on, in our local electronics market.
Vivanco 36665

Worked flawless for a few years.

It’s kind of generic advice, but while there are no better suggestions - you can try to simplify wifi access point settings.

For example, I had issues with mixed WPA2/WPA3 mode, or access point using the same name for 2.4ghz and 5ghz mode. Works for PC, but confuses embedded devices like raspberry pi easily.

Switching from WPA2/WPA3 mixed just to WPA2 was a solution for one of my cases.

Maybe you have some non-ascii characters in you password or wifi AP name.(like non-english national alphabet symbols). Some embedded devices cannot use too long passwords.

I understand that you say that the same dongle worked before firmware update, but if there was some regression in wifi subsystem of the dwarf, it still could be one of those funny issues.

At least, what I would try for myself in your situation - the most generic AP setup - WPA2-PSK (AES), 2ghz only, simple english alphanumeric SSID, simple english alphanumeric 10 symbols password.

(also evade WPA1, it is so bad that it can be hacked even by a bored baby)

1 Like

Thank you for your answer.
I’ll take a look at the WPA2/WPA3 mode, other than that my passwort doesn’t use any unusual characters and my network already splits 2.4G and 5G into seperate ssid’s and I’m only using the 2.4 for my non PC stuff.

I have 2 dongles, one for the Dwarf and one for the Duo and both work on the Dwarf and non on the Duo.

Only thing I could imagine is, that there is some key missmatch on my Duo. Before the update i had to upload the firmware file seperatly to the Duo to enable the wifi. This is now obsolete with some of the last updates that were pushed to it. Maybe somewhere on the migration it uses a key or config dedicated to the old firmware file.
I removed this file completely from the device, and at dmesg it shows the correct new firmware file, but to no avail.

You can also downgrade firmware to the previous version until issue is resolved.
Doubles as a proof of the firmware being guilty, if it fixes your issue, btw.

1 Like

I’ve always used Bluetooth Dongle… But I think it’s too slow. Today I’m making the settings via MIDI, but it’s limited because I can only configure the parameters that I addressed. I’ll try it via wifi.the problem is I have Duo and it’s up to date as well. I’ll wait to see if you sort this out before I get into that endeavor.

Alright, seems like there is really a problem for Duo Wifi users.
I went back to 1.12 and everything worked as intended, then back to 1.13 again and it stopped working.
Is there maybe anyone else with a Duo and Wifi, who can confirm it’s a version problem?

Also, does anyone know if it is allowed to remount the Duo directories in Read/Write mode?
I would like to replace the current firmware file with the one I know to work, but if possible I don’t want to brick my unit it in the process… :sweat_smile: