Mod Launcher Stopped Working

I have been working successfully with uploading gen~ patches via the Mod watcher until today :frowning:

The watcher returns “Upload failed” and the max console returns error returned from server 500 (phase Uploading…)

I have tried with multiple gen~ patches including the demo’s.

How can it work one day and not the next? Could it be something on my end?


error 500 means server error, something on our side.
@acunha has been doing some updates to the cloud to improve stability, seems you sadly run into a regression there.


Hi @Kevin I just fixed an issue regarding the maxgen pipeline. Please try again and let me know how it goes.


Thanks @acunha I’ll try today.


@acunha Tried again without success - although different error message this time error returned from server 504 (phase Uploading…)


Hi @acunha, tried again today to upload (the gen~ dattorro reverb example patch) and received the following message error returned from server 504 (phase Uploading…)

Btw I updated to the new Dwarf OS v1.12

Any thoughts?

@falkTX @acunha the Mod watcher still isn’t working for me can either of you comment on what’s happening with this? error returned from server 504 (phase Uploading…)

Is there something I need to do to flag this as an issue? If so can you let me know who I need to contact?

My M1 Mac Mini had been spitting out errors using the MODwatcher regarding missing libzstd.1.dylib files in various places. After installing the Zstd library with Brew, that problem seems to be solved. The Mac Mini can finally see the Duo X using MODwatcher. So, I tried again. However, the following error message cropped up:

“ error returned from server 504 (phase Uploading…)”

To be thorough, just tried the install on my Intel based MacBook Pro, and it gave the same error. In both cases, I was trying to install the Simple Vibrato as a test. Also checked the Duo X and it didn’t show up there.

So, one problem seems to be solved (Yay!).

At the very least, this problem doesn’t seem to have anything to do with which chip architecture is being used to run MaxMSP. Don’t know if this helps, but I thought I’d pass it on. I’ll keep my eye out for an update. Thanks for your time.


PS All of the relevant software and operating systems have been updated to the latest versions.


This seems to be a new thing that happened super recently. I already talked with @acunha about this, but he didn’t manage to figure out quickly from where the issue is coming and why it started to happen. So he will need a couple of weeks to look at this.

@lgdyson3 @jon Thanks for taking the time to reply.

So the issue seems to be uploading to the cycling 74 server?

Being so heavily dependent on everything working smoothly on my end, the Mod Device end and Cycling 74’s end simultaneously makes me feel a bit nervous about the stability of the system.

It would be great if I could run the custom MOD cloud build system on my own computer, is this a notion that is outside the realm of possibility I wonder?

I will maybe try the manual upload of gen~ patches described here when I get a chance

If anyone has any experience of doing this I’d love to hear how you got on…

:+1:t2: for local builds.

I tried directly with the and got this output:

Please type your plugin name, then press enter to confirm
Submitting process...
Got release process 62a08e6d7be9543eb3e43883.
Uploading buildroot package...Traceback (most recent call last):
  File "/Users/thomas/Downloads/max-gen-deploy/resources/", line 54, in <module>
    checksum = json.loads(urlopen(release_process['source-href'], data).read().decode())
  File "/opt/homebrew/Cellar/python@3.10/3.10.4/Frameworks/Python.framework/Versions/3.10/lib/python3.10/urllib/", line 216, in urlopen
    return, data, timeout)
  File "/opt/homebrew/Cellar/python@3.10/3.10.4/Frameworks/Python.framework/Versions/3.10/lib/python3.10/urllib/", line 525, in open
    response = meth(req, response)
  File "/opt/homebrew/Cellar/python@3.10/3.10.4/Frameworks/Python.framework/Versions/3.10/lib/python3.10/urllib/", line 634, in http_response
    response = self.parent.error(
  File "/opt/homebrew/Cellar/python@3.10/3.10.4/Frameworks/Python.framework/Versions/3.10/lib/python3.10/urllib/", line 563, in error
    return self._call_chain(*args)
  File "/opt/homebrew/Cellar/python@3.10/3.10.4/Frameworks/Python.framework/Versions/3.10/lib/python3.10/urllib/", line 496, in _call_chain
    result = func(*args)
  File "/opt/homebrew/Cellar/python@3.10/3.10.4/Frameworks/Python.framework/Versions/3.10/lib/python3.10/urllib/", line 643, in http_error_default
    raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 504: Gateway Time-out
1 Like

I’m not exactly sure how this system works, so I can’t really answer you on that, sorry :confused:


Thanks @ascii255 and @jon

This URL is broken

Thanks for reporting @ascii255! This may actually help.


Any update on this? “Couple of weeks” is a quite unacceptable support time for a important feature for some of us…

1 Like

The problem has been fixed. Let me know if things are working.


Everytime I fixed something turns out some other thing was broken… Software is strange because if you leave it alone it actually gets old :rofl:



Yay!! :slight_smile:



I have recently updated to MAX 8.3.1 and am having issues with Mod Watcher. Upon hitting “exportnotifier MODwatcher, exportcode” It does create .cpp and h. files, but the mod watcher only presents as idle, and my patch does not send to the mod duo x. I took a look in the mod watcher patch and noticed that max is not recognising the object []. I double checked that I have the, and that max is pointing to it within both User Library and a seperate User Path, just to be sure. I’ve never had issues in the past. I am currently downloading an older version of MAX to see if that will work, but I would rather not have to do this. Is this a known issue? Any suggestions?

I’ve tried to attach a screenshot of the object in question, and the print log within max, but it seems I am also having difficulty with that :confused:

Here is the print in text: unable to load object bundle executable
2022-07-14 23:15:39.879 Max[27407:778443] Error loading /Users/lukegoldfinch/Documents/Max 8/Packages/MOD Duo/externals/ dlopen(/Users/lukegoldfinch/Documents/Max 8/Packages/MOD Duo/externals/modduo.suppor
t.mxo/Contents/MacOS/, 0x0106): Library not loaded: /opt/homebrew/opt/zstd/lib/libzstd.1.dylib
Referenced from: /Users/lukegoldfinch/Documents/Max 8/Packages/MOD Duo/externals/
Reason: tried: ‘/opt/homebrew/opt/zstd/lib/libzstd.1.dylib’ (no such file), ‘/usr/local/lib/libzstd.1.dylib’ (no such file), ‘/usr/lib/libzstd.1.dylib’ (no such file) unable to load object bundle executable
2022-07-14 23:15:39.883 Max[27407:778443] Error loading /Users/lukegoldfinch/Documents/Max 8/Library/ dlopen(/Users/lukegoldfinch/Documents/Max 8/Library/, 0
x0106): Library not loaded: /opt/homebrew/opt/zstd/lib/libzstd.1.dylib
Referenced from: /Users/lukegoldfinch/Documents/Max 8/Library/
Reason: tried: ‘/opt/homebrew/opt/zstd/lib/libzstd.1.dylib’ (no such file), ‘/usr/local/lib/libzstd.1.dylib’ (no such file), ‘/usr/lib/libzstd.1.dylib’ (no such file)


1 Like