MOD IR Loader Presets: ren/sav/del issue


Using the MOD IR Loader pluging:
Saving and deleting several presets with 3rd party IR’s end up not being saved after adding and editing some.

I noticed that some of the presets sounded like the previous one when cycling through them, both on GUI as on device (Dwarf).
Browsing through my presets, each with a different IR’s loaded ( A,B,C,D,E,F,G…), I made presets with the corresponding names A, B, C etc.

when cycling through my presets, I noticed that C sounded like B and F sounded like E etc.
By naming the presets like the IR’s, I thought I couldn’t mix’em up, right?

I tried editing but my changes don’t get saved.
Then I tried to delete the “faulty” preset but the preset doesn’t disappear
Renaming didn’t work either. No dodgy character were used in naming them.
Even after deleting and adding the plugin again, the problem re-occured.

How to reproduce

  1. I used the player to play a dry DI guitar signal in a continuous loop to test my chain without a guitar attached.
  2. Add the MOD IR loader to your chain and make sure some IR’s are in your folders under the IR’s on the filesystem
  3. GUI: in the config of the MOD IR Loader pluging; select an IR and save a preset
  4. select a different IR and “save as”;
  5. repeat steps 2 and 3 until you have about 7 or more items in your preset list
  6. while managing your preset list, try to rename, delete or change the selected IR +(save) the preset.

Expected/suggested solution

deleting a preset should delete the item at all times
renaming the item should rename it at all times
Saving should save the preset at all times

Additional information

Device: Dwarf
Version: V1.11.0.2591
Device serial: MDW01P01-00755
OS and Browser: Win10 - Chrome Version 97.0.4692.71 (Official Build) (64-bit)

Have you deleted or renamed files that the presets refer to?

No I haven’t touched them;
No rename, delete, move or any manipulation whatsoever.
This all happened on a set of files I haven’t touched for a while, many reboots ago.

The files are organised in one level subfolders
in my folder for cab IR’s I have folders, I have folders called Framus, Mesa, Fender, … with in those folders a bunch of IR files

1 Like

I didn’t forget this @LievenDV, but was waiting on the update to be released.
Did it fix this issue that you were reporting?

1 Like

There are some issues with preset renaming and file handling, we did some small fixes for it in v1.11.1 but more will come soon.


I saw progress already! Many thanks!
I felt honored to have contributed to the experience :smiley:


Shouldnt that be expected? If there are issues/bugs reported by users, we will do our best to fix them. Sometimes the fix is quite involved so we need to plan specifically for it, but small stuff is patched up quite quickly I think.