Mod Footswitch X4 not always recognised by Mod Dwarf


I have my Mod Dwarf and X4 Mod Devices Footswitch on a pedal board together. The Footswitch is always plugged into the Control Chain socket on the back of Dwarf.

When the Dwarf powers up, so does the Footswitch - but randomly it appears not to be recognised by the Dwarf so foot switch assignments on my selected pedalboard are not shown on the Footswitch screens (which continue to show the defaul ‘Foot #1’ etc displays).

When this happens (which isn’t always) I have to cycle the power on the Dwarf - sometimes several times - before the Footswitch is recognised.

How to reproduce

1.Footswitch is plugged into Dwarf which is powered down.
2. Power up the Dwarf
3. That’s it - sometimes (about 60% of the time) the Footswitch powers up but does not ‘connect’

Expected/suggested solution

I would expect the Footswitch to be detected every time

Additional information

Open the controller menu (hold left knob down), navigate to Info > Versions and write down here the version.

  • release: v1.11.5.2837

(Footswitch shows version 0.4.1)

Also provide some information about your system if possible.

Not relevant (so far as I can tell - but)

  • Operating system: Windows PC
  • System version: Windows 10
1 Like

We have experienced this as well, it is fixed in the upcoming v1.12 as far as we can tell.
There are quite substantial changes behind the scenes in v1.12, so we cannot simply backport as bugfix.
It will be out in a couple of days as release candidate.


Sounds encouraging - thanks for the info…


I’m having the same issue as Matt. I tried turning off the Dwarf a couple of times but the footswitch still doesn’t work properly (though I can see it in the web interface under CC devices). Even tried with a different cable.
Prior to this morning it had been working fine for months.
I updated to v1.12.0.2949 but that still hasn’t fixed it :scream:

1 Like

I have the same issue here.
Only one mod footswitch plugged and it’s not alway recognise by thw dwarf.
Sometomes it loose the connection when assigned to looperlative.

1 Like

@dncrash are you using only one MOD Footswitch or multiple?

1 Like

Just one.


So if I understood well it was the 1.12 breaking it, right?
@falkTX do you have any idea what can be happening?

1 Like

No it just stopped working before upgrading. I only upgraded to 1.12 after it wasn’t working because I saw the message from falkTX saying there’s a fix in v1.12.

Ah :man_facepalming: I figured it out. The assignments were wiped from the mindis somehow. After reassigning the buttons it works as expected. Don’t know how they got wiped, I have been using the same pedalboard as before. Anyway glad it works and sorry if I wasted anyone’s time.


Happy that you sorted it out @dncrash.
Maybe you updated the mind (?). It’s not exactly what should happen when you update plugins, but sometimes it can happen.

1 Like