Mod Dwarf web server not responding?

I don’t know what has changed, I’ve not had time to plug into the Mod Dwarf for a few weeks. So return to it today and it’s not communicating with my web browser, (Firefox running on Ubuntu 20.04). So maybe there’s been a browser upgrade in recent package updates so I decide that I’ll cut the web browser out of the equation and just use the ‘wget’ command from the terminal window. I get a message from the command to say that it’s using an existing connection and waits for response that never happens.

I’m confused by the “using existing connection” so I try wget with “–no-http-keep-alive”. That clears the “using existing connection” status but I’m still not getting a response to the page request. I can ping but the Mod Dwarf web server is not responding. My ‘wget’ command:

$ wget --no-http-keep-alive
–2021-11-13 20:02:36--
Connecting to… connected.
HTTP request sent, awaiting response… 302 Found
Location: /index.html?v= [following]
–2021-11-13 20:02:36--
Connecting to… connected.
HTTP request sent, awaiting response…

Got it my active pedal board was frying the web server. Sorry, sorted


Hi. I just received my Dwarf yesterday! I’m really excited to dive into it and see how I can use it. I, too, am having NO success getting to the browser interface. I tried using both the URL and the IP address. With the IP address, I get a “taking too long to respond” message (I use Opera but I got the same message in Edge); with the URL, the page just goes white. ANY suggestions would greatly be appreciated.

How are you connecting it? Via USb?

1 Like


Is there another way to connect to my computer?

What OS are you running on your computer?

1 Like

Windows 10 Pro, Version 21H2 Ryzen 5 3600 processor, 32GB of RAM

With the ModDwarf powered up and connected to your computer via a laptop you should have a new network interface. I’m not sure how to do that in Windows, but I assume you can go to the control panel and look at the networks. So you should have a wifi connection, or Ethernet or whatever, and when you plugin the USB connector of the ModDwarf you should see a new network interface.

From the terminal window you could run ‘ipconfig’ if I remember correctly.

Can you check you have a new network when the ModDwarf is connected

1 Like

There are some steps in Troubleshooting - MOD Wiki for when things do not go right in Windows.
The most typical scenario is Windows assuming it is a parallel communication device, rather than an ethernet communication device.

Alternatively, you can switch the USB mode in the Dwarf device settings from “USB Net” to “USB Net + MIDI (Windows)” which contains a special mode known to work in Windows 10 (and as an extra, the Dwarf then acts as a USB MIDI device)


Thanks for pointing me to the wiki - it gave me the answer I needed.

1 Like

This helped me a hell of a lot. I don’t normally use Windows, but my wife no longer wanted her Win10 laptop, so I thought it would make a reasonable music computer. Oh boy. Unlike my Mac would it see the MOD Dwarf properly, not a chance. I spent fruitless hours trying to get it to connect - wouldn’t even update drivers! So I tried searching the Forum and found this thread, and your post. When I read your comment about changing the USB settings to NET + MIDI (Windows) I could’ve slapped myself with a kipper. I remembered seeing the selection when trying to get my MIDI set up. Set it to that, and rebooted - bang, Windows saw it straight away properly. Cheers!