Mod Dwarf: Serial MIDI not working? USB Midi not working?

Hey all, I’m having some issues with the Mod Dwarf and MIDI in general.

I’m trying to send CCs via Serial MIDI Out. I’ve tried multiple different generators with every possible channel.

I’ve enabled Midi ports in the web-gui, but I can’t seem to get the actual CCs or notes to transmit via Serial MIDI Out to my external synths. I’ve just been trying to get some notes to play by sending the MIDI sequencer note data to Serial MIDI Out. None of my synthesizers are receiving anything.

So… questions:

  1. Are the Serial MIDI ports functioning? I’m using standard adapters (DIN-TRS) that are supplied with most modern synths but I can’t seem to get anything to come in or go out from the Mod Dwarf.

  2. I tried connecting my Keystep Pro to the MIDI in and then routing the signal in web-gui from Serial MIDI In to Serial MIDI Out but it does not send the Keystep Pro data through. How does one do this?

  3. I have a Novation LaunchControl XL that works well via USB MIDI with the MIDI Learn and I can control the Dwarf parameters with it. I have another template for the LaunchControl to control my external synths, but similarly to question 2 I’m unable to transmit the data from LaunchControl MIDI In to Serial MIDI Out - nothing is going through.

Appreciate any help I can get! Thanks!

1 Like

DIN-TRS is not actually “standard” to my knowing, vendors failed miserably to unify TRS midi, several different pinouts are existing out there, and you need to be sure that your particular adapter is the one compatible with your particular device, as you can expect some catch here.

Dwarf should use “type A” according to another TRS forum thread. (TRS to MIDI pinout - #9 by malfunction54)

If I had to troubleshoot that, I would start with taking din pinout diagram, type A trs pinout diagram, and test the actual adapter wiring with multimeter beeps to be sure that everything is connected properly.

Also, I do not see mentions of MIDI Display plugin in your post. If you have not tried it yet, you can route MIDI data to it, to see in webui if the input part works at least.


Hi, thanks for replying!

This seems to have been the cause. I was able to find type A DIN-TRS from my boxes and everything is now working as intended. Thank you!


You can check device pinouts on this website:

Vast majority uses type A, however dealing with exceptions can be quite annoying.