Mod Duo X USB issue

Hello everyone.
I don’t know if it’s related to my problem but the other day I wanted to install Neural Amp model on my mod duo x. It restarted on its own.
mod duo x usb issue 3

Since then I can no longer connect it via usb so I can’t do anything.
I see the yellow exclamation mark in windows hardware properties which is never a good sign.
mod duo x usb issue
mod duo x usb issue 2

Apart from that the Duo X mod works correctly but only Midi USB is recognized. I have of course tried on several computers and the result is the same. Everything was up to date before this problem. Do you have an idea? A reset?

did you try on windows machines only?
I wonder if the net+midi usb mode got changed, so that it no longer triggers the windows-specific mode. something worth double-checking.

Thanks @falkTX to read this on this sunday.
I tried with windows machine only with different browser (Google, firefox) and my usb to wifi router that was perfectly working with my dwarf and the mod duo x.
Mod duo x USB setting was on network only when this problem arrived. I switch it to USB and Midi and it’s the same problem.
What is strange is since few days the connection was not stable until it doesn’t work at all now. Like if something was dying. I hope not.
Of course I tried different cable too and I can’t use bluetooth connection because it doesn’t work on my Mod Duo X, I already send it to RMA for this blutooth issue that wasn’t solved.

Strange thing too, connecting the mod duo X to my computers can sometimes result with BSOD!

what is getting me nuts is that I just bought the 3 aida dsp simulator and I can’t use them :smiling_face_with_tear:

One more precision. My mod dwarf is perfectly working in usb with both of my computers. So the issue is not with the driver, the computer or the usb cable

very weird, main question then is… can you get the unit into recovery mode where the usb works as mass storage? if that fails then I am afraid usb device mode is really broken.

if it does work, try reinstalling 1.13.2 again

EDIT: regarding the duox, please send a reply on the email conversation about it, @jon was taking care of it before with me, but at this point I have no idea what the status of that ended up being…

Thanks @falkTX
I tried.
I can see the mod duo x as a storage device when I start it in restore mode.
I updated it and I could open the mod webpage only once during 10 seconds before it lost connection.
Now it doesn’t work anymore…

It works again
But the loading page is slow…
Al seems normal
mod duo x state

Here’s what I get until few minutes trying to edit my pedalboad.

After trying to unplug and plug it again to my computer here’s what I get.

That’s super weird.

Maybe an obvious question, but does is your computer fully updated?

Yes my computer is always up to date. And I have the same issue with my notebook!
I love the mod devices possibilities and sounds. But I’m really thinking about solding all my pedalboard and go for a helix or something that doesn’t bug…

the problems started when i tried to install Neural Amp model plugin.
mod duo x usb issue 3

Does someone here already tried this plugin with a mod duo X?

I just installed it on my DuoX and can load it on my pedalboard (I do not use Windows btw).

1 Like

Ok so I think my unit need a refresh
Should I do a factory reset? I don’t know if it’s possible, I think it is…

@Julien, if I ever own a business, I want you to be my customer. Really. With the amount you’ve invested in Mod thingies and extras, you’d have a super spanky Helix unit by now.

I’ve invested this amout in mod audio gear because I love this machine, it’s flexibility.
But I see now it is a fragile technology and too prone to computer bugs. Not reliable enough unfortunately.

Yes, I use NAM with DuoX, till now no problems. At this point NAM is my main tone generator since DUOX is capable of loaing every profile and still there is about 50% of CPU for other goodies.
I use windows 11.

Thanks @Lukasz
So it was just a coincidence that my mod duo x crashed along with installing NAM.

I do not have any issues with NAM as well, so if there is a correlation, it is not that direct.

By the way, have you tried to choose different pedalboard with hardware interface?
Maybe something gone wrong with particular pedalboard?