Mod Duo X makes pops every few seconds

Im the happy owner of a Mod Duo X.

Im hearing some small pops every few seconds. Sounds like if you tap gently on a SM58 microphone or something.
Not very loud, but annoying if there is complete silence.
It stops if Im pressing Hardware Bypass, but its still there if I make a new pedalboard and disconnects the cables so there should be no connected sound at all.

Im at version 1.9.3.

Any suggestions to how to fix it? Is it something that have to be fixed in the software or am I having a hardware issue?

Thanks in advance

Hi @theohjorth,
Glad that you are an happy owner of a DuoX :slight_smile:

Regarding your issue, I’m not so glad that you are facing it.
I have a question: was this happening before or start happening after the upgrade to the version 1.9.3?

I must admit that I can’t recall if it started before or after. :thinking:
Its quite subtle, but its there and I can see it on my mixer.
Ive also tried to disconnect the cables from the inputs on the device, but no change there

I’m not a Mod hardware specialist but I’ve resolve a lot of issues in the past when I had my post production studios.
If you don’t know what hardware problem inside the box could cause this issue you must first check all possibilities arround the box.
First question:
How are you listening to your Mod Duo X? With headphones? thru an amp? thru a sound card?
If it’s thru a soundcard, do you use the jack output or the spdif output?

1 Like

Hi Julien, thanks for your answer :slight_smile:
Its connected thru jack cables from the output to my SD16 to my Midas M32R.
Ive tried changing inputs with other hardware in the SD16 but the sound is still there - only from the Mod Duo X.
The fun thing is that the sound is stopping when Im using Hardware Bypass on the duo x.

So the sound is still here when nothing is connected to the input? That’s right?
Did you tried a other power supply?

Yes, its still there. No, Im not sure that I have another power supply that fits :thinking:
Could that make a difference? Even though the sound stops when the Hardware Bypass is on on the mod duo x? :slight_smile:

Yes it could.
You says the sound stop when the hardware bypass is activated. So I presume that’s the unit itself that generate the sound.
So now you must found what can cause this sound in the unit.
It could be a power supply problem.
It could be interference, with the screen backlight or with a home appliance for example.
It could be, but I hope not, a faultly motherboard or a faulty RAM. This sound is what you get when you’ve got a faulty RAM in a computer.
Perhaps the more easy thing to do first is to set screen backlight of.
Could you try this?

1 Like

How do I do that? :slight_smile: I can find the Display Brightness and Display contrast, but Im not sure where to turn the backlight off :slight_smile:

Yu must set brightness to minimum, it will power off backlight. That’s how it works on the Mod Duo, I presume that’s the same on Mod Duo X.

It is. But still se same pops :thinking:

So you should try another power supply but you haven’t, right?
So let’s try something else.
First have you tried to listen with headphones? That was the first question I should ask you. Is the sound still here?

1 Like

Yes, but only when I turn hp level to 100%. And then I can hear it really soft.
Maybe I just have to turn down the output level on the main outputs and gain them some more on my mixer to avoid hearing the click

Yes you can try that :+1:
If it doesn’t work you can try to move you Mod Duo X to another room or try to plug it to another plug. perhaps something make interferences with it.

1 Like

Thanks a lot, @Julien for all the help :slight_smile:
@theohjorth let us know if @Julien suggestions helped you solve the issue.

1 Like

A bit silly, but I had second spaced pops on my Mod Duo too. It was caused by the bluetooth dongle I attached to it and happened every time the dongle would flash it’s little blue led.


Ive tried to lower the volume of the outputs but its still there, Ive tried to disconnect the midi cables and usb cable Ive connected but still there.
I will try to move it later today and see if it helps :slight_smile:

1 Like

Keep us posted on the results of your attempts :wink:

I just tried connecting it to a plug with nothing else inserted, but still the same :slight_smile:

Like said Azza, have you tried to disconnect the bluetooth dongle if you have one?