MOD DUO X hardware controls freezed

My MOD DUO X hardware does not respond, the software seems ok

When I start the device, both displays light up, Left shows “MOD DUO” the right on “X”. But after that nothing more happens. None of the buttons light up. Anyway I can pass sound through the device, and even connect it with the web interface, edit stuff, change pedalboards and so on. Only the hardware elements seem dead. The LEDs for input and output signal are working.

Additional information

System: Mod Duo X running from July 26
Kernel aarch64, release 4.9.123-rt125-duox version #6 from July 26, too.

Dear @Marc,

Please send us an email to and our tech team will help you with that.

See if changing pedalboard to ‘new’ and doing a power cycle makes the device screen come up again.
Maybe the “last” pedalboard is causing some issue… ?

1 Like

Thanks for the offer, but it finally works as intended again. Don’t know exactly why, but I hope it won’t return…

The same thing happened once with my DuoX. I suspected it was because the FCB1010, which I had saved in the preset, was not connected when I switched on. Can that be a reason? (Is there a debug mode / logfile where you can see this?)
After a restart everything was OK again.

I had nothing connected to the Duo X.

Please try 1.9.2, we have a fix for that.

If it still happens, please tell us, so we have to keep digging.

1 Like

Hi i got a problem after Updating to 1.9.2

The Mod Duo X Bootscreen shows all the time but the Duo X is Online because i can open the GUI.
Ive updates The Mod Duo several times without any problem but after i restart the Duo X 2-3 Times the bootscreen always show.

i also tried
hmi-update /usr/share/mod/controller/mod*controller.bin

than it works for 1-2 restarts and next day same thing :frowning:

best regards

I’ve had this bug, in two different ways (with the latest software update) - firstly exactly as Marc says and then a version where when trying to load the pedalboard on screen, it got to a certain point then thr lights on the Duo X flashed and the laptop screen says “disconnected”. Unplug and replug resulted in the same thing, the way I got round it was loading the system screen straight away and clicking reboot. That time everything loaded properly…?

This still happens with my ModDuoX, even with the update to Release 1.9.2. :frowning:

Is something being done for or does the problem only occur with a few users?
You are welcome to use ssh to login to my ModDuoX and have a look and debug.

I was experiencing same problem. Re-flashing firmware solved this issue.

1 Like

After the successful update of mod*controller the ModDuoX still does not start correctly. It hangs at the Mod Duo X boot screen.
How can I reinstall the operating system? I can’t get it to work as described on the Wiki page. Pressing and holding the “left endless-knob and the 1st button from the bottom-left” does nothing.
Or did I get something wrong?

Yeah, this is tricky part. I just rebooted it so many times, until it loaded up. Also I did tick/untick restart controller in the advanced menu. If you have successfully rebooted it - re-flash. Weird, I know.

1 Like

I managed to reinstall as described in the Wiki page. :smile:
But everything is the same as before, it hangs at the Mod Duo X boot screen. :frowning:

Oh so you have to use the Factory Reset Images. ^^
Now everything works again. \o/

1 Like

That does not make any difference. You are just seeing random behaviour and assuming a connection where there is none.
We are working on a potential fix, coming very soon in a v1.9.3 release.

1 Like

Guys, please help me. My Mod Duo X just freeze after updating to 1.13. I followed all the instructions to restore back but it still stuck by pressing the both the buttons and plug the power, it just stuck in the restore more. It says “starting restore mode, please wait” and nothing happens. Please HELP!!!

contact support for such matters please, via

please specify your unit serial number, and any other information that might be relevant.

I’ve done that this morning but still haven’t got a reply back yet. I really need this pedal to work again.