Mod Duo stuck at splash screen (x64, Win10)

Hello! So I have a Kickstarter Edition Mod Duo, It has worked for a few years now ever since I got it, I keep it on my pedal board and my pedal board stays in one place at all times. Just recently I plugged it into my computer and the Mod Duo splash screen comes up and just stays there. I’ve tried powering it off, holding the left knob and switch, holding the tiny button in the hole and powering it on, every possible troubleshooting method on the Mod forums, I’ve tried it. I’m in the IT as well so I know I followed the instructions for linux/mac and commands correctly… (just felt the need to specify that.)
An additional issue is that when I plug it into my computer it shows up as an unknown usb device and the drivers on the troubleshoot page don’t work when I select them inside of device manager. Would anyone know what my next steps would be? or if there is a fix I’m missing?

Hello Jake Wenzel aka @E_Corp !

Did you get help (yet)?
You as an IT expert might have more experience in Win10 than me. I’m on WIndows 7 64bit and every now and then I help people with teamviewer (remote desktop) sortiing peoblems with Win10 out. Maybe Win10 just sent some commands over USB when the mod duo booted? Just guessing here.
The last time I put my mod duo in another usb jack win7 wanted to install new drivers, didn’t find some and finished. Fortunately it sorted out so I am a lucky guy.
Did you find a solution for this problem? Other Windows users might get into the same difficulties as well…

I find it awful that MS even can interrupt business computers for days while managing updates…
A friend of mine is CEO of an IT engineering company and he has to rant sometimes…
Greetings and God bless,

Hi @E_Corp. I suggest you try the follow steps so we can isolate the issue:

1 - Turn off your Duo and disconnect all cables.
2 - Turn on the Duo (still no cables - other than the power cable)
3 - Once the Duo is up try using the built-in menus see if it’s responsive
4 - Connect the USB cable to your computer
5 - Open the browser and navigate to the mod-ui ( or modduo.local)

If this doesn’t work, disconnect the USB cable and repeat steps 4 and 5.

Do this whole process at least twice.
If nothing works, try changing the computer. If you still don’t get it working, try a new USB cable.

Let me know how it goes.

solution :

1 Like