Mod duo randomly not booting

I’ve had my mod duo for a while now, I started seeing this on older firmware but I’m currently on the latest 1.10.

When I turn my duo on, sometimes it boots up first time, however the majority of the time that I turn it on now it gets stuck at the logo screen and will sit there forever. If I turn it off/on then sometimes it will boot the 2nd time but more recently it takes about 4 to 5 attempts before it boots. I can tell if it will boot correctly because after around ~20 seconds I’ll see the output lights flash green.

I’m assuming it’s getting stuck at the point where the bootloader tries to load the actual firmware, considering that this has persisted several firmware upgrades I’ve assumed it’s not worth doing a manual reflash.

Is there an easy way to debug this? It appears to be getting worse, but it got pretty bad before and then started working on first power on for ages, so I was hoping it would go away again. :slight_smile:

I’m in the UK if that has any implications for power, Once booted it works fine.

I would guess this is due to your unit being one of the older ones with NAND instead of MMC.
A while ago there were upgrade steps for the Duo kernel so the NAND flash data is more reliable.
Did you do those at some point?

Really sorry for the delay in response, I’ve just not been able to spend much time on the guitar at the moment… I’m certain that I did the nand upgrades as I remember being a little surprised that mine was a unit with nand as it wasn’t that old. Would it do any harm if I were to dig out those instructions and retry them?

Only if somehow the steps didn’t work.

Booting the unit and going into the web interface advanced settings should make it clear.
On the top-right it says the kernel version. 3.4 is old one, 5.4 is the new stuff.

1 Like

Thanks for the quick response, in that case it seems that it’s all up to date…

Machine: armv7l
Release: 5.4.38-rt21-modduo
Version: #13 SMP PREEMPT_RT Tue Mar 30 14:07:38 UTC 2021

Yes, that is all fine.

Have you tried a factory reset?
Basically the same as manual update files, but using the links from Factory Reset Images - MOD Wiki

I’ve just tried to do a factory reset, the install seemed to work fine, but when the install finished and rebooted the mod duo failed to boot, it’s stuck at the ‘mod duo’ screen.

I’ll try rebooting it a few times and see if it comes back online at all like it was previously.

On about the 4th power cycle it’s managed to boot, so I can continue to use it at least.

1 Like

Thanks for letting us know

Sorry but this is not solved! My duo still will not boot most of the time, it’s just that after the complete firmware reset it appeared to not want to boot at all but on the 4th power cycle it finally booted. I tried powering it off this afternoon and my duo will still not boot most of the time, so the problem remains.

If it is the nand at fault, can I change the bootloader to use alternative media?

Sorry, I misunderstood your message reporting that you managed to boot it on the 4th cycle so I thought it was solved. My bad, already fixed.
Have you manage to boot it, have you already backed up the device and made a factory reset as @falkTX suggested you before?

For making a factory-reset, if the data was not backed up it is gone now anyway.
Seems like a coreboard replace is needed here.

Did @pjd already did the factory reset or he couldn’t do it because the device was not booting?

Hi, Sorry if I’ve not been clear.

before the factory reset:
The Duo would not always boot, getting stuck at the Mod Duo logo screen, but it would usually boot after a few power cycles

During the factory reset:
To carry out the reset I was able to get the Duo to boot after a few power cycles. I was then able to do a factory reset from the web interface as usual, the reset process was fine, but when it rebooted at the end of the reset the Duo froze at the Mod Duo logo screen

After the reset:
The Duo exhibits the same behaviour as before the reset, it hangs at the logo screen, but after some power cycles it will boot successfully

I’d really rather avoid sending the Duo for repair unless I can avoid import duties on the repair (I’m in the UK) and even then if there’s some way I can hack this to work a bit better until my dwarf arrives (I think I chose the December option eek!) then I’d prefer to do that. If I can get access to the bootloader can I make it boot from usb? I seem to remember serial console access requires some soldering…

I would suggest you to write your issue to
You can even link this thread so you don’t spend time re-writing and explaining everything.

This is just for us to keep better track of the issue and find a solution that fits all your needs (including the import duties)

Edit: write if you didn’t do it yet. If you did we will get back to you asap

I’m almost wondering if perhaps your Duo isn’t getting enough current? what kind of power supply are you using?

1 Like

I’m using the supply which came with the mod, 12v 2a

Ok, but I suppose this is then many years old already. You do not happen to have another 12v 2a (or more) psu that you can test with?

1 Like

A different power source is worth checking. FWIW I’ve experienced similar problems with my Duo and it happens when connected to my 1SPOT isolated power supply (implying the problem lies with the device hardware or bootloader)